Bug 426782 - Failed to print document: Too many failed attempts
Failed to print document: Too many failed attempts
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
8
powerpc Linux
low Severity low
: ---
: ---
Assigned To: Marek Kašík
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-26 04:16 EST by David Woodhouse
Modified: 2008-05-20 11:04 EDT (History)
1 user (show)

See Also:
Fixed In Version: gtk2-2.12.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-20 11:04:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2007-12-26 04:16:15 EST
Since upgrading to Fedora 8, printing from GNOME applications only ever gives me
a dialog box saying 'Failed to print document' 'Too many failed attempts'. I'm
given no indication of _what_ has actually failed, and printing works fine if I
print to a file and then use lpr.
Comment 1 Paul Howarth 2007-12-26 05:12:26 EST
gnome-libs is the Gnome-1 legacy library; for the vast majority of Fedora 8
Gnome apps, you'll be using libgnome or one of its current companion libraries
(I'm not sure which one myself), and should report the bug against those.
Comment 2 David Woodhouse 2007-12-26 06:21:28 EST
Or maybe against gtk2, which is where libprintbackend-cups comes from.
Comment 3 David Woodhouse 2007-12-26 06:38:34 EST
cupsd says:

E [26/Dec/2007:11:32:59 +0000] cupsdReadClient: 24 IPP Read Error!


[pid 25261] recv(24, "POST /printers/2430DL HTTP/1.1\r\nContent-Length:
0\r\nContent-Type: application/ipp\r\nHost: localhost\r\nUser-Agent:
CUPS/1.3.4\r\n\r\n", 2048, 0) = 125
[pid 25261] write(3, "E [26/Dec/2007:11:36:41 +0000] cupsdReadClient: 24 IPP
Read Error!\n", 67) = 67
[pid 25261] write(25, "localhost - - [26/Dec/2007:11:36:41 +0000] \"POST
/printers/2430DL HTTP/1.1\" 400 0 unknown-0000 -\n", 97) = 97
[pid 25261] send(24, "HTTP/1.1 400 Bad Request\r\nDate: Wed, 26 Dec 2007
11:36:41 GMT\r\nServer: CUPS/1.2\r\nContent-Language: en_US\r\nUpgrade:
TLS/1.0,HTTP/1.1\r\nConnection: close\r\nContent-Type: text/html;
charset=utf-8\r\nContent-Length: 344\r\n\r\n<!DOCTYPE HTML PUBLIC \"-//W3C//DTD
HTML 4.0 Transitional//EN\"
\"http://www.w3.org/TR/REC-html40/loose.dtd\">\n<HTML>\n<HEAD>\n\t<META
HTTP-EQUIV=\"Content-Type\" CONTENT=\"text/html; charset=utf-8\">\n\t<TITLE>400
Bad Request</TITLE>\n\t<LINK REL=\"STYLESHEET\" TYPE=\"text/css\"
HREF=\"/cups.css\">\n</HEAD>\n<BODY>\n<H1>400 Bad
Request</H1>\n<P></P>\n</BODY>\n</HTML>\n", 559, 0) = 559

Probably due to 'Content-Length: 0'? 
Comment 4 Marek Kašík 2008-05-20 09:43:30 EDT
Hi David,
could you post the version of the installed gtk2 here? And could you also post
architecture (ppc vs. i386, 32bit vs. 64bit)?
Is the problem still present with recent updates?

  Thanks

    Marek
Comment 5 David Woodhouse 2008-05-20 10:17:56 EDT
Not sure about F8+updates, but this no longer seems to be happening in Fedora 9.
It was on ppc (64-bit machine, but 32-bit userspace).
Comment 6 Marek Kašík 2008-05-20 11:04:53 EDT
Hi David,
this looks exactly the same as upstream bug #485662
(http://bugzilla.gnome.org/show_bug.cgi?id=485662) which was fixed in version
2.12.2.
Original version was 2.12.1-5 in F8. Actual version is 2.12.8-2.
Actual version in F9 is 2.12.9-5.
So, I'm closing this bug with resolution CURRENTRELEASE.

  Thank you for reporting this bug

    Marek

Note You need to log in before you can comment on or make changes to this bug.