This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 426917 - Network manager doesn't work with 2.6.23.9-85.fc8 kernel
Network manager doesn't work with 2.6.23.9-85.fc8 kernel
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 428177 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-28 07:34 EST by esqmo
Modified: 2008-06-27 20:05 EDT (History)
5 users (show)

See Also:
Fixed In Version: kernel-2.6.25.6-27.fc8.x86_64.rpm
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-27 20:05:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description esqmo 2007-12-28 07:34:42 EST
Description of problem:

Network Manager works fine on 2.6.23.8-63.fc8 but when I change to kernel
version 2.6.23.9-85.fc8 it no longer picks up my wireless connection.

Version-Release number of selected component (if applicable):
0.7

How reproducible:


Steps to Reproduce:
1.Start service NetworkManager
2.Asks for password
3.Picks up connection! (:
4.Restart to 2.6.23.9-85.fc8 kernel
5.Start service NetworkManager
6.No connections other than ethernet ):
  
Actual results:
No connection

Expected results:
Connection (with password request)

Additional info:

nm-tool output:

NetworkManager Tool

State: connected

- Device: eth0 ----------------------------------------------------------------
  Type:              Wired
  Driver:            r8169
  Active:            no
  HW Address:        00:13:D3:EE:B8:31

  Capabilities:
    Supported:       yes
    Carrier Detect:  yes
    Speed:           100 Mb/s

  Wired Settings


- Device: wlan0 ----------------------------------------------------------------
  Type:              802.11 Wireless
  Driver:            zd1211rw_mac80211
  Active:            yes
  HW Address:        00:14:7C:A9:5A:33

  Capabilities:
    Supported:       yes
    Speed:           48 Mb/s

  Wireless Settings
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points(* = Current AP)
    *HomeWireless:  Infra, 00:14:7C:B8:C2:08, Freq 2437 MHz, Rate 54 Mb/s,
Strength 76 WEP

  IP Settings:
    IP Address:      192.168.1.2
    Subnet Mask:     255.255.255.0
    Broadcast:       192.168.1.255
    Gateway:         192.168.1.1
    DNS:             192.168.1.1

------------------------------
For a CRUSB10075 3Com USB adpater
Comment 1 Jon Stanley 2008-01-09 15:30:43 EST
*** Bug 428177 has been marked as a duplicate of this bug. ***
Comment 2 Jon Stanley 2008-01-09 15:32:32 EST
This is really caused by the lack of the zd1211rw_mac80211 driver in the kernel,
not by NM
Comment 3 John W. Linville 2008-01-09 15:41:37 EST
The driver is there, just renamed.  Later (starting with -86.fc8) F8 kernels 
have a module alias that corrects the issue -- it is shame that -85.fc8 got 
pushed and nothing else has been pushed since.

Either remove all references to zd1211rw-mac80211 (possibly replacing them 
with reference to zd1211rw) in /etc/modprobe.conf or simply use a newer kernel 
from koji:

   http://koji.fedoraproject.org/koji/buildinfo?buildID=30116
Comment 4 Jon Stanley 2008-01-09 15:53:53 EST
Thanks John - you're too fast for me :)  I was about ready to research the same
thing since I vaguely recalled something about it :).  Could the reporters
please download and install (rpm -ihv) the kernel in the link above, and report
back here?
Comment 5 Tomi Hautakoski 2008-01-09 16:07:47 EST
I had no network related stuff in modprobe.conf so I installed the koji kernel
-> it works! From my point of view this case can be closed. Thanks to both of
you for the quick response.
Comment 6 Jon Stanley 2008-01-09 16:15:18 EST
Alright, I'll leave this open, but change to RELEASE_PENDING so that others can
find this without searching through closed bugs.
Comment 7 Joe Orton 2008-01-17 13:54:38 EST
Comment 3 seems to imply the driver is still there in -85 but under a different
name; I can't see it.  There is no zd1211rw of any kind; diffing the
modules.usbmap shows the zd1211rw-mac80211 aliases are simply removed; not sure
how any changes to modules.conf would help.
Comment 8 John W. Linville 2008-01-17 14:42:11 EST
Sorry, my mistake.  You'll have to use a newer kernel.
Comment 9 Jon Stanley 2008-01-17 16:14:00 EST
You can get a newer kernel here:

http://koji.fedoraproject.org/koji/buildinfo?buildID=31800

if you don't want to wait for the next update
Comment 10 Jon Stanley 2008-06-27 20:05:23 EDT
This was fixed a long time ago and update released. We're now in 2.6.25 land for
F8. Closing.

Note You need to log in before you can comment on or make changes to this bug.