Bug 426974 - TAHI--DNSv6--can't receive DNS message
TAHI--DNSv6--can't receive DNS message
Status: CLOSED DUPLICATE of bug 428446
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: bind (Show other bugs)
5.1
All Linux
urgent Severity medium
: rc
: ---
Assigned To: Adam Tkac
:
Depends On:
Blocks: 253764
  Show dependency treegraph
 
Reported: 2007-12-29 01:37 EST by Zhiyong Wu
Modified: 2013-04-30 19:37 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-14 05:02:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zhiyong Wu 2007-12-29 01:37:40 EST
Description of problem:

  When having DNSv6 tests in the server mode,we found that TN can't receive DNS 

message in some scenarios.

Version-Release number of selected component (if applicable):

  kernel-2.6.18-53.el5

Software Environment:   
  Testee(NUT):   
    RHEL5 
    Kernel:2.6.18-53.el5 
   
  Tester(TN):   
    FreeBSD6.2
    v6eval-3.0.12.tar.gz
   
TAHI package:    
  DNS_Self_Test_1-1-1.tgz

How reproducible:
  every time

Steps to Reproduce:    
  1. Configure TAHI test environment.     
  2. Run the TAHI test suite     
  3. After the test completes, check for the results 
  
Actual results:

   NUT can't receive DNS message.

Expected results:

   NUT can receive DNS message.

Additional info:
  
   please refer to

   NUT is set to be the server mode
 
http://focus.brisbane.redhat.com/~zwu/RHEL5.1-Server-20071017.0/20071220/DNS_Self_Test_1-1-1_server/index.html

   (1) 10	PTR type

   (2) 44	Caching wildcards queries

   (3) 46	Zone maintenance and transfers

   (4) 47	Zone transfer is not completed case

   (5) 54	Cache data vs authoritative data

   (6) 101	Broadcast/Multicast query

   (7) 104	Caching of temporary failure

   (8) 105	Continue to provide service

   (9) 122	An IXFR client sends an IXFR message through NOTIFY mechanism

   (10)123	A master ignores message if fields are not to be filled with binary
zero (0)

   (11)126	Primary Master sends a NOTIFY query

   (12)127	A master continue to offer name service during the NOTIFY transaction

   (13)128	A slave sends a once a NOTIFY request until timeout

   (14)129	A master periodically sends a NOTIFY request to a slave until timeout

   (15)130	A master periodically sends a NOTIFY request to a slave until ICMP
message indicating

   (16)131	A master periodically sends a NOTIFY request to a slave until a
NOTIFY response is received

   (17)135	A master receives a NOTIMP (unimplemented feature error) message

   (18)136	UDP Source Address Selection

   (19)140	Treat Differing TTLs from non-authoritative source as error

   (20)141	Differing TTLs from non-authoritative source

   (21)152	Least reliability data should not return as answer (Authority section
from a non-authoritative answer)

   (22)158	Received with the most significant bit is set

   (23)201	PTR type

   NUT is set to be the server mode

http://focus.brisbane.redhat.com/~zwu/RHEL5.1-Server-20071017.0/20071220/DNS_Self_Test_1-1-1_client/index.html

   (1) 25	Returning of answer

   (2) 26	Returning of name error

   (3) 28	Encounters a CNAME

   (4) 30	Answer in local information

   (5) 32	Analyze the response (delegation)

   (6) 33	Analyze the response (caching delegation)

   (7) 34	Analyze the response (caching CNAME)

   (8) 36	Analyze the response (answer is invalid for caching)

   (9) 51	Message compression

   (10)52	Not depend on response in order

   (11)54	Invalid response (RRs are incorrectly formatted)

   (12)56	Invalid response (ID does not match)

   (13)61	Time out of cache

   (14)65	Caching of temporary failure

   (15)69	Caching of name error (NXDOMAIN)

   (16)72	Caching of no data (NODATA)

   (17)76	Resolver cache a server failure response

   (18)79	Caching of dead server indication

   (19)82	Caching of SOA record

   (20)87	Responders don't understand OPT RR

   (21)90	Returning of answer (w/o Additional Data section)

   (22)94	NXDOMAIN
Comment 1 RHEL Product and Program Management 2007-12-30 18:44:41 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 Irina Boverman 2008-01-04 14:19:37 EST
asking subhendu to verify this bug (tahi test)
Comment 7 Adam Tkac 2008-01-14 05:02:31 EST

*** This bug has been marked as a duplicate of 428446 ***

Note You need to log in before you can comment on or make changes to this bug.