This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 427035 - Pythion-gammu won't install, libGammu.so.2 needed, libGammu.so.3 is provided by gammu-libs
Pythion-gammu won't install, libGammu.so.2 needed, libGammu.so.3 is provided ...
Status: CLOSED DUPLICATE of bug 426848
Product: Fedora
Classification: Fedora
Component: python-gammu (Show other bugs)
8
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Xavier Lamien
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-30 09:21 EST by Russell Odom
Modified: 2007-12-30 10:28 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-30 10:28:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Russell Odom 2007-12-30 09:21:43 EST
Description of problem:
I can't install wammu, as it requires python-gammu, which in turn requires
libGammu.so.2. A recent release of gammu-libs now provides libGammu.so.3,
instead of libGammu.so.2, so the dependency is not available.

Version-Release number of selected component (if applicable): 0.22-3.fc8.x86_64

How reproducible: Always.

Steps to Reproduce:
1. yum install wammu
  
Actual results:
Dependency check fails to find libGammu.so.2

Expected results:
Install works!

Additional info:
[root@detritus ~]# yum install wammu
[...]
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package wammu.noarch 0:0.19-3.fc8 set to be updated
--> Processing Dependency: python-gammu for package: wammu
--> Running transaction check
---> Package python-gammu.x86_64 0:0.22-3.fc8 set to be updated
--> Processing Dependency: libGammu.so.2()(64bit) for package: python-gammu
--> Finished Dependency Resolution
Error: Missing Dependency: libGammu.so.2()(64bit) is needed by package python-gammu
[root@detritus ~]# rpm -q gammu-libs
gammu-libs-1.17.0-1.fc8.x86_64
[root@detritus ~]# rpm -q --filesbypkg gammu-libs
gammu-libs                /usr/lib64/libGammu.so.3
gammu-libs                /usr/lib64/libGammu.so.3.1.17.0
Comment 1 Xavier Lamien 2007-12-30 10:28:56 EST

*** This bug has been marked as a duplicate of 426848 ***

Note You need to log in before you can comment on or make changes to this bug.