This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 427084 - Named has to be restarted twice
Named has to be restarted twice
Status: CLOSED DUPLICATE of bug 426382
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-30 22:39 EST by Ray Todd Stevens
Modified: 2013-04-30 19:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-02 06:44:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ray Todd Stevens 2007-12-30 22:39:46 EST
Description of problem:

Since the last update I have been having a problem on my name servers.  
/etc/init.d/named restart has to be run twice to actually restart the name server.

Example:

[root@john etc]# /etc/init.d/named restart
Stopping named:                                            [  OK  ]
Starting named: named: already running                     [FAILED]
[root@john etc]# /etc/init.d/named restart
Stopping named:                                            [  OK  ]
Starting named:                                            [  OK  ]

Version-Release number of selected component (if applicable):

[root@john etc]# rpm -qa | grep bind
bind-libs-9.5.0-20.b1.fc8
rpcbind-0.1.4-11.fc8
ypbind-1.20.4-2.fc8
bind-chroot-9.5.0-20.b1.fc8
bind-9.5.0-20.b1.fc8
bind-utils-9.5.0-20.b1.fc8

-rwxr-xr-- 1 root root  6152 2007-12-19 11:58 named

How reproducible:

Never have seem it fail to fail.

Steps to Reproduce:

See example above.

Additional info:

This may be a duplicate of one or more of 426382 426613 or 417431 in root cause,
but I can't see how their patches apply in this case in addition it appears that
the patches are supposed to be in the revision I am presently running.
Comment 1 Adam Tkac 2008-01-02 06:44:14 EST

*** This bug has been marked as a duplicate of 426382 ***

Note You need to log in before you can comment on or make changes to this bug.