Bug 426382 - named is not running after last update
named is not running after last update
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
8
All Linux
high Severity high
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
: 427084 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-20 11:52 EST by Jan ONDREJ
Modified: 2013-04-30 19:37 EDT (History)
5 users (show)

See Also:
Fixed In Version: 9.5.0-22.b1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-06 20:13:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
messages (476 bytes, text/plain)
2007-12-20 13:14 EST, Marek Mahut
no flags Details

  None (edit)
Description Jan ONDREJ 2007-12-20 11:52:46 EST
Description of problem:
named service is not running after update. Same problem on two of my computers.

Version-Release number of selected component (if applicable):
[root@ns ~]# rpm -qa bind\*
bind-libs-9.5.0-20.b1.fc8
bind-utils-9.5.0-20.b1.fc8
bind-chroot-9.5.0-20.b1.fc8
bind-9.5.0-20.b1.fc8

How reproducible:
2 from 3 updates

Steps to Reproduce:
1. yum update
2. service named status
  
Actual results:
rndc: connect failed: 127.0.0.1#953: connection refused
named is stopped

Expected results:
status of running status

Additional info:
Dec 20 14:07:39 ns yum: Updated: selinux-policy - 3.0.8-68.fc8.noarch
Dec 20 14:07:45 ns named[1136]: received control channel command 'stop'
Dec 20 14:07:45 ns named[1136]: shutting down: flushing changes
Dec 20 14:07:45 ns named[1136]: stopping command channel on 127.0.0.1#953
Dec 20 14:07:45 ns named[1136]: no longer listening on 127.0.0.1#53
Dec 20 14:07:45 ns named[1136]: no longer listening on 84.245.82.16#53
Dec 20 14:07:45 ns named[1136]: no longer listening on 84.245.82.34#53
Dec 20 14:07:45 ns named[1136]: no longer listening on 192.168.245.1#53
Dec 20 14:07:46 ns yum: Updated: bind-chroot - 32:9.5.0-20.b1.fc8.i386
Dec 20 14:07:46 ns named[1136]: exiting
Comment 1 Marek Mahut 2007-12-20 13:14:55 EST
Created attachment 290178 [details]
messages

I hit the same issue.
Comment 2 Adam Tkac 2007-12-21 03:16:44 EST
Looks like script stops named and doesn't start it again, not sure why. Could
you please tell me if named running after next update? (will be avaliable soon
due regression in host command)
Comment 3 Jan ONDREJ 2007-12-21 03:59:37 EST
(1/4): bind-utils-9.5.0-2 100% |=========================| 185 kB    00:00
(2/4): bind-9.5.0-21.b1.f 100% |=========================| 1.6 MB    00:00
(3/4): bind-libs-9.5.0-21 100% |=========================| 942 kB    00:00
(4/4): bind-chroot-9.5.0- 100% |=========================|  53 kB    00:00
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating  : bind-libs                    ######################### [1/8]
  Updating  : bind                         ######################### [2/8]
  Updating  : bind-chroot                  ######################### [3/8]
  Updating  : bind-utils                   ######################### [4/8]
  Cleanup   : bind-chroot                  ######################### [5/8]
  Cleanup   : bind-libs                    ######################### [6/8]
  Cleanup   : bind                         ######################### [7/8]
  Cleanup   : bind-utils                   ######################### [8/8]

Updated: bind.i386 32:9.5.0-21.b1.fc8 bind-chroot.i386 32:9.5.0-21.b1.fc8
bind-libs.i386 32:9.5.0-21.b1.fc8 bind-utils.i386 32:9.5.0-21.b1.fc8
Complete!
[root@ns ~]# /etc/init.d/named status
rndc: connect failed: 127.0.0.1#953: connection refused
named je zastavené


Same problem again. I have moved last build from koji to my repository.

!!! PLEASE, DO NOT PUSH THIS TO STABLE AGAIN !!!
Comment 4 Adam Tkac 2007-12-21 04:35:33 EST
If you reproduced it again I expect dome problem with patch for bug #417431. Let
me check it again.
Comment 5 Lubomir Kundrak 2007-12-21 05:15:20 EST
This is weird. Yesterday's update killed my named when updated by yum. This
morning I updated bind bind-libs bind-utils it with rpm and it happened again.

All the subsequent attemtps to reproduce were unsuccessful. I installed a fresh
f8 GA mahcine with bind, applied an update and bind was restarted correctly.
Comment 6 Adam Tkac 2007-12-21 05:25:28 EST
Problem is in initscript's stop function, line 147. This line has to be
while `/sbin/pidof -o %PPID "$named" >/dev/null`; do

Current situation is that initscript doesn't wait for named shutdown. When you
stop named and start it again before named process is terminated it causes that
named doesn't start. If you have long configuration and named has long shutdown
time your "service named restart" will fail. But if you have short configuration
it works. I'm going to do test build for you.
Comment 7 Adam Tkac 2007-12-21 05:39:23 EST
Could you please verify that proposed update works as expected?
http://koji.fedoraproject.org/koji/taskinfo?taskID=304604

I don't think We will discover this problem in updates-testing because people
with long (= more important) configuration simply doesn't use testing
repository. Sorry for your troubles.
Comment 8 Jan ONDREJ 2007-12-21 07:36:34 EST
Works for me, but I can't confirm this exactly. The -21 update worked for me on
4 machines (the first one failed). May be there is something about disk cache,
which can speed up bind and therefore cause restart do not fail.

But -21.1 looks better, 5 machines updated without problems.

Please leave this bug still open and close it aprox. 2 weeks after stable update
is released.
Comment 9 Jon Ciesla 2007-12-21 09:27:03 EST
The initial update left both my DNS servers stopped, but startable.  Haven't
tested the koji build yet.
Comment 10 Jan ONDREJ 2007-12-22 02:07:44 EST
After update from koji (-21.1) I see this change in named init script (diff style):

-  while [ `/sbin/pidof -o %PPID "$named" >/dev/null` ]; do
+  while `/sbin/pidof -o %PPID "$named" >/dev/null`; do

What it means? The "pidof ..." redirected to /dev/null evaluates ALWAYS to empty
string. I think the "`" signs are not needed in this expression. "while"
requires only a command, it is not needed to execute empty output from this command.
Comment 11 Adam Tkac 2007-12-27 09:41:19 EST
(In reply to comment #10)
> After update from koji (-21.1) I see this change in named init script (diff
style):
> 
> -  while [ `/sbin/pidof -o %PPID "$named" >/dev/null` ]; do
> +  while `/sbin/pidof -o %PPID "$named" >/dev/null`; do

Yes, patch for this issue.

> 
> What it means? The "pidof ..." redirected to /dev/null evaluates ALWAYS to empty
> string. I think the "`" signs are not needed in this expression. "while"
> requires only a command, it is not needed to execute empty output from this
command.
> 

When you're right, ` signs are not needed. You will try script with/without "`"
and behavior is same. I'm going to remove ` in final update. Discussed while
loop waits till named stops (when return value from pidof is non-zero named
still runs).
Comment 12 Fedora Update System 2007-12-28 12:19:45 EST
bind-9.5.0-22.b1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update bind'
Comment 13 Adam Tkac 2008-01-02 06:44:15 EST
*** Bug 427084 has been marked as a duplicate of this bug. ***
Comment 14 Ray Todd Stevens 2008-01-02 16:00:37 EST
So far so good this seems to have fixed the original problem.   I will put some
effort into verifying that the rest of the bind system still works during the
next couple of days.
Comment 15 Fedora Update System 2008-01-06 20:13:03 EST
bind-9.5.0-22.b1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.