Bug 427097 - Software Autoupdate failure.
Software Autoupdate failure.
Status: CLOSED DUPLICATE of bug 426975
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
8
i586 Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-31 09:04 EST by Calum MacLeod
Modified: 2007-12-31 09:45 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-31 09:45:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Calum MacLeod 2007-12-31 09:04:22 EST
Description of problem:
Update failure

Version-Release number of selected component (if applicable):


How reproducible:
Yes

Steps to Reproduce:
1. Normal logon
2. Autoupdate
3.
  
Actual results:
Component: pirut
Summary: TB4c8309c5 fastestmirror.py:97:postreposetup_hook:IndexError: list 
index out of range

Traceback (most recent call last):
  File "/usr/sbin/pup", line 611, in <module>
    main()
  File "/usr/sbin/pup", line 607, in main
    pup.run()
  File "/usr/sbin/pup", line 447, in run
    self.doRefresh()
  File "/usr/sbin/pup", line 262, in doRefresh
    pbar = self.doRefreshRepos(destroy=False)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 339, in 
doRefreshRepos
    self.reposSetup(pbar, thisrepo)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 303, in 
reposSetup
    self.doTsSetup()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 72, in doTsSetup
    return self._getTs()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 85, in _getTs
    self._getTsInfo()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 91, in 
_getTsInfo
    self._tsInfo.setDatabases(self.rpmdb, self.pkgSack)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 529, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 384, in 
_getSacks
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.5/site-packages/yum/repos.py", line 214, in 
populateSack
    self.doSetup()
  File "/usr/lib/python2.5/site-packages/yum/repos.py", line 66, in doSetup
    self.ayum.plugins.run('postreposetup')
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 169, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/fastestmirror.py", line 97, in postreposetup_hook
    conduit.info(2, " * %s: %s" % (str(repo), host(repo.urls[0])))
IndexError: list index out of range

Local variables in innermost frame:
repo: InstallMedia
conduit: <yum.plugins.PostRepoSetupPluginConduit instance at 0x98f072c>
repos: ['development', 'updates-debuginfo', 'fedora', 'development-debuginfo', 
'updates-source', 'InstallMedia', 'updates-testing-debuginfo', 'updates-
testing', 'updates', 'updates-testing-source', 'development-source', 'fedora-
source', 'fedora-debuginfo']
repomirrors: {'InstallMedia': [], 'fedora': ['http://ftp.heanet.ie/pub/fedora/
linux/releases/8/Everything/i386/os', 'http://www.mirrorservice.org/sites/
download.fedora.redhat.com/pub/fedora/linux/releases/8/Everything/i386/os', 
'http://ftp.nluug.nl/pub/os/Linux/distr/fedora/linux/releases/8/Everything/i386/
os', 'ftp://ftp.quicknet.nl/pub/Linux/download.fedora.redhat.com/releases/8/
Everything/i386/os', 'http://ftp-stud.hs-esslingen.de/pub/fedora/linux/releases/
8/Everything/i386/os', 'http://ftp.linux.org.uk/pub/distributions/fedora/linux/
releases/8/Everything/i386/os', 'ftp://alviss.et.tudelft.nl/pub/fedora/linux/
releases/8/Everything/i386/os', 'http://mirrors.linux.edu.lv/ftp.redhat.com/pub/
fedora/linux/releases/8/Everything/i386/os', 'http://mirrors.vexs.net/pub/
fedora/linux/releases/8/Everything/i386/os', 'http://ftp.crihan.fr/mirrors/
fedora.redhat.com/fedora/linux/releases/8/Everything/i386/os', 'http://
redhat.linux.ee/pub/fedora/linux/releases/8/Everything/i386/os', 'http://
ftp.SURFnet.nl/pub/os/Linux/distr/fedora/linux/releases/8/Everything/i386/os', 
'http://mirror.karneval.cz/pub/linux/fedora/linux/releases/8/Everything/i386/
os', 'ftp://ftp.pbone.net/pub/fedora/linux/releases/8/Everything/i386/os', 
'http://mirror.atrpms.net/fedora/linux/releases/8/Everything/i386/os', 'http://
ftp.uni-koeln.de/mirrors/fedora/linux/releases/8/Everything/i386/os', 'http://
sunsite.icm.edu.pl/pub/Linux/fedora/linux/releases/8/Everything/i386/os', 
'http://ftp.lip6.fr/ftp/pub/linux/distributions/fedora/releases/8/Everything/
i386/os', 'ftp://ftp.tudelft.nl/pub/Linux/download.fedora.redhat.com/linux/
releases/8/Everything/i386/os', 'ftp://ftp.uib.no/pub/fedora/linux/releases/8/
Everything/i386/os', 'http://ftp.univie.ac.at/systems/linux/fedora/releases/8/
Everything/i386/os', 'http://fedora.tu-chemnitz.de/pub/linux/fedora/linux/
releases/8/Everything/i386/os', 'http://ftp.uni-bayreuth.de/linux/fedora/linux/
releases/8/Everything/i386/os', 'http://ftp.unina.it/pub/linux/distributions/
fedora/linux/releases/8/Everything/i386/os', 'http://gd.tuwien.ac.at/opsys/
linux/fedora/linux/releases/8/Everything/i386/os', 'http://ultra.linux.cz/
MIRRORS/fedora.redhat.com/linux/releases/8/Everything/i386/os', 'ftp://
ftp.sunet.se/pub/Linux/distributions/fedora/linux/releases/8/Everything/i386/
os', 'http://ftp.ntua.gr/pub/linux/fedora/linux/releases/8/Everything/i386/os', 
'http://fedora.mirror.garr.it/mirrors/fedora/linux/releases/8/Everything/i386/
os', 'http://ftp.funet.fi/pub/mirrors/fedora.redhat.com/pub/fedora/linux/
releases/8/Everything/i386/os', 'http://ftp.stw-bonn.de/pub/fedora/linux/
releases/8/Everything/i386/os', 'http://ftp.astral.ro/mirrors/fedora/pub/fedora/
linux/releases/8/Everything/i386/os', 'http://mirrors.ircam.fr/pub/fedora/linux/
releases/8/Everything/i386/os', 'ftp://ftp.cru.fr/pub/linux/fedora/releases/8/
Everything/i386/os', 'http://ftp.cica.es/fedora/linux/releases/8/Everything/
i386/os', 'http://ftp.udl.es/pub/fedora/linux/releases/8/Everything/i386/os', 
'http://mirrors.evrocom.net/fedora/linux/releases/8/Everything/i386/os', 'ftp://
ftp.otenet.gr/pub/linux/fedora/linux/releases/8/Everything/i386/os', 'http://
ftp.crc.dk/fedora/linux/releases/8/Everything/i386/os', 'http://ftp.linux.cz/
pub/linux/fedora/linux/releases/8/Everything/i386/os', 'http://ftp.pwr.wroc.pl/
pub/linux/fedora/linux/releases/8/Everything/i386/os', 'http://
sunsite.rediris.es/mirror/fedora-redhat/releases/8/Everything/i386/os', 'http://
ftp.gts.lug.ro/fedora/linux/releases/8/Everything/i386/os', 'http://
ftp.cc.uoc.gr/pub/fedora/linux/releases/8/Everything/i386/os', 'http://
ftp.rhnet.is/pub/fedora/linux/releases/8/Everything/i386/os', 'ftp://
ftp.uninett.no/pub/linux/Fedora/releases/8/Everything/i386/os', 'http://
fr2.rpmfind.net/linux/fedora/releases/8/Everything/i386/os', 'http://
ftp.ceid.upatras.gr/pub/fedora/linux/releases/8/Everything/i386/os', 'http://
fedora.mirrors.megalan.bg/linux/releases/8/Everything/i386/os', 'http://
ftp.iasi.roedu.net/mirrors/fedora.redhat.com/linux/releases/8/Everything/i386/
os']}


Expected results:
Update of 14 items

Additional info:
Comment 1 Jeremy Katz 2007-12-31 09:45:30 EST

*** This bug has been marked as a duplicate of 426975 ***

Note You need to log in before you can comment on or make changes to this bug.