Bug 426975 - TB4c8309c5 fastestmirror.py:97:postreposetup_hook:IndexError: list index out of range
TB4c8309c5 fastestmirror.py:97:postreposetup_hook:IndexError: list index out ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
8
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Luke Macken
Fedora Extras Quality Assurance
http://openbyte.org/updater-bug
:
: 427021 427023 427024 427074 427097 427113 427163 427313 427341 427519 427522 427604 427753 427770 427838 427842 428128 428495 428529 428602 428604 428657 428885 428957 429908 433364 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-29 01:58 EST by Atanas Beloborodov
Modified: 2016-09-19 22:38 EDT (History)
27 users (show)

See Also:
Fixed In Version: 1.1.10-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-15 17:53:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
application's state at bug (5.79 KB, text/plain)
2007-12-29 07:24 EST, Nico Pellegrini
no flags Details

  None (edit)
Description Atanas Beloborodov 2007-12-29 01:58:02 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.10) Gecko/20071213 Fedora/2.0.0.10-3.fc8 Firefox/2.0.0.10

Description of problem:
When i select "View Updates" of automatic update managet display this bug.

Version-Release number of selected component (if applicable):
pirut-1.3.25-2.fc8

How reproducible:
Always


Steps to Reproduce:
1.Start Fedora, loading Desktop.
2.In right bottom corner display Yum automatic update manager
3.When select "View Updates" dispay this bug.

Actual Results:


Expected Results:


Additional info:
Comment 1 Nico Pellegrini 2007-12-29 07:24:56 EST
Created attachment 290523 [details]
application's state at bug
Comment 2 Nico Pellegrini 2007-12-29 07:28:11 EST
My version-release is pirut-1.3.28-1.fc8
This bug has been taken place after installing new packages:
before bug: rpm -qa |wc -l -> 5256
after  bug: rpm -qa |wc -l -> 5783
After removing (directly at system prompt : rpm -e .....) some packages, pirut 
go again.
Comment 3 Nico Pellegrini 2007-12-29 17:30:08 EST
This bug take place after installation of yum-fastestmirror-1.1.9-1.fc8; 
removing yum-fastestmirror pirut go again.
Comment 4 Nico Pellegrini 2007-12-29 17:41:52 EST
This bug take place also after installation of yum-fastestmirror-1.1.9-2.fc8, 
but don't take place after installation of yum-fastestmirror-1.1.8-1.fc8.
Comment 5 Jeremy Katz 2007-12-29 23:16:51 EST
*** Bug 427021 has been marked as a duplicate of this bug. ***
Comment 6 Jeremy Katz 2007-12-30 09:12:22 EST
*** Bug 427023 has been marked as a duplicate of this bug. ***
Comment 7 Luke Macken 2007-12-30 12:39:01 EST
This issue has been fixed in upstream yum-utils for a little while now; you can
test it out by downloading the latest[0] version and throwing it in
/usr/lib/yum-utils.

Tim, any chance of a new yum-utils update soon ?

[0]:
http://devel.linux.duke.edu/gitweb/?p=yum-utils.git;a=blob_plain;f=plugins/fastestmirror/fastestmirror.py;hb=HEAD
Comment 8 Jeremy Katz 2007-12-30 21:43:07 EST
*** Bug 427074 has been marked as a duplicate of this bug. ***
Comment 9 Jeremy Katz 2007-12-31 09:45:31 EST
*** Bug 427097 has been marked as a duplicate of this bug. ***
Comment 10 Jeremy Katz 2007-12-31 18:12:57 EST
*** Bug 427113 has been marked as a duplicate of this bug. ***
Comment 11 Jeremy Katz 2008-01-01 14:22:23 EST
*** Bug 427163 has been marked as a duplicate of this bug. ***
Comment 12 Eric Tanguy 2008-01-02 14:07:26 EST
Why this fix is still not available by standard update ?
Comment 13 Jeremy Katz 2008-01-02 20:07:40 EST
*** Bug 427313 has been marked as a duplicate of this bug. ***
Comment 14 Jeremy Katz 2008-01-03 06:34:25 EST
*** Bug 427341 has been marked as a duplicate of this bug. ***
Comment 15 Tim Lauridsen 2008-01-04 07:09:36 EST
(In reply to comment #7)

> Tim, any chance of a new yum-utils update soon ?

I have just made a new release, it should be available in updates-testing at
next push
Comment 16 Jon Stanley 2008-01-06 00:17:01 EST
*** Bug 427604 has been marked as a duplicate of this bug. ***
Comment 17 Fedora Update System 2008-01-06 20:16:29 EST
yum-utils-1.1.10-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update yum-utils'
Comment 18 Fedora Update System 2008-01-06 20:21:08 EST
yum-utils-1.1.10-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update yum-utils'
Comment 19 Jeremy Katz 2008-01-08 12:09:14 EST
*** Bug 427024 has been marked as a duplicate of this bug. ***
Comment 20 Jeremy Katz 2008-01-08 12:10:31 EST
*** Bug 427519 has been marked as a duplicate of this bug. ***
Comment 21 Jeremy Katz 2008-01-08 12:12:47 EST
*** Bug 427522 has been marked as a duplicate of this bug. ***
Comment 22 Jeremy Katz 2008-01-08 12:14:42 EST
*** Bug 427753 has been marked as a duplicate of this bug. ***
Comment 23 Jeremy Katz 2008-01-08 12:14:55 EST
*** Bug 427770 has been marked as a duplicate of this bug. ***
Comment 24 Jeremy Katz 2008-01-08 12:15:10 EST
*** Bug 427838 has been marked as a duplicate of this bug. ***
Comment 25 Jeremy Katz 2008-01-08 12:15:21 EST
*** Bug 427842 has been marked as a duplicate of this bug. ***
Comment 26 David Frager 2008-01-10 22:49:44 EST
I applied the proposed update against my FC8 installation and I still get the
same problem.  I show 16 updates to be applied.  

Component: pirut
Summary: TB4c8309c5 fastestmirror.py:97:postreposetup_hook:IndexError: list
index out of range

Traceback (most recent call last):
  File "/usr/sbin/pup", line 611, in <module>
    main()
  File "/usr/sbin/pup", line 607, in main
    pup.run()
  File "/usr/sbin/pup", line 447, in run
    self.doRefresh()
  File "/usr/sbin/pup", line 262, in doRefresh
    pbar = self.doRefreshRepos(destroy=False)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 339, in
doRefreshRepos
    self.reposSetup(pbar, thisrepo)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 303, in reposSetup
    self.doTsSetup()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 72, in doTsSetup
    return self._getTs()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 85, in _getTs
    self._getTsInfo()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 91, in _getTsInfo
    self._tsInfo.setDatabases(self.rpmdb, self.pkgSack)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 529, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 384, in _getSacks
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.5/site-packages/yum/repos.py", line 214, in populateSack
    self.doSetup()
  File "/usr/lib/python2.5/site-packages/yum/repos.py", line 66, in doSetup
    self.ayum.plugins.run('postreposetup')
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 169, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/fastestmirror.py", line 97, in postreposetup_hook
    conduit.info(2, " * %s: %s" % (str(repo), host(repo.urls[0])))
IndexError: list index out of range

Local variables in innermost frame:
repo: InstallMedia
conduit: <yum.plugins.PostRepoSetupPluginConduit instance at 0x133e3f8>
repos: ['development', 'updates-debuginfo', 'atrpms', 'fedora',
'atrpms-testing', 'updates-source', 'InstallMedia', 'updates-testing',
'development-source', 'development-debuginfo', 'updates-testing-debuginfo',
'updates', 'updates-testing-source', 'atrpms-bleeding', 'freshrpms',
'fedora-source', 'fedora-debuginfo']
repomirrors: {'InstallMedia': [], 'atrpms':
['http://dl.atrpms.net/f8-x86_64/atrpms/stable'], 'fedora':
['http://mirror.usu.edu/mirrors/fedora/linux/releases/8/Everything/x86_64/os',
'ftp://mirror.colorado.edu/pub/fedora/linux/releases/8/Everything/x86_64/os',
'http://ftp.osuosl.org/pub/fedora/linux/releases/8/Everything/x86_64/os',
'http://srl.cs.jhu.edu/YUM/fedora/releases/8/Everything/x86_64/os',
'http://mirror.anl.gov/pub/fedora/linux/releases/8/Everything/x86_64/os',
'http://mirror.cc.vt.edu/pub/fedora/linux/releases/8/Everything/x86_64/os',
'ftp://ftp.uci.edu/mirrors/fedora/linux/releases/8/Everything/x86_64/os',
'ftp://thales.memphis.edu/fedora/linux/releases/8/Everything/x86_64/os',
'ftp://ftp.software.umn.edu/linux/fedora/releases/8/Everything/x86_64/os',
'http://limestone.uoregon.edu/ftp/fedora/linux/releases/8/Everything/x86_64/os',
'http://ftp.usf.edu/pub/fedora/linux/releases/8/Everything/x86_64/os',
'http://mirror.steadfast.net/fedora/releases/8/Everything/x86_64/os',
'http://fedora.mirror.facebook.com/linux/releases/8/Everything/x86_64/os',
'http://mirrors.cat.pdx.edu/fedora/linux/releases/8/Everything/x86_64/os',
'http://mirrors.kernel.org/fedora/releases/8/Everything/x86_64/os',
'ftp://mirror.cs.princeton.edu/pub/mirrors/fedora/linux/releases/8/Everything/x86_64/os',
'http://ftp.linux.ncsu.edu/pub/fedora/linux/releases/8/Everything/x86_64/os',
'http://mirror.cogentco.com/pub/linux/fedora/linux/releases/8/Everything/x86_64/os',
'http://gulus.usherbrooke.ca/pub/distro/fedora/linux/releases/8/Everything/x86_64/os',
'http://mirrors.reflected.net/fedora/linux/releases/8/Everything/x86_64/os',
'http://mirror.stanford.edu/fedora/linux/releases/8/Everything/x86_64/os',
'http://linux.nssl.noaa.gov/fedora/linux/releases/8/Everything/x86_64/os',
'ftp://ftp.cse.buffalo.edu/pub/Linux/fedora/linux/releases/8/Everything/x86_64/os',
'http://mirror.web-ster.com/fedora/releases/8/Everything/x86_64/os',
'http://mirror.newnanutilities.org/pub/fedora/linux/releases/8/Everything/x86_64/os',
'ftp://mirror.nyi.net/fedora/linux/releases/8/Everything/x86_64/os',
'http://kdeforge.unl.edu/mirrors/fedora/linux/releases/8/Everything/x86_64/os',
'http://distro.ibiblio.org/pub/linux/distributions/fedora/linux/releases/8/Everything/x86_64/os',
'http://fedora.secsup.org/linux/releases/8/Everything/x86_64/os',
'http://mirror.unl.edu/fedora/linux/releases/8/Everything/x86_64/os',
'http://mirrors.tummy.com/pub/fedora.redhat.com/fedora/linux/releases/8/Everything/x86_64/os']}

Comment 27 Luke Macken 2008-01-11 17:26:25 EST
Are you sure you're running yum-fastestmirror-1.1.10-1.fc8 ?  It's currently in
updates-testing, but should get pushed out to stable soon.
Comment 28 David Frager 2008-01-11 17:50:25 EST
(In reply to comment #27)
> Are you sure you're running yum-fastestmirror-1.1.10-1.fc8 ?  It's currently in
> updates-testing, but should get pushed out to stable soon.

I am sorry..I am running 1.19-2.  I will wait and try again when 1.1.10-1 is
available.

Thanks
Comment 29 Chris Kapsalis 2008-01-13 09:40:53 EST
I just tested yum-fastestmirror-1.1.10-1.fc8.  This has apparently fixed the
list index out of range problem under Fedora 8. Note, that I'm using
pirut-1.3.28-1.fc8 and yum-utils-1.1.9-2.fc8

Thx
Comment 30 James Antill 2008-01-13 23:01:23 EST
*** Bug 428495 has been marked as a duplicate of this bug. ***
Comment 31 James Antill 2008-01-14 08:45:33 EST
*** Bug 428602 has been marked as a duplicate of this bug. ***
Comment 32 James Antill 2008-01-14 08:46:52 EST
*** Bug 428604 has been marked as a duplicate of this bug. ***
Comment 33 Jeremy Katz 2008-01-14 10:47:09 EST
*** Bug 428128 has been marked as a duplicate of this bug. ***
Comment 34 Jeremy Katz 2008-01-14 10:52:41 EST
*** Bug 428529 has been marked as a duplicate of this bug. ***
Comment 35 Jeremy Katz 2008-01-14 10:58:07 EST
*** Bug 428657 has been marked as a duplicate of this bug. ***
Comment 36 Fedora Update System 2008-01-15 17:53:34 EST
yum-utils-1.1.10-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 37 Fedora Update System 2008-01-15 18:12:37 EST
yum-utils-1.1.10-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 38 Jeremy Katz 2008-01-16 08:49:54 EST
*** Bug 428885 has been marked as a duplicate of this bug. ***
Comment 39 Jeremy Katz 2008-01-28 22:38:03 EST
*** Bug 429908 has been marked as a duplicate of this bug. ***
Comment 40 James Antill 2008-02-18 16:14:46 EST
*** Bug 433364 has been marked as a duplicate of this bug. ***
Comment 41 James Antill 2008-03-13 10:58:27 EDT
*** Bug 428957 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.