Bug 427099 - three buttons above synaptics touchpad don't work
three buttons above synaptics touchpad don't work
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-mouse (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
: 428429 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-31 10:50 EST by Charles R. Anderson
Modified: 2008-04-04 00:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-04 00:23:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log with xorg.conf (25.11 KB, text/plain)
2007-12-31 10:50 EST, Charles R. Anderson
no flags Details
xorg.conf that was configured by install (807 bytes, text/plain)
2007-12-31 10:52 EST, Charles R. Anderson
no flags Details
Xorg.0.log with xorg.conf (21.07 KB, text/plain)
2008-01-31 22:22 EST, Charles R. Anderson
no flags Details
xorg.conf (807 bytes, text/plain)
2008-01-31 22:24 EST, Charles R. Anderson
no flags Details
Xorg.0.log without any xorg.conf at all (22.03 KB, text/plain)
2008-01-31 22:27 EST, Charles R. Anderson
no flags Details

  None (edit)
Description Charles R. Anderson 2007-12-31 10:50:50 EST
Description of problem:

On my ThinkPad T61 I have a synaptics touchpad with three buttons above, and two
buttons below.  Only the buttons below the touchpad work.

Version-Release number of selected component (if applicable):
synaptics-0.14.4-12.fc9
xorg-x11-drv-mouse-1.2.3-3.fc9
Comment 1 Charles R. Anderson 2007-12-31 10:50:50 EST
Created attachment 290580 [details]
Xorg.0.log with xorg.conf
Comment 2 Charles R. Anderson 2007-12-31 10:52:10 EST
Created attachment 290581 [details]
xorg.conf that was configured by install
Comment 3 Charles R. Anderson 2007-12-31 11:12:23 EST
These two threads describe this problem in more detail:

https://www.redhat.com/archives/fedora-test-list/2007-December/msg00302.html
https://www.redhat.com/archives/fedora-test-list/2007-December/msg00539.html

Jim Cornette wrote:
> Bryn M. Reeves wrote:
>> Removing the explicit InputDevice section for the synaptics gives me
>> working "joystick" buttons but I loose the synaptics functionality. I'm
>> guessing that with a bit of fiddling they can both be made to work.
>>
>> Previously this "just worked" however.
>
> I have a USB mouse connected which works when running without an
> xorg.conf file in tandem with the pointer only for the touchpad.
> With the xorg.conf file, the USB mouse does not work but the synaptics
> functions as before the X problem.
> Secondary pointing devices might need attention when running with an
> xorg.conf file.

Right, this is what I am seeing too. I've been playing around with
different combinations of InputDevice this morning without success but
the testing is being slowed by another problem I'm hitting with the
intel driver - I'll open a separate BZ for that.

Cheers,
Bryn.
Comment 4 Charles R. Anderson 2007-12-31 11:27:05 EST
It appears that the synaptics driver discovers and uses /dev/input/event2.  If I
"cat /dev/input/event3" I get stuff appearing when clicking the top three
buttons and moving the "joystick" eraser-head pointer device.  So is it possible
that mouse_drv isn't using the right input device /dev/input/event3?
Comment 5 Michel Alexandre Salim 2008-01-27 11:50:34 EST
ping? Not sure if this is specifically a synaptic bug, or a regression in X's
ability to detect a second pointing device.
Comment 6 Charles R. Anderson 2008-01-27 12:44:07 EST
Perhaps this is for the xorg-x11-drv-mouse component...
Comment 7 Matěj Cepl 2008-01-31 11:57:23 EST
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 8 Charles R. Anderson 2008-01-31 12:01:57 EST
Ummm...what you ask for is already there since December:

Xorg.0.log with xorg.conf   	 Valid  	text/plain  	2007-12-31 10:50 EST  
25.11 KB  	 Edit

xorg.conf that was configured by install 	Valid 	text/plain 	2007-12-31 10:52
EST 	807 bytes 	Edit

I'll try again without any xorg.conf.
Comment 9 Charles R. Anderson 2008-01-31 22:22:48 EST
Created attachment 293684 [details]
Xorg.0.log with xorg.conf

With xorg.conf, the synaptics touchpad features such as scrolling and tapping
work, but the joystick mouse and its three buttons don't work at all.
Comment 10 Charles R. Anderson 2008-01-31 22:24:06 EST
Created attachment 293685 [details]
xorg.conf

Here is the xorg.conf that allows the touchpad features to work, but not the
trackpoint joystick pointer device.
Comment 11 Charles R. Anderson 2008-01-31 22:27:33 EST
Created attachment 293686 [details]
Xorg.0.log without any xorg.conf at all

Here is the Xorg.0.log when running without any xorg.conf file at all.	Now
both the synaptics touchpad and the trackpoint pointing devices work, including
all the buttons, but some of the touchpad features do not work, such as
scrolling and tap-drag.  Curiously, single and double-tap do work for
clicking/double-clicking.
Comment 12 Charles R. Anderson 2008-01-31 22:30:11 EST
The above testing in comment #9, comment #10, and comment #11 was done with
these versions:

kernel-2.6.24-9.fc9.x86_64
xorg-x11-drv-mouse-1.2.3-3.fc9.x86_64
synaptics-0.14.6-1.fc9.x86_64
Comment 13 Michel Alexandre Salim 2008-01-31 23:07:34 EST
Same here. With xorg.conf, the Synaptic trackpad has all features enabled but no
other pointing devices work. Without, the trackpad does not use the Synaptic
driver at all.

(exactly same software configuration as Charles; Thinkpad T61)
Comment 14 Matěj Cepl 2008-04-02 18:46:02 EDT
*** Bug 428429 has been marked as a duplicate of this bug. ***
Comment 15 Charles R. Anderson 2008-04-04 00:23:16 EDT
I no longer have this problem.  Closing.

Current versions:

kernel-2.6.25-0.185.rc7.git6.fc9.x86_64
xorg-x11-drv-i810-2.2.1-19.fc9.x86_64
xorg-x11-server-common-1.4.99.901-16.20080401.fc9.x86_64
xorg-x11-server-Xorg-1.4.99.901-16.20080401.fc9.x86_64
xorg-x11-drv-mouse-1.3.0-1.fc9.x86_64
synaptics-0.14.6-7.fc9.x86_64

Note You need to log in before you can comment on or make changes to this bug.