Bug 428429 - Touchpad fails to work in X
Touchpad fails to work in X
Status: CLOSED DUPLICATE of bug 427099
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-mouse (Show other bugs)
i386 Linux
low Severity low
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-01-11 08:42 EST by Horst H. von Brand
Modified: 2008-04-02 18:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-04-02 18:46:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Current xorg.conf (3.52 KB, text/plain)
2008-01-11 08:42 EST, Horst H. von Brand
no flags Details
Latest Xorg log (30.42 KB, text/plain)
2008-01-11 08:43 EST, Horst H. von Brand
no flags Details
Requested log (no xorg.conf) (76.03 KB, text/plain)
2008-03-05 16:47 EST, Horst H. von Brand
no flags Details

  None (edit)
Description Horst H. von Brand 2008-01-11 08:42:20 EST
Description of problem:
This machine (Toshiba Tecra A7 SP2022) has both the nipple in between keys and a
touchpad. I normally use an external USB mouse, but the not working of the
touchpad is annoying all the same.

The nipple works in X and on a text console, the touchpad works only in text

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Try to use touchpad as mouse under X
Actual results:
No reaction

Expected results:
Mouse pointer movement

Additional info:
Comment 1 Horst H. von Brand 2008-01-11 08:42:20 EST
Created attachment 291387 [details]
Current xorg.conf
Comment 2 Horst H. von Brand 2008-01-11 08:43:34 EST
Created attachment 291388 [details]
Latest Xorg log
Comment 3 Horst H. von Brand 2008-01-15 19:22:36 EST
Due to a bug handling fonts I axed /etc/X11/xorg.conf, and then the Touchpad
works! But the nipple and the USB mouse don't :-(
Comment 4 Charles R. Anderson 2008-02-07 19:19:13 EST
This might be similar to bug #427099, or at least related to detecting/using
multiple mouse pointer devices.  Could you please provide the information as
requested below?  Thanks!

"Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance."
Comment 5 Horst H. von Brand 2008-03-05 16:47:21 EST
Created attachment 296945 [details]
Requested log (no xorg.conf)

xorg-x11-server-Xorg- right now.

And yes, I've got several mice (nipple, touchpad, USB mouse).
Comment 6 Horst H. von Brand 2008-03-26 20:04:39 EDT
This worked briefly, now it is broken again...
Comment 7 Matěj Cepl 2008-04-02 18:46:01 EDT

*** This bug has been marked as a duplicate of 427099 ***

Note You need to log in before you can comment on or make changes to this bug.