Bug 427139 - Package Manager crash customizing the software components.
Package Manager crash customizing the software components.
Status: CLOSED DUPLICATE of bug 336791
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
8
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-31 22:09 EST by Jose Pena
Modified: 2008-01-01 10:22 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-01 10:22:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Pirut bug. (673 bytes, text/plain)
2007-12-31 22:09 EST, Jose Pena
no flags Details

  None (edit)
Description Jose Pena 2007-12-31 22:09:28 EST
Component: pirut
Summary: TB91835f44 GroupSelector.py:211:_pkgToggled:TypeError:
GtkTreeModel.get_iter_from_string() argument 1 must be string, not tuple

Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/pirut/GroupSelector.py", line 208, in
_rowToggle
    self._pkgToggled(None, path)
  File "/usr/lib/python2.5/site-packages/pirut/GroupSelector.py", line 211, in
_pkgToggled
    i = self.pkgstore.get_iter_from_string(path)
TypeError: GtkTreeModel.get_iter_from_string() argument 1 must be string, not tuple

Local variables in innermost frame:
path: (11,)
widget: None
self: <pirut.GroupSelector.OptionalPackageSelector instance at 0x86e3f80>



Description of problem:
 
The problem happens when you trying to customize the packages in the
installation, and when you try to see the optional packages in the Package
Manager, at the begin of this comment is the output the the crashed software. 

Version-Release number of selected component (if applicable):

Package Manager, in Fedora 8 x86-64.
Comment 1 Jose Pena 2007-12-31 22:09:28 EST
Created attachment 290600 [details]
Pirut bug.
Comment 2 Jose Pena 2007-12-31 22:16:38 EST
The bug happens again like a problem when the optional packages, its like a
casting problem to a string data type, espected by a function named:
GtkTreeModel.get_iter_from_string() 

Please when the problem is solved advise me. Best regards.

Component: pirut
Summary: TB91835f44 GroupSelector.py:211:_pkgToggled:TypeError:
GtkTreeModel.get_iter_from_string() argument 1 must be string, not tuple

Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/pirut/GroupSelector.py", line 208, in
_rowToggle
    self._pkgToggled(None, path)
  File "/usr/lib/python2.5/site-packages/pirut/GroupSelector.py", line 211, in
_pkgToggled
    i = self.pkgstore.get_iter_from_string(path)
TypeError: GtkTreeModel.get_iter_from_string() argument 1 must be string, not tuple

Local variables in innermost frame:
path: (2,)
widget: None
self: <pirut.GroupSelector.OptionalPackageSelector instance at 0x4ca45f0>
Comment 3 Jeremy Katz 2008-01-01 10:22:24 EST

*** This bug has been marked as a duplicate of 336791 ***

Note You need to log in before you can comment on or make changes to this bug.