Bug 427163 - package updater gives unhandled exception error
package updater gives unhandled exception error
Status: CLOSED DUPLICATE of bug 426975
Product: Fedora
Classification: Fedora
Component: yum-updatesd (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-01 13:41 EST by andy walker
Modified: 2008-01-01 14:22 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-01 14:22:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description andy walker 2008-01-01 13:41:00 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.10) Gecko/20071213 Fedora/2.0.0.10-3.fc8 Firefox/2.0.0.10

Description of problem:
package updater gives unhandled exception error

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1.view or apply updates
2. error
3.

Actual Results:
Component: pirut
Summary: TB4c8309c5 fastestmirror.py:97:postreposetup_hook:IndexError: list index out of range

Traceback (most recent call last):
  File "/usr/sbin/pup", line 611, in <module>
    main()
  File "/usr/sbin/pup", line 607, in main
    pup.run()
  File "/usr/sbin/pup", line 447, in run
    self.doRefresh()
  File "/usr/sbin/pup", line 262, in doRefresh
    pbar = self.doRefreshRepos(destroy=False)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 339, in doRefreshRepos
    self.reposSetup(pbar, thisrepo)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 303, in reposSetup
    self.doTsSetup()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 72, in doTsSetup
    return self._getTs()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 85, in _getTs
    self._getTsInfo()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 91, in _getTsInfo
    self._tsInfo.setDatabases(self.rpmdb, self.pkgSack)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 529, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 384, in _getSacks
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.5/site-packages/yum/repos.py", line 214, in populateSack
    self.doSetup()
  File "/usr/lib/python2.5/site-packages/yum/repos.py", line 66, in doSetup
    self.ayum.plugins.run('postreposetup')
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 169, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/fastestmirror.py", line 97, in postreposetup_hook
    conduit.info(2, " * %s: %s" % (str(repo), host(repo.urls[0])))
IndexError: list index out of range

Local variables in innermost frame:
repo: InstallMedia
conduit: <yum.plugins.PostRepoSetupPluginConduit instance at 0xa529fac>
repos: ['livna-development', 'updates-source', 'livna-development-debuginfo', 'updates-testing', 'livna', 'updates-testing-source', 'livna-debuginfo', 'fedora', 'livna-source', 'InstallMedia', 'development-source', 'adobe-linux-i386', 'development', 'updates-debuginfo', 'fedora-debuginfo', 'livna-development-source', 'updates-testing-debuginfo', 'updates', 'livna-testing', 'fedora-source', 'development-debuginfo', 'livna-testing-debug', 'livna-testing-source']
repomirrors: {'InstallMedia': [], 'livna': ['ftp://mirrors.tummy.com/pub/rpm.livna.org/fedora/8/i386/', 'http://livna.cat.pdx.edu/fedora/8/i386/', 'http://mirror.atrpms.net/livna/fedora/8/i386/', 'http://wftp.tu-chemnitz.de/pub/linux/livna/fedora/8/i386/', 'http://ftp-stud.fht-esslingen.de/pub/Mirrors/rpm.livna.org/fedora/8/i386/', 'http://rpm.livna.org/fedora/8/i386/'], 'fedora': ['ftp://thales.memphis.edu/fedora/linux/releases/8/Everything/i386/os', 'http://mirrors.reflected.net/fedora/linux/releases/8/Everything/i386/os', 'http://mirror.stanford.edu/fedora/linux/releases/8/Everything/i386/os', 'http://fedora.ifc.unam.mx/releases/8/Everything/i386/os', 'http://mirror.steadfast.net/fedora/releases/8/Everything/i386/os', 'ftp://mirror.nyi.net/fedora/linux/releases/8/Everything/i386/os', 'http://ftp.osuosl.org/pub/fedora/linux/releases/8/Everything/i386/os', 'http://mirror.anl.gov/pub/fedora/linux/releases/8/Everything/i386/os', 'http://fedora.mirror.facebook.com/linux/releases/8/Everything/i386/os', 'http://mirror.unl.edu/fedora/linux/releases/8/Everything/i386/os', 'http://fedora.mirror.iweb.ca/releases/8/Everything/i386/os', 'http://linux.nssl.noaa.gov/fedora/linux/releases/8/Everything/i386/os', 'http://kdeforge.unl.edu/mirrors/fedora/linux/releases/8/Everything/i386/os', 'http://www.muug.mb.ca/pub/fedora/linux/releases/8/Everything/i386/os', 'http://mirrors.cat.pdx.edu/fedora/linux/releases/8/Everything/i386/os', 'ftp://ftp.cse.buffalo.edu/pub/Linux/fedora/linux/releases/8/Everything/i386/os', 'http://mirror.hiwaay.net/pub/fedora/linux/releases/8/Everything/i386/os', 'http://mirror.cogentco.com/pub/linux/fedora/linux/releases/8/Everything/i386/os', 'http://gulus.usherbrooke.ca/pub/distro/fedora/linux/releases/8/Everything/i386/os', 'http://mirrors.kernel.org/fedora/releases/8/Everything/i386/os', 'http://mirror.nuvio.com/pub/fedora/linux/releases/8/Everything/i386/os', 'http://distro.ibiblio.org/pub/linux/distributions/fedora/linux/releases/8/Everything/i386/os', 'ftp://ftp.software.umn.edu/linux/fedora/releases/8/Everything/i386/os', 'http://mirror.usu.edu/mirrors/fedora/linux/releases/8/Everything/i386/os', 'http://mirror.cc.vt.edu/pub/fedora/linux/releases/8/Everything/i386/os', 'http://mirror.web-ster.com/fedora/releases/8/Everything/i386/os', 'http://ftp.linux.ncsu.edu/pub/fedora/linux/releases/8/Everything/i386/os', 'http://ftp.usf.edu/pub/fedora/linux/releases/8/Everything/i386/os', 'ftp://ftp.uci.edu/mirrors/fedora/linux/releases/8/Everything/i386/os', 'http://limestone.uoregon.edu/ftp/fedora/linux/releases/8/Everything/i386/os', 'http://srl.cs.jhu.edu/YUM/fedora/releases/8/Everything/i386/os', 'ftp://mirror.cs.princeton.edu/pub/mirrors/fedora/linux/releases/8/Everything/i386/os']}


Expected Results:


Additional info:
Comment 1 Jeremy Katz 2008-01-01 14:22:22 EST

*** This bug has been marked as a duplicate of 426975 ***

Note You need to log in before you can comment on or make changes to this bug.