Bug 427222 - system-control-network doesn't run as a non-root user
system-control-network doesn't run as a non-root user
Status: CLOSED DUPLICATE of bug 368871
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-02 06:38 EST by Hedayat Vatankhah
Modified: 2008-01-03 13:56 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-03 13:56:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hedayat Vatankhah 2008-01-02 06:38:58 EST
Description of problem:
system-control-network doesn't run on my system as a non-root user.


How reproducible:
Steps to Reproduce:
1. run system-control-network as a regular user
  
Actual results:
Traceback (most recent call last):
  File "/usr/bin/system-control-network", line 484, in <module>
    window = mainDialog()
  File "/usr/bin/system-control-network", line 117, in __init__
    self.devicelist = self.getProfDeviceList()
  File "/usr/bin/system-control-network", line 406, in getProfDeviceList
    profilelist = getProfileList(refresh)
  File "/usr/share/system-config-network/netconfpkg/NCProfileList.py", line 652,
in getProfileList
    __PFList.load()
  File "/usr/share/system-config-network/netconfpkg/NCProfileList.py", line 75,
in load
    changed = updateNetworkScripts()
  File "/usr/share/system-config-network/netconfpkg/NC_functions.py", line 940,
in updateNetworkScripts
    log.log(5, "Cannot write to %s" % (getRoot + "/"))
TypeError: unsupported operand type(s) for +: 'function' and 'str'


Expected results:
See it running and be able to activate/deactivate devices
Comment 1 Hedayat Vatankhah 2008-01-03 13:56:50 EST

*** This bug has been marked as a duplicate of 368871 ***

Note You need to log in before you can comment on or make changes to this bug.