Bug 368871 - system-control-network won't start
system-control-network won't start
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
: 398151 427222 427627 (view as bug list)
Depends On:
Blocks: F8Target
  Show dependency treegraph
 
Reported: 2007-11-06 15:49 EST by Zack Cerza
Modified: 2008-01-12 16:12 EST (History)
8 users (show)

See Also:
Fixed In Version: 1.4.7-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-11 17:20:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zack Cerza 2007-11-06 15:49:29 EST
Description of problem:
When started via the menu, nothing happens. When started via terminal, the
following traceback is printed:

Traceback (most recent call last):
  File "/usr/bin/system-control-network", line 484, in <module>
    window = mainDialog()
  File "/usr/bin/system-control-network", line 117, in __init__
    self.devicelist = self.getProfDeviceList()
  File "/usr/bin/system-control-network", line 406, in getProfDeviceList
    profilelist = getProfileList(refresh)
  File "/usr/share/system-config-network/netconfpkg/NCProfileList.py", line 652,
in getProfileList
    __PFList.load()
  File "/usr/share/system-config-network/netconfpkg/NCProfileList.py", line 75,
in load
    changed = updateNetworkScripts()
  File "/usr/share/system-config-network/netconfpkg/NC_functions.py", line 940,
in updateNetworkScripts
    log.log(5, "Cannot write to %s" % (getRoot + "/"))
TypeError: unsupported operand type(s) for +: 'function' and 'str'

I'm guessing the problem is just that getRoot is missing its (), but there could
be some deeper problem.

Version-Release number of selected component (if applicable):
system-config-network-1.4.3-1.fc8
Comment 1 Harald Hoyer 2007-11-07 04:27:10 EST
does it work, if you add the "()" ?
Comment 2 Zack Cerza 2007-11-07 11:53:57 EST
It starts up if I add it, yes. So that will fix this bug.

It doesn't quite work properly still though, as non-root: The
Activate/Deactivate buttons need to ask for root auth instead of just failing.
Comment 3 Harald Hoyer 2007-11-08 06:40:56 EST
/usr/bin/system-config-network asks for the root password with consolehelper.
Comment 4 Zack Cerza 2007-11-08 11:46:47 EST
Well, it doesn't ask for the activate/deactivate buttons :)
Comment 5 Harald Hoyer 2007-11-08 12:01:20 EST
Ah, oh... "control" .. not "config" .. :) ok.

Hmm, it should not display those devices, which are not user-controllable..
USERCTL=yes
has to be set in the ifcfg-* file. And then "Activate" "Deactivate" should work.
Comment 6 LarryT 2007-11-10 02:43:31 EST
Hi, I am not an exact end-user, and would like to know how to fix this problem,
please.
Would you be kind enough to tell me where I have to add those two () ?
Witch file and line ?

thank you very much. I am currently stopped :-/
Comment 7 LarryT 2007-11-10 05:15:39 EST
Ok, I got it :)
Comment 8 Riba Zoltan 2007-11-10 06:03:15 EST
Hi, please change line number 940 in
'/usr/share/system-config-network//netconfpkg/NC_functions.py' file

from:
    log.log(5, "Cannot write to %s" % (getRoot + "/"))

to:
    log.log(5, "Cannot write to %s" % (getRoot() + "/"))
After this change the system-control-network will work.
Comment 9 Adam Pribyl 2007-11-11 11:19:26 EST
I thing the requested info is provided, could this be fixed?
Comment 10 Fedora Update System 2007-11-12 19:09:56 EST
system-config-network-1.4.5-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-network'
Comment 11 Harald Hoyer 2007-11-26 08:05:42 EST
*** Bug 398151 has been marked as a duplicate of this bug. ***
Comment 12 NILMONI DEB 2007-11-27 11:38:06 EST
(In reply to comment #10)
> system-config-network-1.4.5-1.fc8 has been pushed to the Fedora 8 testing 
repository.  If problems still persist, please make note of it in this bug 
report.
>  If you want to test the update, you can install it with 
>  su -c 'yum --enablerepo=updates-testing update system-config-network'

Could not install this update package due to bug 374801.
Comment 13 sarcastic.mannequin 2007-12-02 14:33:47 EST
Grrrrrr!

How does stuff like this get broken? This worked in FC5 (the latest FC that I
was using). It seems FC8 is rife with bugs like this.

Are changes not tested? Is there, or is there not, a formal test plan for
testing these types of changes?

<RANT> I'm starting to believe the people that say that Fedora is a dumping
ground for RH. And I really don't want to! No offense meant. I'm just grumpy
because I uninstalled "A command-line CD/DVD recording program" (that is the
exact description in FC pkg manager) and it uninstalled *ALL* of Gnome. Sigh -
stuff like that makes me want to bang my head on the wall. </RANT>

Anyway, thanks for the fix, but how about testing changes.
Comment 14 Harald Hoyer 2007-12-03 04:38:27 EST
err, you should read what you uninstall, before you click "Ok" :)
Comment 15 Zack Cerza 2007-12-03 12:07:38 EST
What is the bug number for your uninstall issue?
Comment 16 Fedora Update System 2007-12-06 15:44:31 EST
system-config-network-1.4.7-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-network'
Comment 17 Hedayat Vatankhah 2008-01-03 13:56:51 EST
*** Bug 427222 has been marked as a duplicate of this bug. ***
Comment 18 condor 2008-01-05 13:20:49 EST
*** Bug 427627 has been marked as a duplicate of this bug. ***
Comment 19 Nicola Soranzo 2008-01-07 10:38:36 EST
What about moving the updated package from testing to stable?

Thanks,
Nicola
Comment 20 Fedora Update System 2008-01-11 17:20:08 EST
system-config-network-1.4.7-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.