Bug 427263 - Reinstalling quake3 results in no menu entries
Reinstalling quake3 results in no menu entries
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
8
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-02 10:47 EST by Philip Ashmore
Modified: 2008-01-07 13:47 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-07 13:47:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Philip Ashmore 2008-01-02 10:47:14 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.10) Gecko/20071213 Fedora/2.0.0.10-3.fc8 Firefox/2.0.0.10

Description of problem:
Reinstalling quake3 results in no menu entries in KDE

Version-Release number of selected component (if applicable):
1.34-0.3.rc4.fc8

How reproducible:
Always


Steps to Reproduce:
1. yum -y install quake3
2. yum -y remove opengl-games-utils
3. yum -y install quake3


Actual Results:
No menu entries in KDE

Expected Results:
There should be menu entries

Additional info:
This is as a result of https://bugzilla.redhat.com/show_bug.cgi?id=426764
After uninstalling opengl-games-utils and quake3 I removed all the ioquake3 and point release files/directories I could find.
Comment 1 Hans de Goede 2008-01-02 10:58:13 EST
What is the output of:
rpm -q --verify quake3
?

Comment 2 Philip Ashmore 2008-01-03 17:20:53 EST
# rpm -q --verify quake3
S.5.....   /usr/bin/q3ded
S.5.....   /usr/bin/quake3
S.5.....   /usr/bin/quake3-smp
# yum -y remove quake3
# yum -y install quake3
# rpm -q --verify quake3
#

Still no menu entries.

Shouldn't there be one under "games"?
Comment 3 Hans de Goede 2008-01-03 17:54:56 EST
(In reply to comment #2)
> 
> Shouldn't there be one under "games"?

Yes one called "Quake 3 Arena", and there is, atleast on all my testing systems.

You do not happen to have updates-testing enabled by default, do you?

To be sure, what is the output of: "rpm -ql quake3" ?
And what of: "cat /usr/share/applications/fedora-quake3.desktop" ?
Comment 4 Philip Ashmore 2008-01-03 18:40:09 EST
My updates-testing repo is disabled.

# rpm -ql quake3
/usr/bin/q3ded
/usr/bin/quake3
/usr/bin/quake3-demo
/usr/bin/quake3-smp
/usr/share/applications/fedora-quake3.desktop
/usr/share/doc/quake3-1.34
/usr/share/doc/quake3-1.34/BUGS
/usr/share/doc/quake3-1.34/COPYING.txt
/usr/share/doc/quake3-1.34/ChangeLog
/usr/share/doc/quake3-1.34/NOTTODO
/usr/share/doc/quake3-1.34/README
/usr/share/doc/quake3-1.34/TODO
/usr/share/doc/quake3-1.34/id-readme.txt
/usr/share/doc/quake3-1.34/md4-readme.txt
/usr/share/icons/hicolor/64x64/apps/quake3.png
/usr/share/quake3
/usr/share/quake3/quake3.autodlrc

# cat /usr/share/applications/fedora-quake3.desktop

[Desktop Entry]
Encoding=UTF-8
Name=Quake 3 Arena
Comment=Quake 3 Arena demo launcher, will automatically download the needed
data-files
Exec=quake3-demo
Icon=quake3
Terminal=false
Type=Application
Categories=Game;ActionGame;
X-Desktop-File-Install-Version=0.13
Comment 5 Philip Ashmore 2008-01-03 19:43:11 EST
I just installed alienarena, as a test - no menu entries there either.
I checked /usr/share/applications/fedora-alienarena.desktop - it looks very
similiar to quake3's.

Either it's a problem with my installation, a KDE problem or it's a KDE
install-from-live-CD problem.
Comment 6 Hans de Goede 2008-01-04 04:15:54 EST
Looks like a KDE problem to me, as those are both perfectly valid desktop files.
Changing component to KDE.
Comment 7 Lukáš Tinkl 2008-01-04 07:57:18 EST
Try running kbuildsycoca --noincremental to see if it helps.
Comment 8 Philip Ashmore 2008-01-04 08:06:16 EST
I just copied "kbuildsycoca --noincremental" to konsole and ran it.
No change in the (lack of) quake and alienarena menus.
Comment 9 Rex Dieter 2008-01-07 12:20:49 EST
Um, just installed quake3-1.34-0.6.rc4.fc8

No menu entry.

rpm -ql quake3 | grep desktop
(blank)!

no /usr/share/applications/fedora-quake3.desktop on my box.

looks like a broken build/pkg to me.  Reassigning back to quake3
Comment 10 Rex Dieter 2008-01-07 12:24:10 EST
Looks like that's by design, it appears.  

quake3-demo (or quake3-urbanterror or others) contain the .desktop files
Comment 11 Rex Dieter 2008-01-07 12:25:17 EST
fwiw, installing quake3-demo worksforme.
Comment 12 Hans de Goede 2008-01-07 13:17:56 EST
Rex,

Then you either have updates-testing enabled, or are doing this under
development. The quake3 quake3-demo split is recent, to allow quake3 (the
engine) to be used by other packages without dragging in the demo .desktop file
and autodownloader stuff.

See comment #4 for clear proof that this isn't the case / issue in the reporters
case. Note BTW, that the same quake3.desktop shows up in KDE's menu just fine on
my system, iow I haven't been able to reproduce this.

Anyways ping-ponging right back to KDE.
Comment 13 Rex Dieter 2008-01-07 13:37:53 EST
updates-testing yeah, I'll try to reproduce without it. (but I doubt it).
Comment 14 Rex Dieter 2008-01-07 13:46:33 EST
dunno, WORKSFORME.
Comment 15 Rex Dieter 2008-01-07 13:47:44 EST
If you can provide any additional information on how to reproduce, please do so
and reopen this.

Note You need to log in before you can comment on or make changes to this bug.