Bug 427341 - TB4c8309c5 fastestmirror.py:97:postreposetup_hook:IndexError: list index out of range
TB4c8309c5 fastestmirror.py:97:postreposetup_hook:IndexError: list index out ...
Status: CLOSED DUPLICATE of bug 426975
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
8
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-03 04:27 EST by chen chin chia
Modified: 2008-01-03 06:34 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-03 06:34:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description chen chin chia 2008-01-03 04:27:44 EST
raceback (most recent call last):
  File "/usr/sbin/pup", line 611, in <module>
    main()
  File "/usr/sbin/pup", line 607, in main
    pup.run()
  File "/usr/sbin/pup", line 447, in run
    self.doRefresh()
  File "/usr/sbin/pup", line 262, in doRefresh
    pbar = self.doRefreshRepos(destroy=False)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 339, in
doRefreshRepos
    self.reposSetup(pbar, thisrepo)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 303, in reposSetup
    self.doTsSetup()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 72, in doTsSetup
    return self._getTs()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 85, in _getTs
    self._getTsInfo()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 91, in _getTsInfo
    self._tsInfo.setDatabases(self.rpmdb, self.pkgSack)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 529, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 384, in _getSacks
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.5/site-packages/yum/repos.py", line 214, in populateSack
    self.doSetup()
  File "/usr/lib/python2.5/site-packages/yum/repos.py", line 66, in doSetup
    self.ayum.plugins.run('postreposetup')
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 169, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/fastestmirror.py", line 97, in postreposetup_hook
    conduit.info(2, " * %s: %s" % (str(repo), host(repo.urls[0])))
IndexError: list index out of range

Local variables in innermost frame:
repo: InstallMedia
conduit: <yum.plugins.PostRepoSetupPluginConduit instance at 0x88941ac>
repos: ['livna-development', 'updates-source', 'livna-development-debuginfo',
'updates-testing', 'livna', 'updates-testing-source', 'livna-debuginfo',
'fedora', 'livna-source', 'InstallMedia', 'development-source', 'development',
'updates-debuginfo', 'fedora-debuginfo', 'livna-development-source',
'updates-testing-debuginfo', 'updates', 'freshrpms', 'livna-testing',
'fedora-source', 'development-debuginfo', 'livna-testing-debug',
'livna-testing-source']
repomirrors: {'InstallMedia': [], 'livna':
['ftp://mirrors.tummy.com/pub/rpm.livna.org/fedora/8/i386/',
'http://livna.cat.pdx.edu/fedora/8/i386/',
'http://rpm.livna.org/fedora/8/i386/',
'http://mirror.atrpms.net/livna/fedora/8/i386/',
'http://ftp-stud.fht-esslingen.de/pub/Mirrors/rpm.livna.org/fedora/8/i386/',
'http://wftp.tu-chemnitz.de/pub/linux/livna/fedora/8/i386/'], 'fedora':
['http://linux.ntcu.net/ftp/dists/fedora/releases/8/Everything/i386/os',
'http://opensource.nchc.org.tw/fedora/linux/releases/8/Everything/i386/os',
'http://ftp.riken.jp/Linux/fedora/releases/8/Everything/i386/os',
'http://ftp.jaist.ac.jp/pub/Linux/Fedora/releases/8/Everything/i386/os',
'http://spreader.yandex.net/fedora/linux/releases/8/Everything/i386/os',
'http://allotter.yandex.net/fedora/linux/releases/8/Everything/i386/os',
'http://mirror.wbut.ac.in/pub/fedora/linux/releases/8/Everything/i386/os',
'ftp://ftp.cs.hacettepe.edu.tr/pub/mirrors/fedora/linux/releases/8/Everything/i386/os']}
Comment 1 Jeremy Katz 2008-01-03 06:34:24 EST

*** This bug has been marked as a duplicate of 426975 ***

Note You need to log in before you can comment on or make changes to this bug.