Bug 427504 - system-config-users errata breaks user creation
system-config-users errata breaks user creation
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-users (Show other bugs)
5.1
All Linux
low Severity high
: rc
: ---
Assigned To: Nils Philippsen
: Regression
: 428301 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-04 04:55 EST by Carlos Rodrigues
Modified: 2013-04-12 15:29 EDT (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2007-1110
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-27 12:29:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carlos Rodrigues 2008-01-04 04:55:15 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11

Description of problem:
With the latest version of system-config-users (1.2.51-3.el5), trying to create a new user always fails with an exception. The previous version (1.2.51-1.el5) works as expected.


Version-Release number of selected component (if applicable):
system-config-users-1.2.51-3.el5

How reproducible:
Always


Steps to Reproduce:
1. Run system-config-users
2. Click "Add User"
3. Fill the appropriate fields
4. Click OK

Actual Results:
The "Create New User" dialog becomes unresponsive and the following can be seen on the console:

Traceback (most recent call last):
  File "/usr/share/system-config-users/userWindow.py", line 354, in on_userWin_ok_button_clicked
    groupEnt.set (libuser.GROUPNAME, groupName)
NameError: global name 'groupName' is not defined


Expected Results:
The user should have been created.

Additional info:
This has been tested on two fully updated RHEL 5.1 machines (i386 and x86_64). On both cases, rolling back to the previous released version of system-config-users fixes the problem.
Comment 2 RHEL Product and Program Management 2008-02-22 05:08:06 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 4 Carlos Rodrigues 2008-02-22 05:55:28 EST
By that you mean it will be fixed in RHEL 5.2 right? I have no problem with
that. I'm already "exclude="ing this package from the fasttrack channel, and the
version in the normal channel is enough for me. I just filed this report to make
sure it doesn't go unfixed forever. :)
Comment 5 RHEL Product and Program Management 2008-02-22 05:59:23 EST
This bugzilla was reviewed by QE as a non-FasTrack request.
It has since been proposed for FasTrack. The qa_ack has 
been reset. QE needs to re-review this bugzilla for FasTrack.
Comment 6 Phil Knirsch 2008-02-22 06:04:17 EST
Devel ACK.

Read ya, Phil
Comment 10 errata-xmlrpc 2008-02-27 12:29:55 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-1110.html
Comment 11 Nils Philippsen 2008-04-02 06:50:59 EDT
*** Bug 428301 has been marked as a duplicate of this bug. ***
Comment 12 Leonid Kanter 2008-05-06 08:46:35 EDT
Is it possible to look at source code of this update? It's not published.
Comment 13 Nils Philippsen 2008-05-06 12:29:04 EDT
Don't know why this hasn't been pushed to FTP yet (perhaps it will only be done
with a product update, i.e with RHEL 5.2) -- the only change between the
previous version and this one is replacing the offending line (the one mentioned
in the traceback) with this one:

    groupEnt.set (libuser.GROUPNAME, userName)

Note You need to log in before you can comment on or make changes to this bug.