Bug 427524 - pirut crashes (maximum recursion depth exceeded)
pirut crashes (maximum recursion depth exceeded)
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
8
i686 Linux
low Severity high
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-04 07:37 EST by Maxim Egorushkin
Modified: 2008-05-28 15:27 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-28 15:27:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
stack trace (124.24 KB, text/plain)
2008-01-04 07:37 EST, Maxim Egorushkin
no flags Details
crash log (124.25 KB, text/plain)
2008-02-10 17:01 EST, Andrey
no flags Details

  None (edit)
Description Maxim Egorushkin 2008-01-04 07:37:53 EST
Description of problem:
Pirut crashes trying to install any rpm with the following message:
Component: pirut
Summary: TB3242b26e repos.py:278:getAttribute:RuntimeError: maximum recursion
depth exceeded

Version-Release number of selected component (if applicable):
[max@k-pax tmp]$ rpm -qa | egrep "yum|pirut"
yum-fedorafaq-8-2007.11.12
yum-utils-1.1.9-2.fc8
yum-metadata-parser-1.1.2-1.fc8
yumex-2.0.3-2.fc8
yum-3.2.8-2.fc8
yum-fastestmirror-1.1.9-2.fc8
yum-refresh-updatesd-1.1.9-2.fc8
yum-priorities-1.1.9-2.fc8
yum-updatesd-0.9-1.fc8
pirut-1.3.28-1.fc8


How reproducible:
always


Steps to Reproduce:
1. install yum repos and plugins as described at
http://www.fedorafaq.org/#installsoftware
2. download any rpm using firefox
3. click "open" in the download window and enter root password
4. "Installing packages" pirut window appears
  
Actual results:
"exception occurred" dialog pops up


Expected results:
pirut installs the rpm


Additional info:
Comment 1 Maxim Egorushkin 2008-01-04 07:37:53 EST
Created attachment 290843 [details]
stack trace
Comment 2 Jeremy Katz 2008-01-08 12:13:12 EST

*** This bug has been marked as a duplicate of 375221 ***
Comment 3 Maxim Egorushkin 2008-01-08 15:21:46 EST
The problem still does persist with pirut-1.3.28-1.fc8. 

Bug https://bugzilla.redhat.com/show_bug.cgi?id=375221 is marked as resolved. I
could not reopen it; doing so to this one.
Comment 4 Jeremy Katz 2008-01-14 10:59:44 EST
Can you attach the exact traceback you're getting now?
Comment 5 Maxim Egorushkin 2008-01-14 15:21:23 EST
The attachment in comment #1 is the exact stack trace with pirut-1.3.28-1.fc8
Comment 6 Maxim Egorushkin 2008-01-14 15:25:14 EST
I can provide ssh access to my machine, so that the crash can be debugged.
Comment 7 Andrey 2008-02-10 17:01:41 EST
Created attachment 294518 [details]
crash log

I can approve bug. x86_64 , the same steps. crash log in attachment.

Thanks.
Comment 8 Jeremy Katz 2008-05-28 15:27:43 EDT
This was a bug in the yum-priorities plugin which is fixed in the current package.

Note You need to log in before you can comment on or make changes to this bug.