Bug 427630 - Invalid certificates make websites inaccessible to epiphany
Invalid certificates make websites inaccessible to epiphany
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: epiphany (Show other bugs)
9
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
: 444433 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-05 14:03 EST by Joachim Frieben
Modified: 2008-07-18 09:48 EDT (History)
3 users (show)

See Also:
Fixed In Version: 2.22.1.1-1.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-15 01:19:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of invalid certificate notification suggesting to add an exception (57.98 KB, image/png)
2008-01-05 14:03 EST, Joachim Frieben
no flags Details

  None (edit)
Description Joachim Frieben 2008-01-05 14:03:42 EST
Description of problem:
After upgrading to epiphany-2.21.5-0.1.svn7844.fc9, popular secured
websites have become inaccessible because of invalid certificates.
Examples for affected pages/sites are:

  https://bugs.freedesktop.org
  https://fedorahosted.org/nodoka/wiki/Screenshots

Version-Release number of selected component (if applicable):
epiphany-2.21.5-0.1.svn7844.fc9

How reproducible:
Always.

Steps to Reproduce:
1. Upgrade to the latest epiphany browser built against XULRunner.
2. Launch epiphany and point it to
   https://fedorahosted.org/nodoka/wiki/Screenshots .
  
Actual results:
A page load error occurs claiming that a "Secure Connection Failed".
As a workaround, one is invited to add an exception for this webpage
in "Advanced Encryption Settings" which may be implemented for the
FF3 frontend but not for epiphany. This means, that currently,
there is no possibility to override this error message making the
page effectively unaccessible.

Expected results:
When there is no valid certificate, there might be a warning giving
the user the choice to either reject the certificate or accept the
certificate temporarily or even permanently.

Additional info:
For previous versions of epiphany built against FF2, it was possible
to override the certificate alert.
Comment 1 Joachim Frieben 2008-01-05 14:03:42 EST
Created attachment 290891 [details]
Screenshot of invalid certificate notification suggesting to add an exception
Comment 2 Joachim Frieben 2008-01-05 14:31:33 EST
Sorry for the poorly chosen 2nd example. I had copied the URL from a posting
to the Fedora development list. Using

  https://hosted.fedoraproject.org/nodoka/wiki/Screenshots

instead of 

  https://fedorahosted.org/nodoka/wiki/Screenshots

the screenshots section becomes actually accessible. However, it still
serves as an example, and in the case of the fdo bugzilla, the complaint
is about a self-signed certificate which is less obvious to deal with.
Comment 3 Martin Sourada 2008-04-02 06:57:27 EDT
Not sure if this might help solve the problem, but I noticed that I can set the
exeptions via Certificates extension. However, would be good to have it
accessible from the error page itself (like is done in firefox 3).
Comment 4 Joachim Frieben 2008-04-04 10:45:11 EDT
Ah, this actually works. I wonder whether epiphany should then depend
on epiphany-extensions. This requirement may however become obsolete
soon as GNOME is about to switch to the WebKit backend.
Comment 5 W. Michael Petullo 2008-04-17 01:58:35 EDT
I have epiphany-2.22.1.1-1.fc9.ppc installed and this version allows me to set
up exceptions for invalid SSL certificates, just like Firefox does.

I do not have Firefox nor any epiphany extensions installed. This functionality
now seems to be in the base epiphany package.

For me, this bug is fixed.
Comment 6 Bug Zapper 2008-05-14 00:17:33 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Mathieu Bridon 2008-05-14 19:06:05 EDT
I can totally reproduce this bug in epiphany-2.22.1.1-1.fc9.x86_64.
Comment 8 Bastien Nocera 2008-05-14 19:40:36 EDT
That particular bug (not having a button to add an exception) should be fixed
already. I filed bug 444433 about the button not bringing along the URL of the
place into the dialogue.
Comment 9 Joachim Frieben 2008-05-15 01:19:35 EDT
Right, it's possible to add exceptions by simply following the
instructions when encountering a page with an invalid certificate.
Closing the bug as CURRENTRELEASE.
Comment 10 Martin Stransky 2008-07-18 09:48:47 EDT
*** Bug 444433 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.