Bug 427717 - Anaconda exception at end of NFS install
Anaconda exception at end of NFS install
Status: CLOSED DUPLICATE of bug 427715
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
powerpc Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-06 21:36 EST by Olof Johansson
Modified: 2008-01-06 21:38 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-06 21:38:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Olof Johansson 2008-01-06 21:36:58 EST
Description of problem:


Version-Release number of selected component (if applicable):
Fedora rawhide as of Jan 6

How reproducible:
Install with NFS source (this was done on PPC).

My NFS source only contains a clone of the subtree under ppc/os, no iso images, etc.


The following anaconda exception is reported at the end, after installation of
all packages is complete:

anaconda 11.4.0.15 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/yuminstall.py", line 767, in complete
    if self.ayum._loopbackFile and (anaconda.mediaDevice or self.isodir):
  File "/usr/lib/anaconda/installmethod.py", line 30, in doMethodComplete
    anaconda.backend.complete(anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 209, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 132, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/text.py", line 653, in run
    anaconda.dispatch.gotoNext()
  File "/usr/bin/anaconda", line 1021, in <module>
    anaconda.intf.run(anaconda)
AttributeError: YumBackend instance has no attribute 'isodir'

Local variables in innermost frame:
self: <yuminstall.YumBackend instance at 0xf77df968>
anaconda: <__main__.Anaconda instance at 0xf7f00be8>
Comment 1 Olof Johansson 2008-01-06 21:38:57 EST
Alright, that was crappy of me, I didn't search properly before opening this.
It's already been filed: 427715.

*** This bug has been marked as a duplicate of 427715 ***

Note You need to log in before you can comment on or make changes to this bug.