Bug 427753 - yum
yum
Status: CLOSED DUPLICATE of bug 426975
Product: Fedora
Classification: Fedora
Component: yum-updatesd (Show other bugs)
8
All Linux
low Severity urgent
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-07 08:20 EST by Carlos
Modified: 2008-01-08 12:14 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-08 12:14:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bug file (10.05 KB, application/octet-stream)
2008-01-07 08:20 EST, Carlos
no flags Details

  None (edit)
Description Carlos 2008-01-07 08:20:03 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Component: pirut
Summary: TB4c8309c5 fastestmirror.py:97:postreposetup_hook:IndexError: list
index out of range

Traceback (most recent call last):
  File "/usr/sbin/pup", line 611, in <module>
    main()
  File "/usr/sbin/pup", line 607, in main
    pup.run()
  File "/usr/sbin/pup", line 447, in run
    self.doRefresh()
  File "/usr/sbin/pup", line 262, in doRefresh
    pbar = self.doRefreshRepos(destroy=False)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 339, in
doRefreshRepos
    self.reposSetup(pbar, thisrepo)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 303, in reposSetup
    self.doTsSetup()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 72, in doTsSetup
    return self._getTs()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 85, in _getTs
    self._getTsInfo()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 91, in _getTsInfo
    self._tsInfo.setDatabases(self.rpmdb, self.pkgSack)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 529, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 384, in _getSacks
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.5/site-packages/yum/repos.py", line 214, in populateSack
    self.doSetup()
  File "/usr/lib/python2.5/site-packages/yum/repos.py", line 66, in doSetup
    self.ayum.plugins.run('postreposetup')
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 169, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/fastestmirror.py", line 97, in postreposetup_hook
    conduit.info(2, " * %s: %s" % (str(repo), host(repo.urls[0])))
IndexError: list index out of range

Local variables in innermost frame:
repo: InstallMedia
conduit: <yum.plugins.PostRepoSetupPluginConduit instance at 0xa510a0c>
repos: ['livna-development', 'updates-source', 'livna-development-debuginfo',
'updates-testing', 'livna', 'updates-testing-source', 'livna-debuginfo',
'fedora', 'livna-testing', 'InstallMedia', 'development-source', 'development',
'updates-debuginfo', 'fedora-debuginfo', 'livna-development-source',
'updates-testing-debuginfo', 'updates', 'livna-source', 'fedora-source',
'development-debuginfo', 'livna-testing-debug', 'livna-testing-source']
repomirrors: {'InstallMedia': [], 'livna':
['http://rpm.livna.org/fedora/8/i386/',
'http://ftp-stud.fht-esslingen.de/pub/Mirrors/rpm.livna.org/fedora/8/i386/',
'http://wftp.tu-chemnitz.de/pub/linux/livna/fedora/8/i386/',
'http://livna.cat.pdx.edu/fedora/8/i386/',
'ftp://mirrors.tummy.com/pub/rpm.livna.org/fedora/8/i386/',
'http://mirror.atrpms.net/livna/fedora/8/i386/'], 'fedora':
['http://fedora.c3sl.ufpr.br/linux/releases/8/Everything/i386/os',
'http://mirror.hiwaay.net/pub/fedora/linux/releases/8/Everything/i386/os',
'http://mirror.cc.vt.edu/pub/fedora/linux/releases/8/Everything/i386/os',
'http://srl.cs.jhu.edu/YUM/fedora/releases/8/Everything/i386/os',
'http://mirror.steadfast.net/fedora/releases/8/Everything/i386/os',
'http://distro.ibiblio.org/pub/linux/distributions/fedora/linux/releases/8/Everything/i386/os',
'http://gulus.usherbrooke.ca/pub/distro/fedora/linux/releases/8/Everything/i386/os',
'ftp://ftp.uci.edu/mirrors/fedora/linux/releases/8/Everything/i386/os',
'http://ftp.linux.ncsu.edu/pub/fedora/linux/releases/8/Everything/i386/os',
'http://mirror.anl.gov/pub/fedora/linux/releases/8/Everything/i386/os',
'ftp://ftp.cse.buffalo.edu/pub/Linux/fedora/linux/releases/8/Everything/i386/os',
'http://ftp.usf.edu/pub/fedora/linux/releases/8/Everything/i386/os',
'ftp://mirror.colorado.edu/pub/fedora/linux/releases/8/Everything/i386/os',
'http://mirror.unl.edu/fedora/linux/releases/8/Everything/i386/os',
'http://mirrors.usc.edu/pub/linux/distributions/fedora/linux/releases/8/Everything/i386/os',
'http://ftp.linux.org.uk/pub/distributions/fedora/linux/releases/8/Everything/i386/os',
'http://ftp.nluug.nl/pub/os/Linux/distr/fedora/linux/releases/8/Everything/i386/os',
'http://ftp.uni-bayreuth.de/linux/fedora/linux/releases/8/Everything/i386/os',
'http://ftp.crihan.fr/mirrors/fedora.redhat.com/fedora/linux/releases/8/Everything/i386/os',
'http://mirror.switch.ch/ftp/mirror/fedora/linux/releases/8/Everything/i386/os',
'http://gd.tuwien.ac.at/opsys/linux/fedora/linux/releases/8/Everything/i386/os',
'ftp://ftp.quicknet.nl/pub/Linux/download.fedora.redhat.com/releases/8/Everything/i386/os',
'http://ftp.univie.ac.at/systems/linux/fedora/releases/8/Everything/i386/os',
'http://ftp.cica.es/fedora/linux/releases/8/Everything/i386/os',
'http://ftp.unina.it/pub/linux/distributions/fedora/linux/releases/8/Everything/i386/os',
'http://ftp-stud.hs-esslingen.de/pub/fedora/linux/releases/8/Everything/i386/os',
'http://redhat.linux.ee/pub/fedora/linux/releases/8/Everything/i386/os',
'http://ftp.funet.fi/pub/mirrors/fedora.redhat.com/pub/fedora/linux/releases/8/Everything/i386/os',
'ftp://ftp.cru.fr/pub/linux/fedora/releases/8/Everything/i386/os',
'http://sunsite.rediris.es/mirror/fedora-redhat/releases/8/Everything/i386/os',
'http://mirrors.linux.edu.lv/ftp.redhat.com/pub/fedora/linux/releases/8/Everything/i386/os',
'ftp://ftp.pbone.net/pub/fedora/linux/releases/8/Everything/i386/os',
'http://ftp.ntua.gr/pub/linux/fedora/linux/releases/8/Everything/i386/os',
'http://ftp.crc.dk/fedora/linux/releases/8/Everything/i386/os',
'http://ftp.udl.es/pub/fedora/linux/releases/8/Everything/i386/os',
'http://ftp.cc.uoc.gr/pub/fedora/linux/releases/8/Everything/i386/os',
'ftp://ftp.uib.no/pub/fedora/linux/releases/8/Everything/i386/os',
'http://ftp.ceid.upatras.gr/pub/fedora/linux/releases/8/Everything/i386/os',
'ftp://ftp.otenet.gr/pub/linux/fedora/linux/releases/8/Everything/i386/os',
'http://ftp.iasi.roedu.net/mirrors/fedora.redhat.com/linux/releases/8/Everything/i386/os',
'http://ftp.rhnet.is/pub/fedora/linux/releases/8/Everything/i386/os',
'http://mirror.newnanutilities.org/pub/fedora/linux/releases/8/Everything/i386/os',
'http://ftp.jaist.ac.jp/pub/Linux/Fedora/releases/8/Everything/i386/os',
'http://mirrors.reflected.net/fedora/linux/releases/8/Everything/i386/os',
'http://ftp.yz.yamagata-u.ac.jp/pub/linux/fedora/linux/releases/8/Everything/i386/os',
'http://mirror.optus.net/fedora/linux/releases/8/Everything/i386/os',
'ftp://ftp.software.umn.edu/linux/fedora/releases/8/Everything/i386/os',
'http://ftp.cse.yzu.edu.tw/pub/Linux/Fedora/releases/8/Everything/i386/os',
'http://opensource.nchc.org.tw/fedora/linux/releases/8/Everything/i386/os',
'http://linux.nssl.noaa.gov/fedora/linux/releases/8/Everything/i386/os',
'http://mirror.cogentco.com/pub/linux/fedora/linux/releases/8/Everything/i386/os',
'http://ftp.chg.ru/pub/Linux/fedora/linux/releases/8/Everything/i386/os',
'http://mirrors.kernel.org/fedora/releases/8/Everything/i386/os',
'ftp://mirror.nyi.net/fedora/linux/releases/8/Everything/i386/os',
'http://fedora.mirror.facebook.com/linux/releases/8/Everything/i386/os',
'http://ftp.osuosl.org/pub/fedora/linux/releases/8/Everything/i386/os',
'http://fr2.rpmfind.net/linux/fedora/releases/8/Everything/i386/os',
'http://mirror.web-ster.com/fedora/releases/8/Everything/i386/os',
'http://mirrors.cat.pdx.edu/fedora/linux/releases/8/Everything/i386/os',
'http://ftp.SURFnet.nl/pub/os/Linux/distr/fedora/linux/releases/8/Everything/i386/os',
'ftp://alviss.et.tudelft.nl/pub/fedora/linux/releases/8/Everything/i386/os',
'http://limestone.uoregon.edu/ftp/fedora/linux/releases/8/Everything/i386/os',
'http://fedora.tu-chemnitz.de/pub/linux/fedora/linux/releases/8/Everything/i386/os',
'http://ftp.stw-bonn.de/pub/fedora/linux/releases/8/Everything/i386/os',
'http://fedora.mirror.garr.it/mirrors/fedora/linux/releases/8/Everything/i386/os',
'http://fedora.mirror.iweb.ca/releases/8/Everything/i386/os',
'ftp://ftp.sunet.se/pub/Linux/distributions/fedora/linux/releases/8/Everything/i386/os',
'http://ftp.uni-koeln.de/mirrors/fedora/linux/releases/8/Everything/i386/os',
'http://mirror.nuvio.com/pub/fedora/linux/releases/8/Everything/i386/os',
'http://ftp.pwr.wroc.pl/pub/linux/fedora/linux/releases/8/Everything/i386/os',
'http://ftp.astral.ro/mirrors/fedora/pub/fedora/linux/releases/8/Everything/i386/os',
'http://mirror.internode.on.net/pub/fedora/linux/releases/8/Everything/i386/os',
'http://allotter.yandex.net/fedora/linux/releases/8/Everything/i386/os',
'http://mirrors.evrocom.net/fedora/linux/releases/8/Everything/i386/os',
'http://spreader.yandex.net/fedora/linux/releases/8/Everything/i386/os',
'http://ftp.lip6.fr/ftp/pub/linux/distributions/fedora/releases/8/Everything/i386/os',
'http://mirror.wbut.ac.in/pub/fedora/linux/releases/8/Everything/i386/os',
'http://mirror.karneval.cz/pub/linux/fedora/linux/releases/8/Everything/i386/os',
'http://mirrors.vexs.net/pub/fedora/linux/releases/8/Everything/i386/os',
'http://fedora.mirrors.megalan.bg/linux/releases/8/Everything/i386/os',
'http://ultra.linux.cz/MIRRORS/fedora.redhat.com/linux/releases/8/Everything/i386/os',
'http://ftp.gts.lug.ro/fedora/linux/releases/8/Everything/i386/os',
'http://sunsite.icm.edu.pl/pub/Linux/fedora/linux/releases/8/Everything/i386/os',
'http://ftp.linux.cz/pub/linux/fedora/linux/releases/8/Everything/i386/os',
'http://www.muug.mb.ca/pub/fedora/linux/releases/8/Everything/i386/os',
'ftp://ftp.netcraft.com.au/pub/fedora/linux/releases/8/Everything/i386/os',
'ftp://ftp.tudelft.nl/pub/Linux/download.fedora.redhat.com/linux/releases/8/Everything/i386/os',
'http://mirrors.ircam.fr/pub/fedora/linux/releases/8/Everything/i386/os',
'http://mirror.3fl.net.au/pub/fedora/linux/releases/8/Everything/i386/os',
'http://ftp.rhd.ru/pub/fedora/linux/releases/8/Everything/i386/os',
'ftp://ftp.uninett.no/pub/linux/Fedora/releases/8/Everything/i386/os',
'http://ftp.ncnu.edu.tw/Linux/Fedora/linux/releases/8/Everything/i386/os',
'http://mirror.pacific.net.au/linux/fedora/linux/releases/8/Everything/i386/os',
'http://ftp.riken.jp/Linux/fedora/releases/8/Everything/i386/os',
'ftp://ftp.cs.hacettepe.edu.tr/pub/mirrors/fedora/linux/releases/8/Everything/i386/os',
'http://fedora.candishosting.com.cn/pub/fedora/linux/releases/8/Everything/i386/os',
'http://fedora.glug-nith.org/linux/releases/8/Everything/i386/os',
'http://linux.ntcu.net/ftp/dists/fedora/releases/8/Everything/i386/os']}
Comment 1 Carlos 2008-01-07 08:20:03 EST
Created attachment 290951 [details]
bug file
Comment 2 Jeremy Katz 2008-01-08 12:14:41 EST

*** This bug has been marked as a duplicate of 426975 ***

Note You need to log in before you can comment on or make changes to this bug.