This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 427850 - libunwind mock build stuck in make test
libunwind mock build stuck in make test
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libunwind (Show other bugs)
rawhide
i386 Linux
low Severity low
: ---
: ---
Assigned To: Jan Kratochvil
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 434147
  Show dependency treegraph
 
Reported: 2008-01-07 15:39 EST by Matt Domsch
Modified: 2008-02-24 00:17 EST (History)
0 users

See Also:
Fixed In Version: libunwind-0.99-0.4.frysk20070405cvs.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-24 00:16:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Domsch 2008-01-07 15:39:19 EST
Description of problem:
libunwind-0.99-0.1.frysk20070405cvs.fc9 hangs during i386 mock build in 'make
test'.  Process consumes 100% CPU until killed.

Version-Release number of selected component (if applicable):
libunwind-0.99-0.1.frysk20070405cvs.fc9

How reproducible:
don't know

Steps to Reproduce:
1. build srpm in mock

Actual results:
build doesn't complete, test process must be killed off.

Expected results:
build completes

Additional info:
Comment 1 Jan Kratochvil 2008-02-24 00:16:03 EST
Committed to Rawhide:
* Sun Feb 24 2008 Jan Kratochvil <jan.kratochvil@redhat.com> -
0.99-0.4.frysk20070405cvs
- Abort the possibly hung up testcases after 120 seconds (BZ 427850, BZ 434147).

It works for me on F8, though.  The right way is to remove the testing from the
build and move it to a separate testing system (RHTS) as has been done with GDB.

./orphanripper: 21633 Timed out after 120 seconds: ./run-ptrace-stepper
./orphanripper: Killed -9 orphan PID 21651:
/builddir/build/BUILD/libunwind-0.99-alpha/tests/.libs/lt-test-ptrace-stepper
./orphanripper: Killed -9 orphan PID 21635:
/builddir/build/BUILD/libunwind-0.99-alpha/tests/.libs/lt-test-ptrace -t -b jump
foo+ __kernel_sigreturn lockup prefoo+ main+ __libc_start_main+ _start+
./test-ptrace-stepper
FAIL: run-ptrace-stepper
Backtrace does not match on level==2, want "bowler+", got "main"
Backtrace does not match on level==3, want "main+", got "__libc_start_main"
Backtrace does not match on level==4, want "__libc_start_main+", got "_start"
Too short backtrace on level==5, want "_start+"
FAILURE: detected 4 errors

Note You need to log in before you can comment on or make changes to this bug.