Bug 434147 - libunwind failed massrebuild attempt for GCC 4.3
libunwind failed massrebuild attempt for GCC 4.3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libunwind (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jan Kratochvil
Fedora Extras Quality Assurance
:
Depends On: 427850
Blocks: gcc43rebuildfail
  Show dependency treegraph
 
Reported: 2008-02-22 08:10 EST by Jesse Keating
Modified: 2013-01-09 21:58 EST (History)
1 user (show)

See Also:
Fixed In Version: libunwind-0.99-0.4.frysk20070405cvs.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-24 00:17:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of "ps -e -o pid,ppid,pgid,cmd fww" during a hung lt-test-ptrace (4.53 KB, text/plain)
2008-02-22 16:29 EST, Mike Bonnet
no flags Details

  None (edit)
Description Jesse Keating 2008-02-22 08:10:11 EST
This is an automatically filed bug for a failed rebuild attempt for GCC 4.3.

http://fedoraproject.org/wiki/JesseKeating/gcc43MassRebuildProposal

Please verify why this build failed and fix it.
http://koji.fedoraproject.org/koji/taskinfo?taskID=440103
Unknown exit code, check the failed task.
Comment 1 Mike Bonnet 2008-02-22 16:27:50 EST
The i386 and x86_64 builds were hung during the lt-test-ptrace test.  By hung I
mean they were consuming 100% cpu time.  I'm attaching the output of a "ps -e -o
pid,ppid,pgid,cmd fww" to the bug.  The second to last entry (lt-test-ptrace)
was taking up most of the cpu time, with lt-test-ptrace-stepper occasionally
taking a few %.

Could this be a kernel/xen issue?  The builders are running 2.6.18-53.1.6.el5xen.
Comment 2 Mike Bonnet 2008-02-22 16:29:40 EST
Created attachment 295678 [details]
Output of "ps -e -o pid,ppid,pgid,cmd fww" during a hung lt-test-ptrace
Comment 3 Jan Kratochvil 2008-02-22 16:42:03 EST
It is in fact a DUPLICATE of Bug 427850.
Going to fix it ASAP.
(No matter why the test(s) got locked up no test should be allowed to busy-loop
forever.)
Comment 4 Jan Kratochvil 2008-02-24 00:17:14 EST
Committed to Rawhide:
* Sun Feb 24 2008 Jan Kratochvil <jan.kratochvil@redhat.com> -
0.99-0.4.frysk20070405cvs
- Abort the possibly hung up testcases after 120 seconds (BZ 427850, BZ 434147).

It works for me on F8, though.  The right way is to remove the testing from the
build and move it to a separate testing system (RHTS) as has been done with GDB.

./orphanripper: 21633 Timed out after 120 seconds: ./run-ptrace-stepper
./orphanripper: Killed -9 orphan PID 21651:
/builddir/build/BUILD/libunwind-0.99-alpha/tests/.libs/lt-test-ptrace-stepper
./orphanripper: Killed -9 orphan PID 21635:
/builddir/build/BUILD/libunwind-0.99-alpha/tests/.libs/lt-test-ptrace -t -b jump
foo+ __kernel_sigreturn lockup prefoo+ main+ __libc_start_main+ _start+
./test-ptrace-stepper
FAIL: run-ptrace-stepper
Backtrace does not match on level==2, want "bowler+", got "main"
Backtrace does not match on level==3, want "main+", got "__libc_start_main"
Backtrace does not match on level==4, want "__libc_start_main+", got "_start"
Too short backtrace on level==5, want "_start+"
FAILURE: detected 4 errors

Note You need to log in before you can comment on or make changes to this bug.