Bug 427878 - NetworkManager will not connect to a network which doesn't broadcast ESSID
Summary: NetworkManager will not connect to a network which doesn't broadcast ESSID
Status: CLOSED DUPLICATE of bug 373841
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager   
(Show other bugs)
Version: 8
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-01-07 23:59 UTC by Matt Britt
Modified: 2008-01-10 23:35 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-10 23:35:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Matt Britt 2008-01-07 23:59:40 UTC
Description of problem:
When I attempt to connect to a wireless network (simple WEP key) which doesn't
broadcast ESSID in beacon frames using NetworkManager, it will not connect.  I
did not have this problems with previous Fedora versions.

I can connect to this network just fine if I use iwconfig manually, but the
appropriate radio settings (essid and key) are never set by NetworkManager, so I
assume something is getting hung up between NM and wpa_supplicant (not sure
which or where).  If I set the essid and key with iwconfig _while_ NM is
attempting to connect, it will successfully connect but nm-applet shows zero
signal strength (which is untrue, according to iwconfig).  I'm using the ipw2200
drivers.  Let me know what logs you want to see and I'll try to post them next
time I'm at work.

How reproducible:
Every time.

Steps to Reproduce:
1. Try to connect to hidden SSID network with nm-applet's "Connect to Other
Wireless Network" option.
2. Wait until nm-applet fails to connect and asks for a different wifi auth scheme.

Comment 1 Dan Williams 2008-01-10 23:35:32 UTC

*** This bug has been marked as a duplicate of 373841 ***


Note You need to log in before you can comment on or make changes to this bug.