Bug 428030 - When state is SND_PCM_STATE_PREPARED, let pulse_hw_params() work
When state is SND_PCM_STATE_PREPARED, let pulse_hw_params() work
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: alsa-plugins (Show other bugs)
8
All Linux
medium Severity medium
: ---
: ---
Assigned To: Eric Moret
Fedora Extras Quality Assurance
:
: 377701 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-08 15:07 EST by David Cantrell
Modified: 2008-01-27 02:22 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.0.15-2.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-27 02:22:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
1.0.14-pulse-SND_PCM_STATE_PREPARED.patch (812 bytes, patch)
2008-01-08 15:07 EST, David Cantrell
no flags Details | Diff

  None (edit)
Description David Cantrell 2008-01-08 15:07:18 EST
This is fixed upstream, but would be handy if an update was made for Fedora 8. 
I've built it locally and it works for me.  Here is the upstream bug:

https://bugtrack.alsa-project.org/alsa-bug/view.php?id=3470

My use case was trying to capture video from a DV camcorder on Fedora 8.  The
assertion shows up when you try to capture audio as well as video.

Attached is the patch I pulled from upstream, but made for the F-8 branch.
Comment 1 David Cantrell 2008-01-08 15:07:18 EST
Created attachment 291082 [details]
1.0.14-pulse-SND_PCM_STATE_PREPARED.patch
Comment 2 Eric Moret 2008-01-18 17:30:15 EST
*** Bug 377701 has been marked as a duplicate of this bug. ***
Comment 3 Eric Moret 2008-01-21 17:58:58 EST
I have updated the package. It is in testing now. Could you please test and give
it Karma points on bodhi.fedoraproject.org if it works for you. 3 karma points
should move it automatically to stable.
Comment 4 Fedora Update System 2008-01-27 02:22:35 EST
alsa-plugins-1.0.15-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.