Bug 428076 - X server hangs with "tossed event which came in late" + i810 driver problem
X server hangs with "tossed event which came in late" + i810 driver problem
Status: CLOSED DUPLICATE of bug 386091
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
rawhide
i386 Linux
low Severity high
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-08 22:06 EST by denis ivanov
Modified: 2008-01-30 17:32 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-30 17:32:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log from running without any /etc/X11/xorg.conf at all (119.04 KB, text/plain)
2008-01-14 11:14 EST, Matěj Cepl
no flags Details
/var/log/messages (in case anybody is interested) (1.45 MB, text/plain)
2008-01-14 16:03 EST, Matěj Cepl
no flags Details

  None (edit)
Description denis ivanov 2008-01-08 22:06:52 EST
Description of problem:

X server hangs with hundreds of "tossed event which came in late" messages in
Xorg.0.log; no keyboard reaction, only h/w mouse cursor working. Even can't drop
X by ctrl-alt-backspace or switch to another vt. Loggins remotely with ssh shows
100% of CPU loading by X process. killall X can't help, but killall -9 X kills
successfully

Version-Release number of selected component (if applicable):

xorg-x11-server-Xorg-1.4.99.1-0.13.fc9
xorg-x11-drv-i810-2.2.0-2.fc9

Driver: i810
DRI enabled (still not tried without DRI because need it always)
Composite extention disabled (tried both enabled/disabled)

How reproducible:

Seems common problem
(http://www.mail-archive.com/debian-bugs-dist@lists.debian.org/msg432155.html or
just google "tossed event which came in late").

Problem usually come when I try to switch between workspaces when both
workspaces containts gnome-terminal with multiple tabs.


Additional info:

Before I used fc8's xorg server without this problem.
Pls tell me how I can collect more information.
Comment 1 denis ivanov 2008-01-08 23:07:45 EST
Just tested it with DRI "off". The same result - it hangs after 10-20 switches
between virtual desktops with gnome-terminals loaded.

p.s. using xfce as desktop environment but seems it X server problem
Comment 2 denis ivanov 2008-01-08 23:10:53 EST
Also it seems happens when switching between virtual workspaces (desktops) only.
Comment 3 Matěj Cepl 2008-01-09 10:57:56 EST
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 4 denis ivanov 2008-01-11 09:50:29 EST
Unfortunately now I can't reproduce bug because have done new yum update and now
X server even can't load with intel driver! Just see part of log (intel.conf was
generated by X --configure with previous packages
xorg-x11-server-Xorg-1.4.99.1-0.13.fc9 xorg-x11-drv-i810-2.2.0-2.fc9).


(++) Using config file: "intel.conf"
dlopen: /usr/lib/xorg/modules/drivers//intel_drv.so: undefined symbol:
PictureScreenPrivateIndex
(EE) Failed to load /usr/lib/xorg/modules/drivers//intel_drv.so
(EE) Failed to load module "intel" (loader failed, 7)
(EE) No drivers available.



xorg-x11-server-Xorg-1.4.99.1-0.15.20080107.fc9 --- this one updated !
xorg-x11-drv-i810-2.2.0-2.fc9
Comment 5 denis ivanov 2008-01-11 10:02:01 EST
Now running without xorg.conf on Vesa driver. After many switching between
virtual workspaces seems no problem with 100% cpu load and X hangs up with
message "tossed event which came in late".

BUT keyboard/mouse problem continues. I'm switching workspaces with
Ctrl-Alt-left/right combination. After 10-20 fast switch/switch back, keyboard
driver seems like Ctrl key pressed (really it released ;) but for mouse
operations only (for example, in Firefox, mouse wheel does page zoom instead of
page scrolling). Xorg.0.log have no unusual entries about keyboard/mouse problems.

How to fix loading Intel driver to check previous issue?

One more issue: now I'm run kernel 2.6.23.1, still not rebooted to 2.6.24 from
rawhide, but I think it can cause errors like described in this bugreport ?

p.s. with fc8 this problem was never happen
Comment 6 Matěj Cepl 2008-01-14 09:00:30 EST
Still, can we get all those logs and configurations anyway (even with vesa), please?
Comment 7 Matěj Cepl 2008-01-14 11:13:09 EST
I have a good news and bad news for you. The good news is that (a bug triager of RH desktop team) can reproduce this on my computer pretty well. The bad news is that I have no clue what to do with it. It seems to me that the critical component is the latest kernel package in Rawhide. When booting (via Grub) version of kernel 2.6.24-0.150.rc7.git4.fc9 then the issue is reproducable. When however, I select kernel 2.6.24-0.130.rc7.fc9 then I can start X and work. Even that is not 100% perfect though -- whole X freezes something around once a day or so.

When the freeze happens, the symptoms are pretty same as yours.
Comment 8 Matěj Cepl 2008-01-14 11:13:55 EST
Reporter, but please still attach your /var/log/Xorg.*.log and /etc/X11/xorg.conf as well.
Comment 9 Matěj Cepl 2008-01-14 11:14:53 EST
Created attachment 291600 [details]
Xorg.0.log from running without any /etc/X11/xorg.conf at all
Comment 10 denis ivanov 2008-01-14 12:56:49 EST
Sorry, now I still can't run intel driver!

With vesa driver original bug never happened on my computer.

The new problem with keyboard after switching between workspaces produces no
errors in log and X server not hangs with 100% of cpu load.

Waiting to run intel driver to recheck original bug...
Comment 11 denis ivanov 2008-01-14 12:59:44 EST
Checked your log. My was almost the same, bottom is the usual log for X/i810 and
at bottom:

tossed event which came in late
tossed event which came in late
tossed event which came in late
tossed event which came in late
tossed event which came in late

(without
mieqEnequeue: out-of-order valuator event; dropping.)
Comment 12 denis ivanov 2008-01-14 15:54:28 EST
Updated rawhide today:

kernel-2.6.24-0.150.rc7.git4.fc9
xorg-x11-server-Xorg-1.4.99.1-0.15.20080107.fc9
xorg-x11-drv-i810-2.2.0-3.fc9

1) intel driver now loads ok (but DRI-mode bug #428078 still active)

2) seems no "tossed event which came in late" problem (but let me test it more!!!)

3) keyboard driver problem still (CTRL key stucked after 10-20 switches between
workspaces)
Comment 13 Matěj Cepl 2008-01-14 16:03:48 EST
Created attachment 291632 [details]
/var/log/messages (in case anybody is interested)
Comment 14 Matěj Cepl 2008-01-14 16:32:50 EST
Halfline, given my suspicion that gdm may be involved as well, because it never
starts up, adding you to Cc: Do you have any idea, what's going on?
Comment 15 denis ivanov 2008-01-14 16:41:02 EST
I have no gdm on my comp...
Comment 16 denis ivanov 2008-01-28 04:04:00 EST
Today status:

1) no more "tossed event which came in late" problem (tested few days)!

2) keyboard driver problem still (CTRL key stucked after 10-20 switches between
workspaces)! this is very very problem, to fix requires restart of X server !!!

3) today I switched to vesa driver again because i810 driver causes X to
segfault with kernel oops (DRM problem?):

Versions:

kernel-2.6.24-2.fc9.i686
xorg-x11-server-Xorg-1.4.99.1-0.18.20080107.fc9.i386
xorg-x11-drv-i810-2.2.0-3.fc9.i386

last lines from Xorg.0.log:

drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 14, (OK)

dmesg:
BUG: unable to handle kernel paging request at virtual address f8c0e148
printing eip: f8c1bfd6 *pde = 323bc067 *pte = 00000000 
Oops: 0000 [#12] SMP 

Pid: 28808, comm: X Tainted: P      D (2.6.24-2.fc9 #1)
EIP: 0060:[<f8c1bfd6>] EFLAGS: 00213282 CPU: 1
EIP is at i915_driver_lastclose+0x3e/0xec [i915]
EAX: f8c0d898 EBX: f019a1e4 ECX: f17a84d0 EDX: df9be3f0
ESI: f0199000 EDI: f019a000 EBP: e99c9ee8 ESP: e99c9ec8
 DS: 007b ES: 007b FS: 00d8 GS: 0033 SS: 0068
Process X (pid: 28808, ti=e99c9000 task=d5116000 task.ti=e99c9000)
Stack: f019a1f4 e99c9ef0 00000000 f019a000 f0199000 f019a1e4 f019a000 f019a000 
       e99c9f0c f8c833b0 00203246 f019a1e4 00000002 f019a1e4 f019a1e4 00000002 
       f019a000 e99c9f50 f8c842ef 00203246 e57f95c8 00000002 00000000 00000000 
Call Trace:
 [<c04064b6>] show_trace_log_lvl+0x1a/0x2f
 [<c0406566>] show_stack_log_lvl+0x9b/0xa3
 [<c0406615>] show_registers+0xa7/0x178
 [<c040681b>] die+0x135/0x220
 [<c0640bd3>] do_page_fault+0x553/0x631
 [<c063f25a>] error_code+0x72/0x78
 [<f8c833b0>] drm_lastclose+0x40/0x309 [drm]
 [<f8c842ef>] drm_release+0x3a9/0x3dc [drm]
 [<c049366c>] __fput+0xbe/0x16a
 [<c049392f>] fput+0x17/0x19
 [<c0490d5a>] filp_close+0x54/0x5c
 [<c0491f7a>] sys_close+0x76/0xb2
 [<c040526e>] syscall_call+0x7/0xb
 =======================
Code: 45 f0 8b 45 ec e8 b7 71 06 00 85 c0 0f 84 a1 00 00 00 8b 45 f0 83 78 08 00
0f 84 94 00 00 00 8b 45 ec 8b b0 e4 05 00 00 8b 46 08 <83> b8 b0 08 00 00 01 19
db 83 c3 03 83 3d 8c ce c9 f8 00 74 1c 
EIP: [<f8c1bfd6>] i915_driver_lastclose+0x3e/0xec [i915] SS:ESP 0068:e99c9ec8
---[ end trace 3a52f29051b78ff9 ]---

Comment 17 Matěj Cepl 2008-01-28 12:49:07 EST
I guess, it has something to do with bug 428813, right Dave? Should I close this
as DUPLICATE?
Comment 18 denis ivanov 2008-01-28 13:52:12 EST
Please don't forget here is two actual bugs...
Comment 19 Matěj Cepl 2008-01-28 18:20:47 EST
(In reply to comment #18)
> Please don't forget here is two actual bugs...

I am just looking into this -- could you please file a separate bug for the
mouse/keyboard stuff? Don't forget to reattach the files to the bug as well.

Thank you very much.
Comment 20 denis ivanov 2008-01-30 12:41:33 EST
Keyboard issue described in bug #386091 so it seems not actual here.

i810 driver failure with kernel oops...
Let me update to today's rawhide and test it again!
Comment 21 denis ivanov 2008-01-30 17:32:32 EST
i810 driver is ok now:

xorg-x11-server-Xorg-1.4.99.1-0.19.20080107.fc9.i386
xorg-x11-drv-i810-2.2.0-3.fc9.i386
kernel-2.6.24-9.fc9.i686

Please look deeper into bug #386091 (keyboard issue is still actual)

Thanks!


*** This bug has been marked as a duplicate of 386091 ***

Note You need to log in before you can comment on or make changes to this bug.