Bug 428102 - vtk won't build on rawhide against new Tcl 8.5
Summary: vtk won't build on rawhide against new Tcl 8.5
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: vtk   
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Axel Thimm
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 428672 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-01-09 08:23 UTC by Alex Lancaster
Modified: 2008-01-16 12:01 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-16 09:03:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
I needed at least this, didn't get the other error, probably just a BuildRequires needed (1.11 KB, patch)
2008-01-10 11:14 UTC, Caolan McNamara
no flags Details | Diff
Additional fixes for Python eggs (1.42 KB, patch)
2008-01-15 12:07 UTC, Alex Lancaster
no flags Details | Diff

Description Alex Lancaster 2008-01-09 08:23:59 UTC
The current version of vtk causes broken deps because it is built against tcl
8.4, but rawhide now ships 8.5, and hence needs to be rebuilt:

here's end of failed build.log:

-- Looking for glXGetProcAddressARB in GL/glx.h - FALSE
CMake Error: This project requires some variables to be set,
and cmake can not find them.
Please set the following variables:
TK_INTERNAL_PATH (ADVANCED)

koji build here: http://koji.fedoraproject.org/koji/taskinfo?taskID=336370

Seems that it doesn't know how to find the new Tcl.

(Also, if you didn't have ACLs on), I could help fix this, but I can't bump the
spec and rebuild.)

Comment 1 Caolan McNamara 2008-01-10 11:14:16 UTC
Created attachment 291264 [details]
I needed at least this, didn't get the other error, probably just a BuildRequires needed

Comment 2 Alex Lancaster 2008-01-15 12:07:52 UTC
Created attachment 291704 [details]
Additional fixes for Python eggs

The earlier patch needed an additional modification to include Python Egg
files, see:

http://fedoraproject.org/wiki/Packaging/Python/Eggs

I have added that feature, and now vtk builds correctly in rawhide, see:

http://koji.fedoraproject.org/koji/taskinfo?taskID=349849

Please apply this ASAP, or at least open up the ACLs so other's can build this
package.  Thanks.

Comment 3 Jason Tibbitts 2008-01-16 05:11:33 UTC
To save Axel the trouble, I went ahead and committed this patch and did a build:
http://koji.fedoraproject.org/koji/taskinfo?taskID=352138

The only thing I changed was the Caolan's changelog line, to add the dash before
the version so the formats were consistent.


Comment 4 Alex Lancaster 2008-01-16 09:03:51 UTC
Build now complete in rawhide.  Closing bug.

Comment 5 Axel Thimm 2008-01-16 12:01:23 UTC
*** Bug 428672 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.