Bug 42813 - unable to install jetdirect printer
unable to install jetdirect printer
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: printconf (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
: 47638 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-30 05:05 EDT by Peter Huebschen
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-24 06:15:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of strace -olog2.txt printtool (287.78 KB, text/plain)
2001-10-10 10:29 EDT, Giuseppe Raimondi
no flags Details

  None (edit)
Description Peter Huebschen 2001-05-30 05:05:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [de] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
printconf-gui denies to create jetdirect printerqueue and it gives an error
message (see below). If I reopen printconf-gui it crashes with the same
error and I can't print.


How reproducible:
Always

Steps to Reproduce:
1. Use a fresh installation of alchemist, printconf, printconf-gui from
RH7.1 CD
2. Start printconf-gui via a shell
3. Create an jetdirect-printer as normal => First error message
4. Save changes and close printconf-gui
5. Start printconf-gui again and it crashes again =>Second error message
	

Actual Results:  I get the following error message:
File "/usr/sbin/printconf-gui", line 567, in gizmo_queue_description
    details = _("%s JetDirect queue %s:%s") % (
ValueError: unsupported format character 'S' (0x53)


Expected Results:  There should be created a jetdirect printerqueue.

Additional info:

If I change at line 567: _("%s JetDirect queue %s:%s") to _("%s JetDirect
queue %s on %s") everything works fine. It seems that ":" creates this
error.
It's the rpm that shipped with RH 7.1.
Comment 1 Giuseppe Raimondi 2001-10-10 09:29:11 EDT
I just had a customer with an up2dated 7.1 and he had the same symptoms.

workaround as above seemed to help.

printconf-0.2.12-1

printconf-gui-0.2.12-1

pygtk-0.6.6-7

pygnome-1.0.53-7

pygnome-libglade-0.6.6-7

pygtk-libglade-0.6.6-7

perl-5.6.0-12

I'll attach a strace from the customer for more info

Giuseppe
Comment 2 Giuseppe Raimondi 2001-10-10 10:29:08 EDT
Created attachment 33761 [details]
output of strace -olog2.txt printtool
Comment 3 Tim Waugh 2002-01-10 07:34:59 EST
Is this bug still current?  The 7.2 package doesn't seem to have the same line 
anywhere.
Comment 4 Tim Waugh 2002-01-10 07:41:24 EST
*** Bug 47638 has been marked as a duplicate of this bug. ***
Comment 5 Peter Huebschen 2002-01-24 04:16:07 EST
With RH7.2 I did not get this error message, but with a clean RH7.2 I couldn't
print either. First I had to install the available printing related updates due
to errors in the Laserjet 4 printer driver.

Peter
Comment 6 Tim Waugh 2002-01-24 06:15:00 EST
But with those updates the problem is fixed?
Comment 7 Tim Waugh 2002-07-08 09:24:52 EDT
This was a translation problem.

Note You need to log in before you can comment on or make changes to this bug.