Bug 428211 - Package Review of gtk-vnc-0.3.2 requested
Package Review of gtk-vnc-0.3.2 requested
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: Package Review (Show other bugs)
5.2
All Linux
high Severity low
: rc
: ---
Assigned To: Tim Burke
:
Depends On:
Blocks: 188273 428162 428717
  Show dependency treegraph
 
Reported: 2008-01-09 17:50 EST by Suzanne Yeghiayan
Modified: 2010-02-01 07:00 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-01 07:00:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed GTK-VNC rpm (383.48 KB, application/octet-stream)
2008-01-14 14:52 EST, Daniel Berrange
no flags Details

  None (edit)
Description Suzanne Yeghiayan 2008-01-09 17:50:15 EST
Description of problem:

New package gtk-vnc 0.3.2 required for virt-manager

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Daniel Berrange 2008-01-14 14:52:01 EST
Created attachment 291619 [details]
Proposed GTK-VNC rpm
Comment 2 Daniel Berrange 2008-01-14 14:58:25 EST
Original Fedora Review notes

https://bugzilla.redhat.com/show_bug.cgi?id=252418
Comment 3 Bill Burns 2008-01-14 15:57:40 EST
Review:
+ package builds in mock (development i386).
+ rpmlint is silent for SRPM and RPM.
+ source files match upstream.
f0781695819bd00d5ba160205723a3b4  gtk-vnc-0.1.0.tar.gz
+ package meets naming and packaging guidelines.
+ specfile is properly named, is cleanly written
+ Spec file is written in American English.
+ Spec file is legible.
+ dist tag is present.
+ build root is correct.
+ license is open source-compatible.
+ License text is included in package.
+ %doc files present.
+ BuildRequires are proper.
+ %clean is present.
+ package installed properly.
+ Macro use appears rather consistent.
+ Package contains code.
+ no static libraries.
+ gtk-vnc-1.0.pc file present.
+ -devel subpackage exists.
+ no .la files.
+ no translations are available.
+ Does owns the directories it creates.
+ no duplicates in %files.
+ file permissions are appropriate.
+ ldconfig scriptlets are used.
+ gtk-vnc-0.1.0-3.fc8 rpm
=>Provides: libgtk-vnc-1.0.so.0
=>Requires: libatk-1.0.so.0 libc.so.6 libc.so.6(GLIBC_2.0) libc.so.6(GLIBC_2.1)
libc.so.6(GLIBC_2.1.3) libc.so.6(GLIBC_2.2) libc.so.6(GLIBC_2.3.4)
libc.so.6(GLIBC_2.4) libcairo.so.2 libdl.so.2 libgdk-x11-2.0.so.0
libgdk_pixbuf-2.0.so.0 libglib-2.0.so.0 libgmodule-2.0.so.0 libgnutls.so.13
libgnutls.so.13(GNUTLS_1_3) libgobject-2.0.so.0 libgtk-vnc-1.0.so.0
libgtk-x11-2.0.so.0 libpango-1.0.so.0 libpangocairo-1.0.so.0 rtld(GNU_HASH)
+ gtk-vnc-devel-0.1.0-3.fc8 rpm
=>Requires: gnutls-devel gtk-vnc = 0.1.0 gtk2-devel libgtk-vnc-1.0.so.0
pkgconfig pygtk2-devel
+ gtk-vnc-python-0.1.0-3.fc8 rpm
=>Provides: gtkvnc.so
=>Requires: gtk-vnc = 0.1.0 libc.so.6 libc.so.6(GLIBC_2.0)
libc.so.6(GLIBC_2.1.3) libglib-2.0.so.0 libgobject-2.0.so.0 libgtk-vnc-1.0.so.0
python(abi) = 2.5 rtld(GNU_HASH)

+ Not a GUI app.

No significant changes since the Fedora review.
 
APPROVED.

Comment 4 Bill Burns 2008-01-14 16:00:52 EST
Setting flags.
Comment 5 RHEL Product and Program Management 2008-01-14 16:05:34 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 6 Daniel Riek 2008-01-17 15:08:22 EST
Moving to RHEL-ACCEPT based on comment 3
Comment 7 Don Domingo 2008-04-01 22:14:10 EDT
Hi,
the RHEL5.2 release notes will be dropped to translation on April 15, 2008, at
which point no further additions or revisions will be entertained.

a mockup of the RHEL5.2 release notes can be viewed at the following link:
http://intranet.corp.redhat.com/ic/intranet/RHEL5u2relnotesmockup.html

please use the aforementioned link to verify if your bugzilla is already in the
release notes (if it needs to be). each item in the release notes contains a
link to its original bug; as such, you can search through the release notes by
bug number.

Cheers,
Don

Note You need to log in before you can comment on or make changes to this bug.