Bug 428246 - hp-check fails with "ImportError: No module named installer" traceback
hp-check fails with "ImportError: No module named installer" traceback
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F8Target 447083
  Show dependency treegraph
 
Reported: 2008-01-10 05:43 EST by Russell Odom
Modified: 2008-05-17 14:34 EDT (History)
0 users

See Also:
Fixed In Version: 2.7.12-4.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-29 00:14:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Russell Odom 2008-01-10 05:43:30 EST
Description of problem:
As per bug 243273 comment 4 and bug 243273 comment 25...

[root@detritus ~]# hp-check
Traceback (most recent call last):
  File "/usr/bin/hp-check", line 37, in <module>
    from installer import dcheck
ImportError: No module named installer

Version-Release number of selected component (if applicable):
hplip-gui-2.7.7-6.fc8.x86_64

How reproducible:
Every time

Additional info:
A patch is mentioned in bug 222639 comment 2 but I don't know if that's related
(I can't find any other reference to it).
Comment 1 Fedora Update System 2008-01-22 10:47:58 EST
hplip-2.7.12-2.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hplip'
Comment 2 Tim Waugh 2008-01-23 10:55:21 EST
Works for me (although hp-check output does not really make much sense in a
packaged environment).
Comment 3 Russell Odom 2008-01-24 04:05:51 EST
Works for me too. Thanks Tim!
Comment 4 Fedora Update System 2008-01-27 02:11:12 EST
hplip-2.7.12-4.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hplip'.  You can provide feedback for this update here: http://admin.fedoraproject.org/F8/FEDORA-2008-0820
Comment 5 Fedora Update System 2008-01-29 00:14:02 EST
hplip-2.7.12-4.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.