Bug 428438 - (t61p+nv@install) Installation fails with black screen on Lenovo t61p with nvidia
Installation fails with black screen on Lenovo t61p with nvidia
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-drv-nv (Show other bugs)
5.1
i386 Linux
low Severity low
: rc
: ---
Assigned To: Adam Jackson
desktop-bugs@redhat.com
:
: 427635 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-11 10:24 EST by Juha Tuomala
Modified: 2010-10-22 17:41 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 17:05:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmidecode data (15.57 KB, text/plain)
2008-02-20 09:44 EST, Christian Jung
no flags Details
xorg.conf (831 bytes, application/octet-stream)
2008-02-20 09:44 EST, Christian Jung
no flags Details
startx without /etc/X11/xorg.conf (35.64 KB, application/octet-stream)
2008-02-20 09:45 EST, Christian Jung
no flags Details
startx with config from comment #6 (33.68 KB, application/octet-stream)
2008-02-20 09:45 EST, Christian Jung
no flags Details

  None (edit)
Description Juha Tuomala 2008-01-11 10:24:25 EST
Description of problem:

If you try to make installation into Lenovo t61p with nvidia chipset, 
the installation will fail with black screen when the graphical part 
of the installation starts.

kudzu claims that nv driver is okay and thus tries to use it, so this would 
need temporary hwdata fix nv->vesa until the nv driver is fixed.

Installation can be done in text mode and changing to the vesa driver until 
the firstboot starts.


Version-Release number of selected component (if applicable):

RHEL 5u1 still suffers this. Don't have exact pkg versions atm.

How reproducible:

Always.

Wish I had more info but don't have the hw at hand atm. I'll try
add more detailed info to this entry later.
Comment 1 Juha Tuomala 2008-01-11 10:35:46 EST
dmi:

System Information
	Manufacturer: LENOVO
	Product Name: 6458BQ3
	Version: ThinkPad T61p

lshw:
           *-display
                description: VGA compatible controller
                product: Quadro FX 570M
                vendor: nVidia Corporation
                physical id: 0
                bus info: pci@0000:01:00.0
                version: a1
                width: 64 bits
                clock: 33MHz
                capabilities: pm msi pciexpress vga bus_master cap_list
                configuration: driver=nvidia latency=0 module=nvidia

Comment 2 Matěj Cepl 2008-01-24 08:35:00 EST
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 Juha Tuomala 2008-01-24 10:35:54 EST
I will do that. The unfortunate fact is that I don't have these devices at hand 
at the moment (had it for some days for making this bug report). But I order 
one and come back with those files once it gets delivered.
Comment 4 Matěj Cepl 2008-01-24 12:22:20 EST
Thanks, but you don't have to sweat about this -- if you are not able to provide
this information, I will close this, and somebody else will come with it again.
Comment 5 Christian Jung 2008-02-20 09:44:10 EST
Created attachment 295419 [details]
dmidecode data

I have access to the same kind of hardware as the original reporter. I update
this ticket with all requested information.
Comment 6 Christian Jung 2008-02-20 09:44:36 EST
Created attachment 295420 [details]
xorg.conf
Comment 7 Christian Jung 2008-02-20 09:45:06 EST
Created attachment 295421 [details]
startx without /etc/X11/xorg.conf
Comment 8 Christian Jung 2008-02-20 09:45:38 EST
Created attachment 295422 [details]
startx with config from comment #6
Comment 9 Alan Matsuoka 2008-02-21 09:19:16 EST
The customer has confirmed that this problem is resolved by the candidate builds
for RHEL 5.2. Please attach to BZ#428438 so that we can set the status to
Waiting On Engineering.
Comment 10 Juha Tuomala 2008-02-21 09:51:59 EST
This looks great, I'll test it asap when I get one such thingy to hand. :)
Comment 11 Matěj Cepl 2008-02-21 10:25:34 EST
OK, let us know. In meanwhile setting the bug into NEEDINFO(reporter) state.
Comment 12 Juha Tuomala 2008-02-25 06:03:43 EST
this is probably a duplicate for bug #427635
Comment 13 Matěj Cepl 2008-02-25 11:58:54 EST
*** Bug 427635 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.