Bug 428482 - Azureus GUI will not show
Azureus GUI will not show
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: azureus (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Lillian Angel
Fedora Extras Quality Assurance
: Reopened
: 429036 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-11 17:55 EST by E Mair
Modified: 2008-01-30 22:38 EST (History)
7 users (show)

See Also:
Fixed In Version: 8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-16 16:05:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description E Mair 2008-01-11 17:55:51 EST
Description of problem:

When starting Azureus, it will not start the GUI and it doesn't create an icon
in the system tray. All it does is displaying a requester that says:

"Error Initialize MainWindow
org/gnu/gtk/IconTheme"

Clicking on the "Details" button in the requester reveals this text:

"java.lang.NoClassDefFoundError: org/gnu/gtk/IconTheme
	at org.gudy.azureus2.ui.swt.ImageRepository.getThemedIcon(ImageRepository.java:77)
	at org.gudy.azureus2.ui.swt.ImageRepository.loadImages(ImageRepository.java:145)
	at
com.aelitis.azureus.ui.swt.shells.main.MainWindow.createWindow(MainWindow.java:451)
	at
com.aelitis.azureus.ui.swt.shells.main.MainWindow$1.runSupport(MainWindow.java:198)
	at org.gudy.azureus2.core3.util.AERunnable.run(AERunnable.java:38)
	at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
	at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:123)
	at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:3296)
	at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:2974)
	at org.gudy.azureus2.ui.swt.mainwindow.SWTThread.<init>(SWTThread.java:156)
	at org.gudy.azureus2.ui.swt.mainwindow.SWTThread.createInstance(SWTThread.java:68)
	at org.gudy.azureus2.ui.swt.mainwindow.Initializer.<init>(Initializer.java:102)
	at org.gudy.azureus2.ui.swt.Main.<init>(Main.java:80)
	at org.gudy.azureus2.ui.swt.Main.main(Main.java:203)"

Version-Release number of selected component (if applicable):
azureus-3.0.3.4-2.fc8

$ java -version
java version "1.6.0_03"
Java(TM) SE Runtime Environment (build 1.6.0_03-b05)
Java HotSpot(TM) Client VM (build 1.6.0_03-b05, mixed mode)

How reproducible:
Always.

Steps to Reproduce:
1. Update from the last 2.x azureus release for F8 to azureus-3.0.3.4-2.fc8
2. Run Azureus from the GNOME menu.
  
Actual results:
No GUI. No systray icon. Only an error message, and two running processes:

Process 1: /bin/sh /usr/bin/azureus

Process 2: java -Dazureus.install.path=[my-home-dir]/.azureus/ app
-Dazureus.script.version=2 - Dazureus.script=/usr/bin/azureus
org.gudy.azureus2.ui.swt.Main

Expected results:
Azureus should start up and show its GUI.

Additional info:
Renaming the old .azureus directory from azureus v2.x didn't help.
Comment 1 Lillian Angel 2008-01-14 11:07:51 EST
I tested this out and it works fine. Though by looking at your processes, it
looks like it is not running the correct azureus. 

This is not a bug, and maybe you should re-test this once it shows up in the F-8
updates.

vi /usr/bin/azureus - you should see this:
MOZILLA_FIVE_HOME=/usr/lib/firefox-2.0.0.10/ JAVA_HOME=/usr/lib/jvm/java-icedtea
LD_LIBRARY_PATH=$MOZILLA_FIVE_HOME:/usr/lib/eclipse/plugins/:/usr/lib/eclipse/:/usr/lib/
CLASSPATH=/usr/lib/eclipse/swt.jar:`build-classpath bcprov jakarta-commons-cli
log4j gtk2.8 glib0.2`:/usr/share/azureus/Azureus2.jar java
-Dazureus.install.path=$APPDIR -Dazureus.script.version=$SCRIPT_VERSION
-Dazureus.script=$0 org.gudy.azureus2.ui.swt.Main "$@"
Comment 2 E Mair 2008-01-14 12:07:01 EST
That is the exact text found in my /usr/bin/azureus script. I just checked with
diff.

I omitted my real username in the process listing in my report, sorry if that
was unclear. Now I also see a typo in the java process, there are a couple of
spaces that weren't there, my mistake.

Copy-n-paste of the correct process, again with username edited out:

java -Dazureus.install.path=/home/<username>/.azureus/app
-Dazureus.script.version=2 -Dazureus.script=/usr/bin/azureus
org.gudy.azureus2.ui.swt.Main
Comment 3 E Mair 2008-01-15 21:04:24 EST
Installed azureus-3.0.3.4-2.fc8.i386.rpm from the F8 updates mirror at
ftp.funet.fi today. Exact same version/release number, but different RPM file
sizes: The RPM from Koji was 15027913 bytes, the new one from F8 updates is
15028073 bytes.

There's no difference in behaviour though. No GUI, and the same error message.
Comment 4 Lillian Angel 2008-01-15 22:49:34 EST
I suspect this might be an issue only on your side since I cannot reproduce it. I will keep this bug report 
open, for sake of other users that might encounter the same problem.
Comment 5 Lillian Angel 2008-01-15 23:05:21 EST
In the meantime, please give me more information:

rpm -qa libswt3-gtk2 ?
rpm -qa libgtk-java ? This should be version 2.8.
Comment 6 Lillian Angel 2008-01-15 23:11:34 EST
rpm -qa libglib-java ?
Comment 7 E Mair 2008-01-15 23:20:11 EST
libswt3-gtk2-3.3.1.1-13.fc8
libgtk-java-2.8.7-5.fc8
No libglib-java installed or available through yum.
Comment 8 E Mair 2008-01-15 23:30:44 EST
I just found a glib-java installed, if that helps:
glib-java-0.2.6-10.fc8
Comment 9 Alex Lancaster 2008-01-15 23:43:41 EST
I get the same error:

$ rpm -q libgtk-java libswt3-gtk2
libgtk-java-2.8.7-4.fc7
libswt3-gtk2-3.3.0-30.fc8

looks like glib-java-0.2.6-10.fc8 wasn't pushed at the same time and is still in
updates-testing:

https://admin.fedoraproject.org/updates/F8/FEDORA-2008-0461

this might be the underlying cause of this?
Comment 10 Alex Lancaster 2008-01-15 23:58:54 EST
Hmm, tried updating from updates-testing:

sudo yum --enablerepo=updates-testing install glib-java

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Updating:
 glib-java               i386       0.2.6-10.fc8     updates-testing    37 k


but no luck.  For further reference this is my java version:

$ java -version
java version "1.7.0"
IcedTea Runtime Environment (build 1.7.0-b21)
IcedTea Client VM (build 1.7.0-b21, mixed mode)
Comment 11 Lillian Angel 2008-01-16 08:25:32 EST
https://admin.fedoraproject.org/updates/F8/FEDORA-2008-0461

this might be the cause. I have not updated to these versions:
$ rpm -qa glib-java
glib-java-0.2.6-8.fc7

I will update my glib-java and retest this. In the meantime, try downgrading to glib-java-0.2.6-8.fc7.
Comment 12 Mathieu Brabant 2008-01-16 08:31:32 EST
Same problem here.

libgtk-java-2.8.7-4.fc7
libswt3-gtk2-3.3.0-30.fc8
glib-java-0.2.6-8.fc7

java version "1.7.0"
IcedTea Runtime Environment (build 1.7.0-b21)
IcedTea Client VM (build 1.7.0-b21, mixed mode)
Comment 13 Alex Lancaster 2008-01-16 08:36:08 EST
(In reply to comment #11)
> https://admin.fedoraproject.org/updates/F8/FEDORA-2008-0461

> I will update my glib-java and retest this. In the meantime, try downgrading
to glib-java-0.2.6-8.fc7.

That's the version I was originally using when I first ran into the problem, I
get the same issue with both the old or new glib-java. 

Comment 14 Lillian Angel 2008-01-16 08:43:01 EST
Ok, these packages obviously don't have any effect on azureus. I have completely updated my system, and 
I am still able to run azureus fine. I will keep working on reproducing it.

If urgent, you can try upgrading to azureus in rawhide.
Comment 15 Lillian Angel 2008-01-16 08:51:31 EST
This is definitely a problem with libgtk-java
Comment 16 Lillian Angel 2008-01-16 08:54:38 EST
$ jar tf /usr/share/java/gtk2.8.jar | grep IconTheme
org/gnu/gtk/IconTheme.class


Can you try doing this? If you don't have that jar, that is the problem.
Comment 17 Alex Lancaster 2008-01-16 09:09:52 EST
I don't have jar installed, but unzip -l works and it looks like IconTheme is
installed:

$ unzip -l /usr/share/java/gtk2.8.jar |grep IconTheme
3959  09-14-06 22:14   org/gnu/gtk/IconTheme.class
Comment 18 Lillian Angel 2008-01-16 09:32:30 EST
$ echo `build-classpath bcprov jakarta-commons-cli log4j gtk2.8 glib0.2`   ?

Mine gives:
/usr/share/java/bcprov.jar:/usr/share/java/jakarta-commons-cli.jar:/usr/share/java/log4j.jar:/usr/share/java/gtk2.8.jar:/usr/share/java/glib0.2.jar

This might be a problem with how CLASSPATH is set up in the /usr/bin/azureus script.
Comment 19 E Mair 2008-01-16 10:19:54 EST
$ echo `build-classpath bcprov jakarta-commons-cli log4j gtk2.8 glib0.2`
/usr/share/java/bcprov.jar:/usr/share/java/jakarta-commons-cli.jar:/usr/share/java/log4j.jar:/usr/share/java/gtk2.8.jar:/usr/share/java/glib0.2.jar

and

$ jar tf /usr/share/java/gtk2.8.jar | grep IconTheme
org/gnu/gtk/IconTheme.class
Comment 20 Lillian Angel 2008-01-16 11:19:19 EST
Do you have CLASSPATH set elsewhere? It may be overriding that defined in azureus.
Comment 21 Lillian Angel 2008-01-16 11:31:51 EST
That probably isnt it. Though if you had azureus 2.5.0 running fine without this
error, then this is even more unusual.

Thanks for your patience. Still looking....
Comment 22 Lillian Angel 2008-01-16 12:10:04 EST
I applied a patch that might fix this problem. Before I build it into the
updates repo, can you try installing the rpms found here:

http://langel.fedorapeople.org/azureus-test-rpms/
Comment 23 Mathieu Brabant 2008-01-16 12:24:45 EST
Same problem with this new RPM (azureus-3.0.3.4-3.fc8) with the addition that
the splash screen and GUI error message does not display at all.

Comment 24 Lillian Angel 2008-01-16 12:25:36 EST
strange. ok thanks, ill keep looking.
Comment 25 E Mair 2008-01-16 12:31:08 EST
Same result as in comment #23.

Output from running this version from a shell:

$ azureus
[GUI] Initialization fails:
DEBUG::Wed Jan 16 18:22:08 CET
2008::org.gudy.azureus2.ui.swt.mainwindow.Initializer::run::305:
  java.lang.NoClassDefFoundError: org/gnu/gtk/Gtk
	at org.gudy.azureus2.ui.swt.mainwindow.Initializer.run(Initializer.java:127)
	at org.gudy.azureus2.ui.swt.mainwindow.SWTThread$2.runSupport(SWTThread.java:146)
	at org.gudy.azureus2.core3.util.AERunnable.run(AERunnable.java:38)
	at java.lang.Thread.run(Thread.java:619)
Comment 26 Lillian Angel 2008-01-16 12:36:42 EST
Ok it seems as though libgtk-java is not being loaded. 
Comment 27 Lillian Angel 2008-01-16 12:39:47 EST
is this happening on i386 or x86_64?
Comment 28 E Mair 2008-01-16 12:46:12 EST
For me, i386.
Comment 29 Andrew Overholt 2008-01-16 12:53:51 EST
This may be way off base, but does azureus cache things somewhere in ~ ?  If so,
is there a -clean startup option?
Comment 30 Lillian Angel 2008-01-16 12:55:32 EST
~/.azureus can be deleted. This might help, but i think someone tried this already.
Comment 31 Mathieu Brabant 2008-01-16 12:59:34 EST
I'm on i386.  Deleting ~/.azureus did not solve the problem.
Comment 32 Lillian Angel 2008-01-16 15:35:33 EST
I took out the azureus gtk custom theme patch. This will surely fix the problem.
Please test out the rpms found here:

http://langel.fedorapeople.org/azureus-test-rpms/
Comment 33 Mathieu Brabant 2008-01-16 16:03:51 EST
azureus-3.0.3.4-3.fc8.i686.rpm fixed the problem !

Thank you for your efforts.
Comment 34 Lillian Angel 2008-01-16 16:05:23 EST
Great! I am building it into rawhide and F-8 now. It should be available through
yum within the next couple of days.
Comment 35 E Mair 2008-01-16 16:42:13 EST
Works for me too. Thank you!
Comment 36 Lillian Angel 2008-01-16 17:39:30 EST
*** Bug 429036 has been marked as a duplicate of this bug. ***
Comment 37 Alex Lancaster 2008-01-16 20:25:07 EST
Works for me too.  Azureus has really changed with this update. 

(PS: Is there anyway to disable the Flash animation bar at the top?  Please
reply off-bug).
Comment 38 Lillian Angel 2008-01-16 23:43:04 EST
You can vote for azureus to go into updates here:
https://admin.fedoraproject.org/updates/F8/pending/azureus-3.0.3.4-3.fc8
Comment 39 Andrew Farris 2008-01-20 16:16:08 EST
I also had this issue and the update does fix it, should go to updates-testing.
Comment 40 Fedora Update System 2008-01-22 10:50:42 EST
azureus-3.0.3.4-3.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.