Bug 429036 - azureus fails to start
azureus fails to start
Status: CLOSED DUPLICATE of bug 428482
Product: Fedora
Classification: Fedora
Component: azureus (Show other bugs)
8
All Linux
low Severity urgent
: ---
: ---
Assigned To: Lillian Angel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-16 17:31 EST by Gen Zhang
Modified: 2008-01-16 17:39 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-16 17:39:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gen Zhang 2008-01-16 17:31:59 EST
Description of problem:

Azureus fails to start. The splash screen briefly flashes.

Console output:

Locale Initializing took 377ms
   Core: 25ms for Loading Plugin : bdcc
   Core: 25ms for Loading Plugin : azplugins
   Core: 151ms for Loading Plugin : Built In
   Core: 126ms for Initializing Global Torrent Manager
   Core: 125ms for Initializing Plugin: BitTorrent IRC Bot Plugin
   Core: 50ms for Initializing Plugin: Tracker Static Pages
   Core: 50ms for Initializing Plugin: Tracker Static Pages
   Core: 25ms for Initializing Plugin: DownloadRemoveRulesPlugin
   Core: 25ms for Initializing Plugin: UPnP
   Core: 25ms for Initializing Plugin: DHT Tracker
DEBUG::Wed Jan 16 22:29:51 GMT 2008  ExternalStimulus debug
Core Initializing took 711ms
[alert] Alert:3:Error Initialize MainWindow
DEBUG::Wed Jan 16 22:29:51 GMT
2008::com.aelitis.azureus.ui.swt.shells.main.MainWindow$1::runSupport::200:
   Core: 159ms for Initializing Plugin: azlocaltracker
  java.lang.NoClassDefFoundError: org/gnu/gtk/IconTheme
        at
org.gudy.azureus2.ui.swt.ImageRepository.getThemedIcon(ImageRepository.java:77)
        at
org.gudy.azureus2.ui.swt.ImageRepository.loadImages(ImageRepository.java:145)
        at
com.aelitis.azureus.ui.swt.shells.main.MainWindow.createWindow(MainWindow.java:451)
        at
com.aelitis.azureus.ui.swt.shells.main.MainWindow$1.runSupport(MainWindow.java:198)
        at org.gudy.azureus2.core3.util.AERunnable.run(AERunnable.java:38)
        at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
        at
org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:123)
        at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:3296)
        at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:2974)
        at org.gudy.azureus2.ui.swt.mainwindow.SWTThread.<init>(SWTThread.java:156)
        at
org.gudy.azureus2.ui.swt.mainwindow.SWTThread.createInstance(SWTThread.java:68)
        at
org.gudy.azureus2.ui.swt.mainwindow.Initializer.<init>(Initializer.java:102)
        at org.gudy.azureus2.ui.swt.Main.<init>(Main.java:80)
        at org.gudy.azureus2.ui.swt.Main.main(Main.java:203)
Caused by: java.lang.ClassNotFoundException: org.gnu.gtk.IconTheme
        at java.net.URLClassLoader$1.run(URLClassLoader.java:221)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:209)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:324)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:269)
        at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:337)
        ... 14 more

GUI Initializing took 80ms

(SWT:10602): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate
widget with width 250 and height -1


Version-Release number of selected component (if applicable):


How reproducible:

Everytime


Steps to Reproduce:
1. Install azureus (fresh install)
2. Run it
Comment 1 Lillian Angel 2008-01-16 17:39:29 EST
This will fix will be in updates soon



*** This bug has been marked as a duplicate of 428482 ***

Note You need to log in before you can comment on or make changes to this bug.