Bug 42850 - sessreg broken with high UID's
sessreg broken with high UID's
Status: CLOSED DUPLICATE of bug 63116
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.2
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-30 08:51 EDT by panu.matilainen
Modified: 2007-03-26 23:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-11 11:13:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to workaround the high uid problem (578 bytes, patch)
2002-03-26 10:16 EST, panu.matilainen
no flags Details | Diff

  None (edit)
Description panu.matilainen 2001-05-30 08:51:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.2-2smp i686; en-US; rv:0.9)
Gecko/20010507

Description of problem:
[xkg]dm login fails with very high UID's on default setup when sessreg
gets called from /etc/X11/xdm/Give|TakeConsole scripts

How reproducible:
Always

Steps to Reproduce:
1. useradd -u 10000000 highuid
2. passwd highuid
3. try to login from a xdm/gdm/kdm

	

Actual Results:  Login starts and then crashes out back to initial login
prompt.

Expected Results:  Default gnome-session should've started, and it works ok
for lower UID's.

Additional info:

This is easy to work around by commenting out the sessreg lines from
/etc/X11/xdm/Give|TakeConsole scripts, after which everything works as
expected. Also interestingly this doesn't appear to be a strict 16bit UID
limitation as the problem doesn't happen with UID=100000.
Comment 1 Mike A. Harris 2002-03-23 05:47:44 EST
Deferring for future investigation.
Comment 2 panu.matilainen 2002-03-26 09:45:07 EST
Since nobody else seems interested ;) I took a further look at this. There's
nothing fundamentally wrong with sessreg itself, the problem lies in the lastlog
mechanism/fileformat where the file grows too large for even 64bit offsets to
handle with big enough UIDs. Login & friends actually have the same problem but
it doesn't normally show up because it doesn't check for errors like sessreg does.
Comment 3 panu.matilainen 2002-03-26 10:16:04 EST
Created attachment 50464 [details]
patch to workaround the high uid problem
Comment 4 panu.matilainen 2002-03-26 10:19:29 EST
Soo typical.. just after posting the earlier comment I realized it's just not
using the 64bit interface. Attached patch works around it but that's the way to
do it - I guess this is just some kind of linking problem.

AND this affects every RH 7.x release, Skipjack included. Pretty please fix it
for Skipjack / whatever comes after it.
Comment 5 panu.matilainen 2002-04-10 04:35:04 EDT
Refiled this against skipjack2 and closing this one (I'm not expecting a fix for
the old releases..)
Comment 6 Mike A. Harris 2002-04-11 11:11:25 EDT
Just a note for the future...  Instead of opening a new report, you
can just update an existing report with new information, and update the
product/version instead if you prefer.  Either way is fine however.

Marking as a dupe of the new report, which is fixed in RAWHIDE
XFree86 4.2.0-6.63 and later.

Thanks.


*** This bug has been marked as a duplicate of 61136 ***
Comment 7 Mike A. Harris 2002-04-11 11:13:40 EDT
ARGH.  Closed as dupe of wrong bug.
Comment 8 Mike A. Harris 2002-04-11 11:14:23 EDT

*** This bug has been marked as a duplicate of 63116 ***

Note You need to log in before you can comment on or make changes to this bug.