Bug 61136 - latex2html with JA patch
latex2html with JA patch
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: tetex (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-13 22:29 EST by yamagata
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-18 19:51:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Here is a patch for rev. 1.62 (1.41 KB, patch)
2002-03-17 19:41 EST, yamagata
no flags Details | Diff

  None (edit)
Description yamagata 2002-03-13 22:29:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020310

Description of problem:
LaTeX2HTML included in the tetex-latex package is not applied a JA patch which
is avalable the following URL.
http://takeno.iee.niit.ac.jp/~shige/TeX/latex2html/ltx2html.html
If one writes a LaTeX text in Japanese, it is neccessary to apply the patch.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:

	

Additional info:
Comment 1 Tim Waugh 2002-03-14 06:15:13 EST
There are several patches on that page.  Which one is needed?  (If you could
supply a test case too, that would be great.)

Thanks.
Comment 2 yamagata 2002-03-14 19:38:17 EST
The patch, l2h-2K1b+jp1.4.patch.gz is needed for latex2html-2K.1beta.gar.gz(the
newest revison 1.62).
Comment 3 Tim Waugh 2002-03-15 11:00:19 EST
Patch doesn't apply cleanly to 1.62.  Even tried with fuzz 5.

Also, it changes the $default_language to Japanese!
Comment 4 yamagata 2002-03-17 19:41:13 EST
Created attachment 48824 [details]
Here is a patch for rev. 1.62
Comment 5 yamagata 2002-03-17 20:23:32 EST
`$default_language' may be changed in l2hconf.pm or ~/.latex2html-init.
Comment 6 Tim Waugh 2002-03-18 13:05:38 EST
Patch doesn't apply cleanly: there are offsets if I apply it before the original
patch, and it just plain doesn't apply if I try it after the original patch.

Please attach a complete tested patch, _or_ a simple test case so that I can
verify that it actually works at all.

> `$default_language' may be changed in l2hconf.pm or ~/.latex2html-init.

And so I will leave it how it currently is (english).
Comment 7 yamagata 2002-03-18 19:51:35 EST
Sorry for my no information.

$ ls
l2h-2K1b+jp1.4-fix-1.62.patch
l2h-2K1b+jp1.4.patch.gz
latex2html-2K.1beta.tar.gz
$ tar zxf latex2html-2K.1beta.tar.gz
$ cd latex2html-2K.1beta
$ zcat ../l2h-2K1b+jp1.4.patch.gz | patch -p1

We get a file latex2html.pin.rej.

$ patch -p1 <../l2h-2K1b+jp1.4-fix-1.62.patch
Comment 8 Tim Waugh 2002-03-21 16:22:25 EST
Patch rediffed and modified, and applied in 1.0.7-45.
Comment 9 Mike A. Harris 2002-04-11 11:11:19 EDT
*** Bug 42850 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.