Bug 428539 - gcl doesn't build on x86_64
gcl doesn't build on x86_64
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gcl (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Jerry James
Fedora Extras Quality Assurance
:
Depends On: 440913
Blocks: FE-ExcludeArch-x64/F-ExcludeArch-x64 427250
  Show dependency treegraph
 
Reported: 2008-01-12 20:09 EST by Alex Lancaster
Modified: 2009-01-21 16:34 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-21 16:33:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Lancaster 2008-01-12 20:09:19 EST
Currently doesn't seem to rebuild on rawhide:

http://koji.fedoraproject.org/koji/buildinfo?buildID=29978

Broken deps for i386
----------------------------------------------------------
        gcl - 2.6.7-15.fc8.i386 requires libtk8.4.so
        gcl - 2.6.7-15.fc8.i386 requires libtcl8.4.so
     

Seems to a problem not building with randomized sbrk.  I did a quick Google
search and it mentioned needing to "setarch i386":

checking for randomized sbrk... yes
checking for randomized brk remedy... no
Cannot build with randomized sbrk
error: Bad exit status from /var/tmp/rpm-tmp.87773 (%build)
Comment 1 Alex Lancaster 2008-01-15 07:41:03 EST
Looks like this has been build on rawhide now:

http://koji.fedoraproject.org/koji/buildinfo?buildID=31442

but had to exclude, x86_64 arch, so changing bug summary to be about that.
Comment 2 Bug Zapper 2008-05-14 00:45:38 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Alex Lancaster 2008-10-23 04:56:25 EDT
Is this package even being maintained anymore?  Looks like it currently fails to even build from source since April 2008: bug #440913.
Comment 4 Gérard Milmeister 2008-10-23 11:46:02 EDT
I can't get it to compile on any architectures, at least on the
build machine. At home on F-9 I compiled it successfully on
i386. Unfortunately I got no response for my request for
help :-(
Comment 5 Fedora Update System 2009-01-18 01:08:51 EST
gcl-2.6.8-0.1.20080902cvs.1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/gcl-2.6.8-0.1.20080902cvs.1.fc9
Comment 6 Fedora Update System 2009-01-18 01:08:58 EST
gcl-2.6.8-0.1.20080902cvs.1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/gcl-2.6.8-0.1.20080902cvs.1.fc10
Comment 7 Fedora Update System 2009-01-21 16:33:15 EST
gcl-2.6.8-0.1.20080902cvs.1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2009-01-21 16:34:27 EST
gcl-2.6.8-0.1.20080902cvs.1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.