Bug 440913 - FTBFS gcl-2.6.7-18.fc9
FTBFS gcl-2.6.7-18.fc9
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gcl (Show other bugs)
9
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jerry James
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
:
Depends On:
Blocks: FTBFS 428539 F10FTBFS
  Show dependency treegraph
 
Reported: 2008-04-04 13:13 EDT by FTBFS
Modified: 2009-01-21 16:34 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-21 16:33:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
root.log.bz2 (2.55 KB, application/x-bzip2)
2008-04-04 13:13 EDT, FTBFS
no flags Details
build.log.bz2 (13.76 KB, application/x-bzip2)
2008-04-04 13:13 EDT, FTBFS
no flags Details

  None (edit)
Description FTBFS 2008-04-04 13:13:17 EDT
gcl-2.6.7-18.fc9.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
Comment 1 FTBFS 2008-04-04 13:13:22 EDT
Created attachment 301182 [details]
root.log.bz2

root.log for i386
Comment 2 FTBFS 2008-04-04 13:13:23 EDT
Created attachment 301183 [details]
build.log.bz2

build.log for i386
Comment 3 Bug Zapper 2008-05-14 04:52:24 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Kevin Kofler 2008-07-19 19:12:56 EDT
Finished 
compiling /builddir/build/BUILD/gcl-2.6.7/unixport/../pcl/gcl_pcl_walk.o.
Loading binary of GCL_PCL_WALK...
0x8768000 0x8770fff
Error: Cannot mprotect
Fast links are on: do (si::use-fast-links nil) for debugging
Error signalled by OR.
Permission denied
Broken at LOAD.  Type :H for Help.

Something blocks the mprotect, maybe SELinux?
Comment 5 FTBFS 2008-09-05 12:11:28 EDT
This package has Failed to Build From Source for many months.  Per
http://fedoraproject.org/wiki/FTBFS, this package is now proposed for
removal from the distribution.  Please address this FTBFS bug
immediately, or this package will be removed from the distribution
within the next few weeks.

Thank you for your continued contributions to Fedora, and your
commitment to ensuring Fedora packages remain buildable from source
code.
Comment 6 Matt Domsch 2008-09-17 23:22:34 EDT
this needs to BR zlib-devel, and add -lz to the libs line in %setup.  However, doing so, it also needs -fno-stack-protector. :-(
http://lists.gnu.org/archive/html/gcl-devel/2008-08/msg00001.html

Not sure now much we want to filter that out of the default CFLAGS.  Stack protection is generally a good thing.  Of course, there hasn't been a release of this software since 2005...
Comment 7 Matt Domsch 2008-09-18 00:24:46 EDT
Starting program: /builddir/build/BUILD/gcl-2.6.7/unixport/matt_pre_gcl unixport/ -libdir /builddir/build/BUILD/gcl-2.6.7 < unixport/foo
GCL (GNU Common Lisp)  April 1994  131072 pages
Building symbol table for /builddir/build/BUILD/gcl-2.6.7/unixport/matt_pre_gcl ..

Program received signal SIGSEGV, Segmentation fault.
0x0811f757 in _bfd_elf_merge_symbol ()
(gdb) bt
#0  0x0811f757 in _bfd_elf_merge_symbol ()
#1  0x081283b5 in bfd_elf_link_add_symbols ()
#2  0x0807040f in build_symbol_table_bfd () at sfasli.c:45
#3  0x0808048c in gcl_init_init () at sys_pre_gcl.c:61
#4  0x0804d102 in main (argc=4, argv=0x0, envp=0x0) at main.c:407

not happy...
Comment 8 Matt Domsch 2008-09-18 00:56:55 EDT
jakub, gonna need your help on this one please...
Comment 9 Jan Kratochvil 2008-09-18 16:13:45 EDT
The crash is due to an incompatible API/ABI of recent libbfd (binutils package).

-------------------------------------------------------------------------------

GCL (GNU Common Lisp)  April 1994  131072 pages
Building symbol table for /home/jkratoch/redhat/fedora/gcl/devel/gcl-2.6.7/unixport/raw_pre_gcl ..

Program received signal SIGSEGV, Segmentation fault.
0x0812b069 in _bfd_elf_merge_symbol (abfd=0x8398f00, info=0x8389de0, name=0x83e0421 "keyword_package", sym=0x83c4000,
    psec=0xffffb0e0, pvalue=0xffffaf98, pold_alignment=0xffffb0b0, sym_hash=0x83b8008, skip=0xffffb07c, override=0xffffb0b8,
    type_change_ok=0xffffb0c0, size_change_ok=0xffffb0c4) at elflink.c:937
937       if (!(*bed->relocs_compatible) (abfd->xvec, info->output_bfd->xvec))
Missing separate debuginfos, use: debuginfo-install glibc.i686 ncurses.i386 readline.i386 zlib.i386
(gdb) bt
#0  0x0812b069 in _bfd_elf_merge_symbol (abfd=0x8398f00, info=0x8389de0, name=0x83e0421 "keyword_package", sym=0x83c4000,
    psec=0xffffb0e0, pvalue=0xffffaf98, pold_alignment=0xffffb0b0, sym_hash=0x83b8008, skip=0xffffb07c, override=0xffffb0b8,
    type_change_ok=0xffffb0c0, size_change_ok=0xffffb0c4) at elflink.c:937
#1  0x08130a8e in elf_link_add_object_symbols (abfd=0x8398f00, info=0x8389de0) at elflink.c:4061
#2  0x08132d3a in bfd_elf_link_add_symbols (abfd=0x8398f00, info=0x8389de0) at elflink.c:5086
#3  0x0806feca in build_symbol_table_bfd () at sfasli.c:45
#4  0x0808034f in gcl_init_init () at sys_pre_gcl.c:61
#5  0x0804c9e4 in main (argc=4, argv=0x458b14ec, envp=0xc453b08) at main.c:407
(gdb) p info->output_bfd->xvec
Cannot access memory at address 0x8
(gdb) p info->output_bfd
$6 = (bfd *) 0x0
(gdb) up
#1  0x08130a8e in elf_link_add_object_symbols (abfd=0x8398f00, info=0x8389de0) at elflink.c:4061
4061              if (!_bfd_elf_merge_symbol (abfd, info, name, isym, &sec,
(gdb) 
#2  0x08132d3a in bfd_elf_link_add_symbols (abfd=0x8398f00, info=0x8389de0) at elflink.c:5086
5086          return elf_link_add_object_symbols (abfd, info);
(gdb) 
#3  0x0806feca in build_symbol_table_bfd () at sfasli.c:45
45        if (!bfd_link_add_symbols(bself,&link_info))
(gdb) l
40          FEerror("I'm not an object",0);
41      /*    if (link_info.hash) */
42      /*      bfd_link_hash_table_free(bself,link_info.hash); */
43        if (!(link_info.hash = bfd_link_hash_table_create (bself)))
44          FEerror("Cannot make hash table",0);
45        if (!bfd_link_add_symbols(bself,&link_info))
46          FEerror("Cannot add self symbols\n",0);
47        if ((u=bfd_get_symtab_upper_bound(bself))<0)
48          FEerror("Cannot get self's symtab upper bound",0);
49    
(gdb) _

-------------------------------------------------------------------------------

One possibility is to port gcl for recent libbfd - therefore to either provide dummy OUTPUT_BFD or to even extend libbfd upstream to support back again reading symbols with no output bfd.

Still I would rather suggest to stick with the already bundled libbfd as gcl does seem to be no longer actively developed:
    --disable-statsysbfd --enable-locbfd

(Please also update ".cvsignore" and it would be nice to fix the build to pass `rpmbuild --target=i386' on x86_64 host - without mock.)
Comment 10 Fedora Update System 2009-01-18 01:08:54 EST
gcl-2.6.8-0.1.20080902cvs.1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/gcl-2.6.8-0.1.20080902cvs.1.fc9
Comment 11 Fedora Update System 2009-01-18 01:09:03 EST
gcl-2.6.8-0.1.20080902cvs.1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/gcl-2.6.8-0.1.20080902cvs.1.fc10
Comment 12 Fedora Update System 2009-01-21 16:33:22 EST
gcl-2.6.8-0.1.20080902cvs.1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2009-01-21 16:34:30 EST
gcl-2.6.8-0.1.20080902cvs.1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.