Bug 428587 - catalog doesn't rewrite xsl/current
catalog doesn't rewrite xsl/current
Status: CLOSED DUPLICATE of bug 428531
Product: Fedora
Classification: Fedora
Component: docbook-style-xsl (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-13 16:31 EST by Mark Wielaard
Modified: 2008-01-14 03:25 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-14 03:25:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
example docbook man file (4.71 KB, application/octet-stream)
2008-01-13 16:31 EST, Mark Wielaard
no flags Details

  None (edit)
Description Mark Wielaard 2008-01-13 16:31:18 EST
Description of problem:

When processing docbook manpages with xmlto the /etc/xml/catalog doesn't contain
the correct rewrite rules to process
http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl

Version-Release number of selected component (if applicable):

Known broken version docbook-style-xsl-1.73.2-4.fc8
Known working version docbook-style-xsl-1.73.2-2.fc8

How reproducible:

Always.

Steps to Reproduce:
1. Get attached example file from Frysk project (fsystest.8.tmp)
2. Run: xmlto man fsystest.8.tmp
  
Actual results:

$ xmlto man fsystest.8.tmp
I/O error : Attempt to load network entity
http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl
warning: failed to load external entity
"http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl"
compilation error: file /tmp/xmlto-xsl.cj2015 line 4 element import
xsl:import : unable to load
http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl

Expected results:

Nice error free transformation into fsystest.8 manpage.

Additional info:

The broken version of /etc/xml/catalog doesn't have the following rewrite rule:

<rewriteURI uriStartString="http://docbook.sourceforge.net/release/xsl/current"
rewritePrefix="file:///usr/share/sgml/docbook/xsl-stylesheets-1.73.2"/>
Comment 1 Mark Wielaard 2008-01-13 16:31:18 EST
Created attachment 291515 [details]
example docbook man file
Comment 2 Ondrej Vasik 2008-01-14 03:25:10 EST
In fact, problem is not in docbook-style-xsl-1.73.2-4.fc8 but in %postun of
docbook-style-xsl-1.73.2-3.fc8 (and appeared once docbook-style-xsl-1.73.2-4.fc8
came to stable). For details and workaround check comments in duplicate bugzilla
#428531 , sorry for troubles.

*** This bug has been marked as a duplicate of 428531 ***

Note You need to log in before you can comment on or make changes to this bug.