Bug 428531 - gtk-doc suddenly broken
Summary: gtk-doc suddenly broken
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: docbook-style-xsl
Version: 8
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Ondrej Vasik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 428587 429214 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-01-12 22:24 UTC by Dan Winship
Modified: 2008-01-24 21:57 UTC (History)
3 users (show)

Fixed In Version: 1.73.2-5.fc8
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-01-24 21:49:04 UTC


Attachments (Terms of Use)

Description Dan Winship 2008-01-12 22:24:54 UTC
gtk-doc is broken today:

cd ./html && gtkdoc-mkhtml libsoup ../libsoup-docs.sgml
I/O error : Attempt to load network entity
http://docbook.sourceforge.net/release/xsl/current/html/chunk.xsl
warning: failed to load external entity
"http://docbook.sourceforge.net/release/xsl/current/html/chunk.xsl"
compilation error: file /usr/share/gtk-doc/data/gtk-doc.xsl line 6 element import
xsl:import : unable to load
http://docbook.sourceforge.net/release/xsl/current/html/chunk.xsl
make: *** [html-build.stamp] Error 5


Fallout from yesterday's libxml2 update?

gtk-doc-1.8-2.fc7
libxml2-2.6.31-1.fc8
libxslt-1.1.22-1.fc8

Comment 1 Matthias Clasen 2008-01-12 23:40:58 UTC
I think I have seen this before. I believe that I found it to be caused by
broken registration of the docbook stylesheets. I forgot to file a bug about that...
Please check if the docbook-xsl stylesheets are registered and if they are not,
find the docbook-style-xsl maintainer.

Comment 2 Dan Winship 2008-01-14 02:53:10 UTC
ok, rerunning the postinstall script from docbook-style-xsl fixed it... but why
did it break?


Comment 3 Matthias Clasen 2008-01-14 04:19:58 UTC
dunno...not my package...

Comment 4 Ondrej Vasik 2008-01-14 08:20:54 UTC
Sorry for that, was caused by wrong %postun which deregistered catalogs
installed by docbook-style-xsl - it's known problem and was mentioned in the
update note. (See #389231 comments for details of problem) - problem is already
fixed for common updates from base F7 and F8 installation, fix for the rest
could be done by doubled update(which will not fix every installation).

As easy workaround yum erase/yum install docbook-style-xsl - or to force update
by docbook-style-xsl-1.73.2-4.fc8. Once more time, sorry for that, was not aware
enough to find that, because the error is caused by %postun
docbook-style-xsl-1.73.2-3.fc8 and occurs only when updating to newer package.

Comment 5 Ondrej Vasik 2008-01-14 08:25:11 UTC
*** Bug 428587 has been marked as a duplicate of this bug. ***

Comment 6 Ondrej Vasik 2008-01-18 09:28:12 UTC
*** Bug 429214 has been marked as a duplicate of this bug. ***

Comment 7 Colin Walters 2008-01-24 19:05:33 UTC
Note this bug breaks jhbuild.  Is there a way we could release an update which
forcibly regenerated the catalogs?

Comment 8 Ondrej Vasik 2008-01-24 21:28:49 UTC
I already pushed that to stable on Monday, so hopefully will be closed errata
automatically soon - koji is displaying update in stable since tuesday:
docbook-style-xsl-1.73.2-4.fc7 [bugfix] stable 0 2008-01-22 14:47:40
docbook-style-xsl-1.73.2-5.fc8 [bugfix] stable 0 2008-01-22 14:45:18

Those one should work automatically even from the broken 1.73.2-3.fc8 or
1.73.2-2.fc7 because I temporarily changed destdir. 

Comment 9 Fedora Update System 2008-01-24 21:49:02 UTC
docbook-style-xsl-1.73.2-5.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2008-01-24 21:57:55 UTC
docbook-style-xsl-1.73.2-4.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.