Bug 428607 - anaconda does not handle volume group or logical volumes with a dash in the name
anaconda does not handle volume group or logical volumes with a dash in the name
Status: CLOSED DUPLICATE of bug 430907
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.1
All Linux
low Severity low
: rc
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-14 00:39 EST by Michael Kearey
Modified: 2008-02-16 13:05 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-16 13:05:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Kearey 2008-01-14 00:39:38 EST
Description of problem:
Install RHEL5 update 1 using kickstart. Specify a volume group name like
'mkearey-vg'. After package dep resolution and filesystem is successfully
created, the installer fails with a traceback stating :

OSError: [Errno2] No such file or directory: '/dev/mapper/mkearey-vg-rootvol'

Looking at the state of the system at the time of the failure, there exists
/dev/mapper/mkearey--vg-rootvol

Version-Release number of selected component (if applicable):


How reproducible:

100%


Steps to Reproduce:
1. Create a kickstart with the following partition details:

partition /boot --fstype=ext3 --size=200
partition pv.00 --size=1000 --grow

volgroup mkearey-vg pv.00

logvol / --fstype ext3 --vgname=mkearey-vg --name=rootvol --size=1000 --grow
logvol swap --fstype swap --name=swapvol --vgname=mkearey-vg --size=1000 --grow
--maxsize=2000

2. Begin the install, using ks=PATH_TO_KICKSTART_FILE 

  
Actual results:

anaconda python traceback including:
OSError: [Errno2] No such file or directory: '/dev/mapper/mkearey-vg-rootvol'

Expected results:
Clean install where dashes are allowed in both volume group and logical volume
names, and handled properly by anaconda
 
Additional info:

This problem is likely to affect all releases of RHEL5 not just update 1.
Comment 1 Michael Kearey 2008-01-14 00:40:45 EST
Note https://bugzilla.redhat.com/show_bug.cgi?id=407701 is equivalent bug from
Fedora 8
Comment 2 Chris Lumens 2008-02-16 13:05:56 EST
Duping to a future bug where a patch is discussed.

*** This bug has been marked as a duplicate of 430907 ***

Note You need to log in before you can comment on or make changes to this bug.