Bug 428659 - Package installer one-time exception. Can't check package to install. Component: pirut; Summary: TB91835f44 GroupSelector.py:211:_pkgToggled:TypeError
Package installer one-time exception. Can't check package to install. Compone...
Status: CLOSED DUPLICATE of bug 336791
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
8
i586 Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-14 08:50 EST by Štefan
Modified: 2008-01-14 10:46 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-14 10:46:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Štefan 2008-01-14 08:50:00 EST
Description of problem:
Can't select packages to install, unhandled exception occurs once.

Version-Release number of selected component (if applicable):
Fedora 8 on 3,3G DVD available at 
ftp://ftp.linux.cz/pub/linux/fedora/linux/releases/8/Fedora/i386/iso/

How reproducible:
Sorry, don't know. I relaunched package installer and no exception occurred.
Before, while downloading updates I lost WAN connection (LAN was still up) and
the downloader stopped responding for a long time. Maybe for unexpected exit it
has left inconsistent configuration.

Steps to Reproduce:

(1. Install Fedora 8, select Czech language, newly created partitions, with
default set of packages for office use, development and web server.)

2. After first login download updates and make WAN unavailable while downloading
is in the middle (don't shut down LAN). If not responding for a long time (5
minutes), force quit.
3. Run Applications - Add/Remove programs from Fedora top menu on GNOME desktop.
Before shutting LAN down and back up and making WAN available you may get access
conflict error (some other application is getting info of installed software).
4. In package manager select GNOME, open list of packages and check
avant-window-navigator. This action made the exception.
  
Actual results:
Exception (see below)

Expected results:
The check box to check

Additional info:

Component: pirut
Summary: TB91835f44 GroupSelector.py:211:_pkgToggled:TypeError:
GtkTreeModel.get_iter_from_string() argument 1 must be string, not tuple

Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/pirut/GroupSelector.py", line 208, in
_rowToggle
    self._pkgToggled(None, path)
  File "/usr/lib/python2.5/site-packages/pirut/GroupSelector.py", line 211, in
_pkgToggled
    i = self.pkgstore.get_iter_from_string(path)
TypeError: GtkTreeModel.get_iter_from_string() argument 1 must be string, not tuple

Local variables in innermost frame:
path: (2,)
widget: None
self: <pirut.GroupSelector.OptionalPackageSelector instance at 0xc66c94c>
Comment 1 Jeremy Katz 2008-01-14 10:46:56 EST

*** This bug has been marked as a duplicate of 336791 ***

Note You need to log in before you can comment on or make changes to this bug.