Bug 428660 - kernel 2.6.23.9-85.fc8 is missing zd1211rw
kernel 2.6.23.9-85.fc8 is missing zd1211rw
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 428580 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-14 09:04 EST by Hans de Goede
Modified: 2008-02-06 15:07 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.6.23.14-115.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-06 15:07:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2008-01-14 09:04:15 EST
Description of problem:
As stated in the summary kernel 2.6.23.9-85.fc8 is missing zd1211rw, making it
impossible to use wireless usb dongles using this chipset with this kernel

Also it seems that FC-7 has a newer kernel then F-8, it currently has a
2.6.13.12 based kernel (or it seems), this kernel does include zd1211rw.
Comment 1 John W. Linville 2008-01-14 09:28:23 EST
Actually -85.fc8 has zd1211rw, but it does not have zd1211rw-mac80211.  
Starting with -86.fc8 there is a MODULE_ALIAS for zd1211rw-mac80211 in the 
zd1211rw module, resolving this issue.  It is unfortunate that -85.fc8 got 
pushed to updates instead of -86.fc8, and even more unfortunate that there has 
been no update since.  (How does that process work anyway?)

Using any F8 kernel available in Koji with a version later than -85.fc8 should 
resolve this issue.
Comment 2 Hans de Goede 2008-01-16 11:22:15 EST
(In reply to comment #1)
> Actually -85.fc8 has zd1211rw, but it does not have zd1211rw-mac80211.  

No it doesn't (I think):
[hans@localhost ~]$ cd /lib/modules/2.6.23.9-85.fc8/
[hans@localhost 2.6.23.9-85.fc8]$ find -name '*zd1112rw*'
[hans@localhost 2.6.23.9-85.fc8]$

> Starting with -86.fc8 there is a MODULE_ALIAS for zd1211rw-mac80211 in the 
> zd1211rw module, resolving this issue.

This shouldn't be necessary, its an usb device and should get autoloaded on its
usb id's whatever the name, it seems that neither version of the module is
present in 2.6.23.9-85.fc8 .

Comment 3 John W. Linville 2008-01-16 12:30:46 EST
Yes I was mistaken about -85 having zd1211rw.  Still, the point remains -- use 
a later kernel.
Comment 4 Hans de Goede 2008-01-16 13:52:17 EST
(In reply to comment #3)
> Yes I was mistaken about -85 having zd1211rw.  Still, the point remains -- use 
> a later kernel.

I didn't report this for myself, but on behalf of a college of mine who had this
problem. For him a less experienced Fedora user, doing so is less then trivial
if such a kernel is not available from updates. Sure I can help him, but there
are bound to be lots of other people bitten by this. Any chance we could get a
fixed kernel out? For example -86 (assuming that has fixing this as only change,
and thus little chance of causing other issues).

As for your question in comment 1 how the update process work, normally one goes to:
https://admin.fedoraproject.org/updates/new/

Logs in with once Fedora Account System account and creates the update, how this
goes for the kernel with regard to coordinating this with the other Fedora
kernel developers/maintainers I do not know.
Comment 5 Chuck Ebbert 2008-01-22 19:42:28 EST
2.6.23.14-115 is in testing now and this should be fixed in that version.
Comment 6 Chuck Ebbert 2008-01-22 19:43:23 EST
*** Bug 428580 has been marked as a duplicate of this bug. ***
Comment 7 Hans de Goede 2008-01-23 05:12:38 EST
I can confirm that the module is back in 2.6.23.14-115, I downloaded it from
koji though as:
http://download.fedora.redhat.com/pub/fedora/linux/updates/testing/8/i386/

And mirrors, don't have it yet.

Note You need to log in before you can comment on or make changes to this bug.