Bug 428580 - zd1211rw driver is omitted
zd1211rw driver is omitted
Status: CLOSED DUPLICATE of bug 428660
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
: 429392 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-13 14:33 EST by David A. De Graaf
Modified: 2008-02-02 05:21 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-22 19:43:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David A. De Graaf 2008-01-13 14:33:13 EST
Description of problem:
The zd1211rw driver is needed to support my new Belkin Wireless USB adapter.
It's been there, working; now it's gone.


Version-Release number of selected component (if applicable):
kernel-2.6.23.9-85.fc8

How reproducible:
It's not there!


Steps to Reproduce:
1.  Plug in USB adapter; note that the kernel sees a new USB device.
2.  Run ifup wlan0
3.  Error message:  Device wlan0 does not seem to be present.
  
Actual results:
Delaying initialization.

Expected results:
Activation and connection.

Additional info:

What's going on with the zd1211rw driver?
In Fedora 8 it is omitted entirely from the latest kernel-2.6.23.9-85.fc8
The immediately prior kernel provides
./2.6.23.8-63.fc8/kernel/drivers/net/wireless/zd1211rw-mac80211/zd1211rw-
mac80211.ko
which works fine on an i386 system.

On Fedora 7, x86_64, the penultimate kernel, 2.6.23.8-34.fc7, provides
zd1211rw-mac80211.ko, while the ultimate kernel, 2.6.23.12-52.fc7,
has switched to zd1211rw.ko.  Unfortunately neither seems to work on my
x86_64 system.

I recently purchased a Belkin Wireless G USB network adapter, part No.
F5D7050, and was pleased to find it was supported by the zd1211rw
driver.  However, there seems to be some churning with this software
and I am dismayed to see that only some combinations of kernel and
driver seem usable.

I hope the omission from kernel-2.6.23.9-85.fc8 was merely inadvertent.
Can it be restored?
Comment 1 Nicolas Chauvet (kwizart) 2008-01-13 15:09:04 EST
you are true!
Thx for reporting this.. Actually you have reported it to the wrong component
(firmware instead of the kernel).

But later kernels have it re-enabled. So i suggest to use koji to get a newer
kernel (there is no newer kernel in updates-testing for now) or take an older one..
Comment 2 John W. Linville 2008-01-15 10:06:09 EST
Upstream the zd1211rw transformed into what had been the zd1211rw-mac80211.  
Unfortunately I flubbed the configuration when moving this change into the F8 
kernels starting at -80.fc8.

As kwizart suggests, this was resolved starting with the -86.fc8 kernel.  As 
soon as any newer version becomes available in updates we should see this 
issue no more...

In the meantime, I suggest using a kernel from Koji:

   http://koji.fedoraproject.org/koji/buildinfo?buildID=31090
Comment 3 Chuck Ebbert 2008-01-22 19:43:22 EST

*** This bug has been marked as a duplicate of 428660 ***
Comment 4 Nicolas Chauvet (kwizart) 2008-02-02 05:21:01 EST
*** Bug 429392 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.