Bug 428708 - [RHEL5 U2] Kernel panic - not syncing: Attempted to kill init!
[RHEL5 U2] Kernel panic - not syncing: Attempted to kill init!
Status: CLOSED DUPLICATE of bug 428945
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.2
All Linux
high Severity high
: rc
: ---
Assigned To: Jeff Garzik
Martin Jenner
http://rhts.lab.boston.redhat.com/cgi...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-14 14:08 EST by Jeff Burke
Modified: 2008-02-11 19:28 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-24 16:02:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Burke 2008-01-14 14:08:33 EST
Description of problem:
While trying to boot the 2.6.18-68.el5 x86_64 kernel on
nec-em12.rhts.boston.redhat.com. The system panics. It can't find a root files
system.

Version-Release number of selected component (if applicable):
2.6.18-68.el5

How reproducible:
Unknown

Steps to Reproduce:
1. Install RHEL5.U1 x86_64 on nec-em12.rhts.boston.redhat.com
2. Install 2.6.18-68.el5
3. Reboot into new kernel
  
Actual results:
Loading megaraid_mm.ko module
megaraid cmm: 2.20.2.7 (Release Date: Sun Jul 16 00:01:03 EST 2006)
Loading megaraid_mbox.ko module
megaraid: 2.20.5.1 (Release Date: Thu Nov 16 15:32:35 EST 2006)
megaraid: probe new device 0x1000:0x1960:0x1000:0x0520: bus 3:slot 1:func 0
GSI 21 sharing vector 0x3A and IRQ 21
ACPI: PCI Interrupt 0000:03:01.0[A] -> GSI 24 (level, low) -> IRQ 58
megaraid: fw version:[1N41] bios version:[G119]
scsi0 : LSI Logic MegaRAID driver
scsi[0]: scanning scsi channel 0 [Phy 0] for non-raid devices
scsi[0]: scanning scsi channel 1 [virtual] for logical drives
Loading dm-mod.ko module
device-mapper: uevent: version 1.0.3
device-mapper: ioctl: 4.11.5-ioctl (2007-12-12) initialised: dm-devel@redhat.com
Loading dm-mirror.ko module
Loading dm-zero.ko module
Loading dm-snapshot.ko module
Waiting for driver initialization.
Scanning and configuring dmraid supported devices
Scanning logical volumes
  Reading all physical volumes.  This may take a while...
  No volume groups found
Activating logical volumes
  Volume group "VolGroup00" not found
Trying to resume from /dev/VolGroup00/LogVol01
Unable to access resume device (/dev/VolGroup00/LogVol01)
Creating root device.
Mounting root filesystem.
mount: could not find filesystem '/dev/root'
Setting up other filesystems.
Setting up new root fs
Kernel panic - not syncing: Attempted to kill init!
setuproot:  moving /dev fail

Expected results:
This should boot normally

Additional info:
Link to a successful boot of nec-em12.rhts.boston.redhat.com with RHEL5.U1
http://rhts.lab.boston.redhat.com/cgi-bin/rhts/test_log.cgi?id=1599407
This was not seen on all systems. I believe it has to do with the configuration
of this system.
Comment 1 Milan Broz 2008-01-14 15:17:41 EST
It seems that there is no physical device with lvm metadata.
Unfotunately there is no full log.

See link to successful log:
...
SCSI device sda: drive cache: write back
 sda: sda1 sda2
sd 1:0:0:0: Attached scsi disk sda
...

Is this SATA disk correctly detected in this kernel boot too ?
Comment 2 Don Zickus 2008-01-14 15:26:44 EST
doh!  missed that.  I did bring in the giant sata rebase with this kernel too,
that might be the cause.  Thanks.
Comment 3 Don Zickus 2008-01-14 15:29:46 EST
A link to the boot log can be found below under URL
Comment 5 Linda Wang 2008-01-24 16:02:31 EST

*** This bug has been marked as a duplicate of 428945 ***

Note You need to log in before you can comment on or make changes to this bug.