This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 428945 - rhel5.2 sata driver update patch caused kernel panic
rhel5.2 sata driver update patch caused kernel panic
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.2
All Linux
medium Severity medium
: beta
: ---
Assigned To: Jeff Garzik
Martin Jenner
:
: 428708 429418 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-16 04:10 EST by CAI Qian
Modified: 2008-05-21 11:06 EDT (History)
5 users (show)

See Also:
Fixed In Version: RHBA-2008-0314
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:06:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
cpuinfo (1.23 KB, text/plain)
2008-01-16 04:10 EST, CAI Qian
no flags Details
Dmesg for successfully booting -67 kernel (20.95 KB, text/plain)
2008-01-16 04:12 EST, CAI Qian
no flags Details
dmidecode (13.00 KB, text/plain)
2008-01-16 04:12 EST, CAI Qian
no flags Details
fstab (490 bytes, text/plain)
2008-01-16 04:12 EST, CAI Qian
no flags Details
dumpe2fs on root partition /dev/hda1 (187.10 KB, text/plain)
2008-01-16 04:13 EST, CAI Qian
no flags Details
lspci (1.89 KB, text/plain)
2008-01-16 04:13 EST, CAI Qian
no flags Details
lspci -vvvxxx (30.63 KB, text/plain)
2008-01-17 20:31 EST, CAI Qian
no flags Details

  None (edit)
Description CAI Qian 2008-01-16 04:10:38 EST
Description of problem:
While booting kernel 2.6.18-68.el5 on lenovo ThinkCentre machine, the kernel
panic. However, there is no problem for kernel 2.6.18-67.el5. I have verified
the panic is caused by patch,

- [sata] rhel5.2 driver update (Jeff Garzik ) [184884 307911]

...
Waiting for driver initialization.
Scanning and configuring dmraid supported.
Trying to resume from LABEL=SWAP-hda2
hda: status timeout: status = 0xff { BUSY }
ide: failed opcode was: unknown
hda: drive not ready for command.
ide0: reset time-out. status = 0xff
hda: status timeout: status = 0xff { BUSY }
ide: failed opcode was: unknown
hda: drive not ready for command.
end_request: I/O error, dev hda, sector 156312448
end_request: I/O error, dev hda, sector 156312448
end_request: I/O error, dev hda, sector 0
end_request: I/O error, dev hda, sector 8
end_request: I/O error, dev hda, sector 16
end_request: I/O error, dev hda, sector 24
end_request: I/O error, dev hda, sector 32
end_request: I/O error, dev hda, sector 40
end_request: I/O error, dev hda, sector 48
end_request: I/O error, dev hda, sector 56
end_request: I/O error, dev hda, sector 0
mount: could not find filesystem '/dev/root'
setting up other filesystems.
setting up new root fs.
setuproot: moving /dev failed: No such file or directory.
no fstab.sys, mounting internal defaults.
setuproot: error mounting /proc: No such file or directory.
setuproot: error mounting /sys: No such file or directory.
Switching to new root and running init.
unmounting old /dev
unmounting old /proc
unmounting old /sys
Switchroot: mount failed: No such file or directory.
Kernel Panic - not syncing: Attempted to kill init.

How reproducible:
Always
Comment 1 CAI Qian 2008-01-16 04:10:38 EST
Created attachment 291833 [details]
cpuinfo
Comment 2 CAI Qian 2008-01-16 04:12:07 EST
Created attachment 291834 [details]
Dmesg for successfully booting -67 kernel
Comment 3 CAI Qian 2008-01-16 04:12:26 EST
Created attachment 291835 [details]
dmidecode
Comment 4 CAI Qian 2008-01-16 04:12:44 EST
Created attachment 291836 [details]
fstab
Comment 5 CAI Qian 2008-01-16 04:13:28 EST
Created attachment 291837 [details]
dumpe2fs on root partition /dev/hda1
Comment 6 CAI Qian 2008-01-16 04:13:44 EST
Created attachment 291838 [details]
lspci
Comment 7 Jay Turner 2008-01-17 07:13:24 EST
Proposing for 5.2 beta blocker.  Recently introduced regression apparently
related to the SATA update, so definitely want to kill this one off as quickly
as possible.  QE ack for RHEL5.2 Beta Blocker.
Comment 8 RHEL Product and Program Management 2008-01-17 09:27:36 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 9 Jeff Garzik 2008-01-17 11:54:07 EST
Please provide full 'lspci -vvvxxx' as root.
Comment 10 CAI Qian 2008-01-17 20:31:46 EST
Created attachment 292095 [details]
lspci -vvvxxx
Comment 13 Aristeu Rozanski 2008-01-24 11:03:26 EST
*** Bug 429418 has been marked as a duplicate of this bug. ***
Comment 14 Linda Wang 2008-01-24 16:02:33 EST
*** Bug 428708 has been marked as a duplicate of this bug. ***
Comment 15 Mike Gahagan 2008-01-25 10:30:42 EST
I found another boot failure on ibm-x3200m2-01.rhts.boston.redhat.com with the
-74 kernel:

http://rhts.lab.boston.redhat.com/cgi-bin/rhts/test_log.cgi?id=1758845
Comment 16 Don Zickus 2008-01-25 13:25:16 EST
in 2.6.18-75.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5
Comment 18 Joshua Giles 2008-02-25 10:01:24 EST
Generic tests exercising the software stack related to SATA devices passed.
Comment 20 errata-xmlrpc 2008-05-21 11:06:37 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0314.html

Note You need to log in before you can comment on or make changes to this bug.