Bug 428845 - fence_ilo can not recognize option="off" but fence_wti can
fence_ilo can not recognize option="off" but fence_wti can
Status: CLOSED DUPLICATE of bug 433536
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cman (Show other bugs)
5.1
All Linux
medium Severity medium
: rc
: ---
Assigned To: Marek Grac
GFS Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-15 11:23 EST by Ryan McCabe
Modified: 2009-04-16 18:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-12 10:12:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ryan McCabe 2008-01-15 11:23:02 EST
+++ This bug was initially created as a clone of Bug #428243 +++

Description of problem:

I have a cluster system on my lab with WTI fencing device. At that time, I add
an fence_method option "option=off" to the cluster.conf, so the fencing action
will power off the destinate server instead of reboot it.

This is fence option:
<device name="wti" port="6" option="off"/>
Please refer to attached file for the original file cluster.conf. 


But when I use the same option on fence_ilo, it doesn't work. This is the error.

  agent "fence_ilo" reports: parse error: unknown option "option=off" 

My question is:

I found fence_ilo can work with method option : action="off", 

This option is not hardware-related, can we make it identical on all fence_*

Version-Release number of selected component (if applicable):

RHCS 4 & RHCS 5 both have the issue.

How reproducible:

Install a RHEL4/5 cluster system on HP system. to use fence_ilo as fence device.

Add the method option "option="off"" to fence_ilo and make it active.

fence_node node1

  
Actual results:

Fence failed to work.

Expected results:

fence_ilo can work well

Additional info:

-- Additional comment from jzhenyon@redhat.com on 2008-01-10 04:17 EST --
Created an attachment (id=291248)
cluster conf file


-- Additional comment from rmccabe@redhat.com on 2008-01-15 11:16 EST --
As a workaround, you can use action="off" but I'll fix the script to take either
action or option.
Comment 1 Marek Grac 2008-03-12 10:12:31 EDT
We will accept both of them, proposed patch is in #433536

*** This bug has been marked as a duplicate of 433536 ***

Note You need to log in before you can comment on or make changes to this bug.