Bug 433536 - fence_ilo uses odd parameter name for host address
fence_ilo uses odd parameter name for host address
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cman (Show other bugs)
5.3
All Linux
low Severity low
: rc
: ---
Assigned To: Marek Grac
GFS Bugs
:
: 428845 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-19 16:48 EST by Jim Parsons
Modified: 2009-04-16 18:57 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:52:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (718 bytes, patch)
2008-03-12 10:09 EDT, Marek Grac
no flags Details | Diff

  None (edit)
Description Jim Parsons 2008-02-19 16:48:08 EST
Description of problem:
fence_ilo param for device address uses the 'hostname' attr unlike all other
fence agents that use the 'ipaddr' attr.

All agents should support a consistent attribute set.

This issue exists with the fence_ilo 'action' attr as well, while all other
fence agents use 'option'.
Comment 1 Jim Parsons 2008-02-27 09:22:28 EST
Marc, I was thinking we should just add support for the ipaddr and option params
in the stdin arg parser.
Comment 2 Marek Grac 2008-03-12 10:09:35 EDT
Created attachment 297770 [details]
Proposed patch

Add support for stdin option 'ipaddr' and 'option'. I have found out that DRAC
fencing agent is also using the 'option' instead of 'action'
Comment 3 Marek Grac 2008-03-12 10:12:33 EDT
*** Bug 428845 has been marked as a duplicate of this bug. ***
Comment 4 Marek Grac 2008-05-20 06:09:43 EDT
Fixed in RHEL5 branch
Comment 8 errata-xmlrpc 2009-01-20 16:52:42 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0189.html

Note You need to log in before you can comment on or make changes to this bug.