Bug 428878 - Booting installer with "ip=dhcp" causes crash in libdhcp
Booting installer with "ip=dhcp" causes crash in libdhcp
Status: CLOSED DUPLICATE of bug 428870
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-15 15:40 EST by Will Woods
Modified: 2008-01-24 14:32 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-15 15:47:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Will Woods 2008-01-15 15:40:47 EST
With anaconda 11.4.0.21 (rawhide 20080115), booting the installer with 'ip=dhcp'
on the commandline results in a crash in libdhcp4client's next_iface() function.

The traceback looks vaguely like this:

(clumens says he's got it partially figured out and doesn't need the trace
details, so this is just for the historical record.)

loaderSegvHandler
fgets
next_iface
discover_interfaces
dhcpv4_client
do_dhcpv4
[etc]
Comment 1 Will Woods 2008-01-15 15:47:54 EST
Duh. Shame on me for failing to check bugzilla before filing a new bug.

*** This bug has been marked as a duplicate of 428870 ***
Comment 2 Josh Boyer 2008-01-24 14:32:20 EST
duplicate bug on F9 Alpha tracker is confusicating me

Note You need to log in before you can comment on or make changes to this bug.