Bug 428870 - /sbin/loader segfault - /lib/libdhcp4client-4.0.so.0(next_iface+0x80)[0xfbda990]
Summary: /sbin/loader segfault - /lib/libdhcp4client-4.0.so.0(next_iface+0x80)[0xfbda990]
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: dhcp   
(Show other bugs)
Version: rawhide
Hardware: powerpc
OS: Linux
high
low
Target Milestone: ---
Assignee: David Cantrell
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 428878 429066 (view as bug list)
Depends On:
Blocks: F9Alpha
TreeView+ depends on / blocked
 
Reported: 2008-01-15 19:54 UTC by James Laska
Modified: 2013-09-02 06:23 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-16 00:30:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
check return values (642 bytes, patch)
2008-01-15 20:02 UTC, Chris Lumens
no flags Details | Diff

Description James Laska 2008-01-15 19:54:13 UTC
Description of problem:

Fedora rawhide-20080115/ppc segfault while enabling network

Version-Release number of selected component (if applicable):

rawhide-20080115 (anaconda-11.4.0.21-1)

How reproducible:

100%

Steps to Reproduce:
1. Boot installer with ksdevice=link ip=dhcp
method=http://../rawhide-20080115/ppc/os
2. Select lang=en, keymap=us
3. Select eth0 as network device
  
Actual results:

Welcome to Fedora for ppc

           +-------------------------------------------------------+            
           |                                                       |            
           | Sending request for IP information for eth0...        |            
           |                                                       |            
           +-------------------------------------------------------+            
                                                                                

loader received SIGSEGV!  Backtrace:                                           
/sbin/loader(loaderSegvHandler+0xa0)[0x10008d80]
[0x100364]
[0xf7ff8000]
/lib/libdhcp4client-4.0.so.0(next_iface+0x80)[0xfbda990]
/lib/libdhcp4client-4.0.so.0(discover_interfaces+0x490)[0xfbdbfd0]
/lib/libdhcp4client-4.0.so.0(dhcpv4_client+0x408)[0xfbcabe8]
/lib/libdhcp-1.99.so.1(do_dhcpv4+0x3c)[0xfce8edc]
/lib/libdhcp-1.99.so.1[0xfceaf48]
/lib/libdhcp-1.99.so.1(dhcp_nic+0x5c)[0xfceb47c]
/lib/libdhcp-1.99.so.1(pumpDhcpClassRun+0x158)[0xfcf3d98]
/sbin/loader(doDhcp+0xfc)[0x1001c80c]
/sbin/loader(configureTCPIP+0x864)[0x1001e984]
/sbin/loader(readNetConfig+0x4c8)[0x1001f108]
/sbin/loader(main+0x1788)[0x1000ae88]
/lib/libc.so.6[0xf7b88dc]
/lib/libc.so.6[0xf7b8aac]
install exited abnormally [1/1] 
sending termination signals...done
sending kill signals...done
disabling swap...
unmounting filesystems...
        /proc done
        /dev/pts done
        /sys done
you may safely reboot your system

Expected results:

No segfault

Additional info:

Booting with *no* kickstart and *no* cmdline arguments works without a problem.
 I can then do a DHCP URL (http) installation.

Comment 1 Chris Lumens 2008-01-15 19:59:45 UTC
On tty3:

ERROR    : Error opening '/proc/net/if_inet6' to list IPv6 interfaces; No such
file or directory
CRITICAL : Can't get list of interfaces.

I don't know why it can't open that file.  The segfault seems to be a direct
result of not checking the file pointer being passed to fgets.  Patch to follow.

Comment 2 Chris Lumens 2008-01-15 20:02:08 UTC
Created attachment 291735 [details]
check return values

Comment 3 Chris Lumens 2008-01-15 20:05:06 UTC
Whoops, in that second case I of course mean ifaces->fp6.

Comment 4 Will Woods 2008-01-15 20:47:55 UTC
*** Bug 428878 has been marked as a duplicate of this bug. ***

Comment 5 Will Woods 2008-01-16 21:11:46 UTC
Should be fixed in the next anaconda build (which would be 10.4.0.22).

Comment 6 Chris Lumens 2008-01-17 02:30:19 UTC
*** Bug 429066 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.