Bug 428983 - SDL_pulseaudio_hack.sh doesn't work if you have more than one architecture
SDL_pulseaudio_hack.sh doesn't work if you have more than one architecture
Status: CLOSED DUPLICATE of bug 428577
Product: Fedora
Classification: Fedora
Component: SDL (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-16 11:16 EST by JM
Modified: 2008-01-17 09:16 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-17 09:16:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description JM 2008-01-16 11:16:50 EST
The SDL_pulseaudio_hack.sh in the SDL-1.2.12-5.fc8 RPM doesn't work when you use
more then architecture (e.g. i386 and x86_64), the problem is this line in the
script:

[ -e /usr/lib*/alsa-lib/libasound_module_pcm_pulse.so ] && export
SDL_AUDIODRIVER=esd

This line gets two results for
"/usr/lib*/alsa-lib/libasound_module_pcm_pulse.so" when you install the 32bit
and the 64bit version of the "alsa-plugins-pulseaudio" RPM (for example skype
needs the 32bit alsa-plugins-pulseaudio RPM on a 64bit system) and when you get
more then two results the scripts fails with the message (every single time you
open a shell):

bash: [: /usr/lib64/alsa-lib/libasound_module_pcm_pulse.so: binary operator expected

I changed the line to this:

[ -e /usr/lib64/alsa-lib/libasound_module_pcm_pulse.so -o -e
/usr/lib/alsa-lib/libasound_module_pcm_pulse.so ] && export SDL_AUDIODRIVER=esd

this way it works at least for i386 and x86_64.
Comment 1 JM 2008-01-16 11:23:26 EST
Btw. I'm not alone with this problem, as you can see here
http://forum.fedoraforum.org/showthread.php?t=176265
Comment 2 Thomas Woerner 2008-01-17 09:16:40 EST

*** This bug has been marked as a duplicate of 428577 ***

Note You need to log in before you can comment on or make changes to this bug.